aboutsummaryrefslogtreecommitdiff
path: root/games/xabacus
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:30:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:30:39 +0000
commit5686389b98212013d2237391a648219657c62e33 (patch)
treefe6db22cb1d5aba4a7fb07e491a9a0692329a485 /games/xabacus
parentad97fa692379193ccbe030259a613dfa6814fb33 (diff)
downloadports-5686389b98212013d2237391a648219657c62e33.tar.gz
ports-5686389b98212013d2237391a648219657c62e33.zip
- Update to version 8.0.0
- Convert to USES - Convert to OPTIONS helper PR: 188355 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=352213
Diffstat (limited to 'games/xabacus')
-rw-r--r--games/xabacus/Makefile45
-rw-r--r--games/xabacus/distinfo4
-rw-r--r--games/xabacus/pkg-plist12
3 files changed, 39 insertions, 22 deletions
diff --git a/games/xabacus/Makefile b/games/xabacus/Makefile
index f03e17373da1..eb90275b6116 100644
--- a/games/xabacus/Makefile
+++ b/games/xabacus/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xabacus
-PORTVERSION= 7.7.1
+PORTVERSION= 8.0.0
CATEGORIES= games
MASTER_SITES= http://www.tux.org/~bagleyd/abacus/ \
http://ftp.tux.org/pub/tux/bagleyd/xabacus/
@@ -12,31 +12,38 @@ COMMENT= Abacus for X Window System
LICENSE= BSD
-OPTIONS_DEFINE= MOTIF ESOUND
-OPTIONS_DEFAULT= MOTIF
-
-USE_BZIP2= yes
+USES= tar:bzip2
USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-nas
+INSTALLS_ICONS= yes
-MOTIF_USES= motif
-MOTIF_CONFIGURE_WITH= motif
+DESKTOP_ENTRIES="XAbacus" "" "abacus" "${PORTNAME}" "" ""
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= ESOUND MOTIF
+OPTIONS_DEFAULT= MOTIF
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-CONFIGURE_ARGS+= --without-rplay --with-esound
-.else
-LIB_DEPENDS+= librplay.so:${PORTSDIR}/audio/rplay
-CONFIGURE_ARGS+= --with-rplay --without-esound
-.endif
+ESOUND_LIB_DEPENDS_OFF= librplay.so:${PORTSDIR}/audio/rplay
+ESOUND_USE= gnome=esound
+ESOUND_CONFIGURE_ON= --without-rplay --with-esound
+ESOUND_CONFIGURE_OFF= --with-rplay --without-esound
+ESOUND_LDFLAGS= -L${LOCALBASE}/lib -laudiofile
+MOTIF_USES= motif
+MOTIF_CONFIGURE_WITH= motif
post-patch:
- @${REINPLACE_CMD} -e 's|/games/|/|g' ${WRKSRC}/Makefile.in
-
-post-configure:
- @${REINPLACE_CMD} -e '/^XWIDGETLDFLAGS/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|\($$(datadir)\)/games|\1| ; \
+ s|@XWIDGETLDFLAGS@|@LDFLAGS@| ; \
+ s|\([[:blank:]]\)/usr/games|\1$$(DESTDIR)$$(bindir)| ; \
+ /chmod/s|^|#| ; \
+ /chown/s|^|#|' ${WRKSRC}/Makefile.in
+
+post-install:
+.for i in 16 22 24 32 48
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ (cd ${WRKSRC}/pixmaps/${i}x${i} && ${INSTALL_DATA} abacus.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps)
+.endfor
.include <bsd.port.mk>
diff --git a/games/xabacus/distinfo b/games/xabacus/distinfo
index 20479632b9bc..3acd9a962d05 100644
--- a/games/xabacus/distinfo
+++ b/games/xabacus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xabacus-7.7.1.tar.bz2) = f5d409b62dbbe8e4dc091f4c4b9823edb85a4f4b6286505a0eb2cf5bf6945fd1
-SIZE (xabacus-7.7.1.tar.bz2) = 296037
+SHA256 (xabacus-8.0.0.tar.bz2) = e81aa183f2f0e1ed962709ed9aed0646ae1ad8cf57b4e60866201e8af54ea874
+SIZE (xabacus-8.0.0.tar.bz2) = 285620
diff --git a/games/xabacus/pkg-plist b/games/xabacus/pkg-plist
index b389cc2e7d9a..ce5e439475a3 100644
--- a/games/xabacus/pkg-plist
+++ b/games/xabacus/pkg-plist
@@ -1,6 +1,15 @@
+@group games
+@owner games
bin/xabacus
-man/man6/xabacus.6.gz
+@owner
+@group
lib/X11/app-defaults/Abacus
+man/man6/xabacus.6.gz
+share/icons/hicolor/16x16/apps/abacus.png
+share/icons/hicolor/22x22/apps/abacus.png
+share/icons/hicolor/24x24/apps/abacus.png
+share/icons/hicolor/32x32/apps/abacus.png
+share/icons/hicolor/48x48/apps/abacus.png
%%DATADIR%%/Abacus.ps
%%DATADIR%%/Abacus1_1.les
%%DATADIR%%/Abacus1_2.les
@@ -27,5 +36,6 @@ lib/X11/app-defaults/Abacus
%%DATADIR%%/Abacusru4_1.les
%%DATADIR%%/Abacusru5_1.les
%%DATADIR%%/bump.au
+%%DATADIR%%/drip.au
%%DATADIR%%/move.au
@dirrm %%DATADIR%%