aboutsummaryrefslogtreecommitdiff
path: root/games/xasteroids/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:38:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:38:05 +0000
commit232ac32ead8f5bad0967a522cb0fd1fa45f3c291 (patch)
tree379f195874e647ea1a21e17fc374efb22b966587 /games/xasteroids/Makefile
parent63a50f4df38055166891bbdf4170393cb7ff9fed (diff)
downloadports-232ac32ead8f5bad0967a522cb0fd1fa45f3c291.tar.gz
ports-232ac32ead8f5bad0967a522cb0fd1fa45f3c291.zip
- Update MASTER_SITES
- Fix build with clang - Fix header PR: 175567 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=311592
Diffstat (limited to 'games/xasteroids/Makefile')
-rw-r--r--games/xasteroids/Makefile35
1 files changed, 22 insertions, 13 deletions
diff --git a/games/xasteroids/Makefile b/games/xasteroids/Makefile
index b924a8f61e25..ff885c144886 100644
--- a/games/xasteroids/Makefile
+++ b/games/xasteroids/Makefile
@@ -1,31 +1,40 @@
-# New ports collection makefile for: xasteroids
-# Date created: 3 Jan 1995
-# Whom: swallace
-#
+# Created by: swallace
# $FreeBSD$
-#
PORTNAME= xasteroids
PORTVERSION= 5.0
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ftp://ftp.x.org/R5contrib/
-DISTFILES= xasteroids.sh.Z
+MASTER_SITES= XCONTRIB/../R5contrib
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .sh.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 based asteroids style arcade game
-USE_IMAKE= yes
-USE_XORG= x11 xext
-NO_WRKSUBDIR= yes
-EXTRACT_CMD= ( cd ${WRKDIR}; zcat | sh -s )
+EXTRACT_CMD= ( cd ${WRKDIR}; zcat | ${SH} -s )
EXTRACT_BEFORE_ARGS= <
EXTRACT_AFTER_ARGS= # empty
+
+NO_WRKSUBDIR= yes
+
+USE_XORG= x11 xext
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lXext -lX11 -lm
+
MAN6= xasteroids.6
PLIST_FILES= bin/xasteroids
post-extract:
- ${CP} ${FILESDIR}/Imakefile ${WRKSRC}
- ${CP} ${WRKSRC}/xast.man ${WRKSRC}/xasteroids.man
+ @${LN} -sf xast.man ${WRKSRC}/xasteroids.6
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CPPFLAGS} ${CFLAGS} -o xasteroids xast.c \
+ ${LDFLAGS})
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} xasteroids ${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} xasteroids.6 ${MAN6PREFIX}/man/man6)
.include <bsd.port.mk>