aboutsummaryrefslogtreecommitdiff
path: root/games/xasteroids/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
commit5114e2637e2224ea9b0e0ea4b315bc38370ccf04 (patch)
tree414dd9b31f0192eb7d0054b2463c2eed8afd25b4 /games/xasteroids/Makefile
parentfd5131ad95770d2ae6bee7059204950dfa6402d1 (diff)
downloadports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.tar.gz
ports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Notes
Notes: svn path=/head/; revision=16518
Diffstat (limited to 'games/xasteroids/Makefile')
-rw-r--r--games/xasteroids/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/xasteroids/Makefile b/games/xasteroids/Makefile
index 2b5f7ad09ff0..7c1c124dbb18 100644
--- a/games/xasteroids/Makefile
+++ b/games/xasteroids/Makefile
@@ -3,7 +3,7 @@
# Date created: 3 Jan 1995
# Whom: swallace
#
-# $Id: Makefile,v 1.9 1998/09/28 02:14:47 steve Exp $
+# $Id: Makefile,v 1.10 1998/10/03 13:39:44 jseger Exp $
#
DISTNAME= xasteroids
@@ -18,7 +18,8 @@ MAINTAINER= swallace@FreeBSD.org
USE_IMAKE= yes
NO_WRKSUBDIR= yes
EXTRACT_CMD= ( cd ${WRKDIR}; zcat | sh -s )
-EXTRACT_ARGS= <
+EXTRACT_BEFORE_ARGS= <
+EXTRACT_AFTER_ARGS= # empty
MAN6= xasteroids.6
.include <bsd.port.mk>