aboutsummaryrefslogtreecommitdiff
path: root/games/xbat
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-29 10:21:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-29 10:21:18 +0000
commitb71bdc0e0c53a748031878aaba5bad7125a92eef (patch)
tree26eee8548cc3a701f83548dea21e97ceddf30322 /games/xbat
parent0c9fe0f218ecaaf4f45af24169c2ac5db99d83d2 (diff)
downloadports-b71bdc0e0c53a748031878aaba5bad7125a92eef.tar.gz
ports-b71bdc0e0c53a748031878aaba5bad7125a92eef.zip
- Use gcc, as the game segfaults being compiled with clang
- Move highscores to /var/games - Modernize plist PR: 205630 Submitted by: amdmi3 Approved by: turutani@scphys.kyoto-u.ac.jp
Notes
Notes: svn path=/head/; revision=404729
Diffstat (limited to 'games/xbat')
-rw-r--r--games/xbat/Makefile3
-rw-r--r--games/xbat/files/patch-Imakefile18
-rw-r--r--games/xbat/pkg-plist24
3 files changed, 25 insertions, 20 deletions
diff --git a/games/xbat/Makefile b/games/xbat/Makefile
index f26ce82ded4a..a686026ef912 100644
--- a/games/xbat/Makefile
+++ b/games/xbat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xbat
PORTVERSION= 1.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= LOCAL/hrs
DISTNAME= xev111
@@ -19,5 +19,6 @@ USES= imake
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/Xev111
ALL_TARGET= xbat
+USE_GCC= yes # segfaults when compiled with clang
.include <bsd.port.mk>
diff --git a/games/xbat/files/patch-Imakefile b/games/xbat/files/patch-Imakefile
index 6165e9fb1e00..6f9c65f0b563 100644
--- a/games/xbat/files/patch-Imakefile
+++ b/games/xbat/files/patch-Imakefile
@@ -1,10 +1,10 @@
---- Imakefile.orig Mon Mar 17 12:32:22 1997
-+++ Imakefile Tue Jul 1 18:37:39 1997
+--- Imakefile.orig 1997-03-17 12:32:22 UTC
++++ Imakefile
@@ -1,24 +1,24 @@
# TOP10 DIR : directory for socre files
#
-SCORE_DIR = /usr/local/games/Xbat/Score
-+SCORE_DIR = ${PREFIX}/lib/X11/Xbat/Score
++SCORE_DIR = /var/games/xbat/Score
# IMAGE DIR : directory for image files
-IMAGE_DIR = /usr/local/games/Xbat/Image
@@ -32,3 +32,15 @@
#######################################################################
+@@ -48,9 +48,8 @@ DependTarget()
+ CleanTarget()
+
+ install::
+- MakeDir($(DESTDIR)$(SCORE_DIR))
+- chmod 777 $(DESTDIR)$(SCORE_DIR);
+- @case '${MFLAGS}' in *[i]*) set +e;; esac; for i in Score/?* ; do set -x; $(INSTALL) -c -m 0666 $$i $(DESTDIR)$(SCORE_DIR) ; \
++ MakeDir($(DESTDIR)$(SCORE_DIR))
++ @case '${MFLAGS}' in *[i]*) set +e;; esac; cd Score; for i in ?* ; do set -x; $(INSTALL) -c -m 0666 $$i $(DESTDIR)$(SCORE_DIR)/$$i.sample ; \
+ done;
+
+ MakeDir($(DESTDIR)$(IMAGE_DIR))
diff --git a/games/xbat/pkg-plist b/games/xbat/pkg-plist
index d6c7402fe353..cf853b834977 100644
--- a/games/xbat/pkg-plist
+++ b/games/xbat/pkg-plist
@@ -1,8 +1,4 @@
-@owner root
-@group games
-@mode 2755
-bin/xbat
-@mode 0664
+@(,games,2755) bin/xbat
lib/X11/Xbat/Domo/domoX0201.dat
lib/X11/Xbat/Domo/domoX0202.dat
lib/X11/Xbat/Domo/domoX0203.dat
@@ -694,14 +690,10 @@ lib/X11/Xbat/Map/kuuchuu_map6.dat
lib/X11/Xbat/Map/kuuchuu_map7.dat
lib/X11/Xbat/Map/kuuchuu_map8.dat
lib/X11/Xbat/Map/kuuchuu_map9.dat
-@mode 0755
-lib/X11/Xbat/Score/top10-0.txt
-lib/X11/Xbat/Score/top10-1.txt
-lib/X11/Xbat/Score/top10-2.txt
-lib/X11/Xbat/Score/top10-3.txt
-lib/X11/Xbat/Score/top10-4.txt
-@dirrm lib/X11/Xbat/Domo
-@dirrm lib/X11/Xbat/Image
-@dirrm lib/X11/Xbat/Map
-@dirrm lib/X11/Xbat/Score
-@dirrm lib/X11/Xbat
+@sample(,games,664) /var/games/xbat/Score/top10-0.txt.sample
+@sample(,games,664) /var/games/xbat/Score/top10-1.txt.sample
+@sample(,games,664) /var/games/xbat/Score/top10-2.txt.sample
+@sample(,games,664) /var/games/xbat/Score/top10-3.txt.sample
+@sample(,games,664) /var/games/xbat/Score/top10-4.txt.sample
+@dir(,games,775) /var/games/xbat/Score
+@dir /var/games/xbat