aboutsummaryrefslogtreecommitdiff
path: root/games/xboard/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-06-11 18:31:03 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-06-11 18:31:03 +0000
commita7be8265c2262ed6443d70f4928ab4da445404e6 (patch)
treed4e95f0ac4432c04f909169e02078b6c22c8d8e3 /games/xboard/Makefile
parent03196bcbc3ea90f9c6c7f64e7d8ae4f158bcd67f (diff)
downloadports-a7be8265c2262ed6443d70f4928ab4da445404e6.tar.gz
ports-a7be8265c2262ed6443d70f4928ab4da445404e6.zip
Add shebangfix to fix build when the option ZIPPY is selected
PR: 200790 Submitted by: kalten@gmx.at
Notes
Notes: svn path=/head/; revision=389244
Diffstat (limited to 'games/xboard/Makefile')
-rw-r--r--games/xboard/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index 6a907833b6e8..b20875a68982 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -56,7 +56,8 @@ GTK2_CONFIGURE_WITH= gtk
.include <bsd.port.options.mk>
-USES+= desktop-file-utils makeinfo perl5 pkgconfig shared-mime-info
+USES+= desktop-file-utils makeinfo perl5 pkgconfig shared-mime-info \
+ shebangfix
USE_XORG+= xt xpm
USE_GNOME+= librsvg2
.if ${PORT_OPTIONS:MXAW}
@@ -65,6 +66,8 @@ USE_XORG+= xaw
.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
.endif
+SHEBANG_FILES= texi2man
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=MKDIR_P="${MKDIR}" PERLPATH=${PERL}
CFLAGS+= -I${LOCALBASE}/include