aboutsummaryrefslogtreecommitdiff
path: root/games/xconq
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-05-07 02:14:29 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-05-07 02:14:29 +0000
commit3c024e8418d3b7d283fb6c79305ed981b515ca22 (patch)
treefbe09a3cf8c0561756378df7b825a40cba2c8fbd /games/xconq
parent3899eb0a372f59b8ec807de3e7d193b7a322605d (diff)
downloadports-3c024e8418d3b7d283fb6c79305ed981b515ca22.tar.gz
ports-3c024e8418d3b7d283fb6c79305ed981b515ca22.zip
Make this port setgid, not setuid.
Reviewed by: maintainer
Notes
Notes: svn path=/head/; revision=28325
Diffstat (limited to 'games/xconq')
-rw-r--r--games/xconq/files/patch-ad48
-rw-r--r--games/xconq/files/patch-ai16
-rw-r--r--games/xconq/files/patch-aj13
-rw-r--r--games/xconq/files/patch-ak20
4 files changed, 78 insertions, 19 deletions
diff --git a/games/xconq/files/patch-ad b/games/xconq/files/patch-ad
index ef77d71f0a38..424411f511dd 100644
--- a/games/xconq/files/patch-ad
+++ b/games/xconq/files/patch-ad
@@ -1,19 +1,29 @@
-*** Makefile.in.orig Sat Feb 21 19:26:25 1998
---- Makefile.in Sat Jul 4 16:53:47 1998
-***************
-*** 44,50 ****
-
- CC = cc
-
-! CFLAGS = -g
-
- RANLIB = ranlib
-
---- 44,50 ----
-
- CC = cc
-
-! CFLAGS ?=
-
- RANLIB = ranlib
-
+--- Makefile.in.orig Sat Feb 21 16:26:25 1998
++++ Makefile.in Sun Apr 30 18:36:42 2000
+@@ -25,12 +25,12 @@
+
+ srcdir = .
+
+-GAMEUID = games
+-GAMEGRP = bin
++GAMEUID = root
++GAMEGRP = games
+
+-GAMEPERM = 04755
+-DIRPERM = 0755
+-FILEPERM = 0644
++GAMEPERM = 02755
++DIRPERM = 0775
++FILEPERM = 0664
+
+ SHELL = /bin/sh
+
+@@ -44,7 +44,7 @@
+
+ CC = cc
+
+-CFLAGS = -g
++CFLAGS ?= -O
+
+ RANLIB = ranlib
+
diff --git a/games/xconq/files/patch-ai b/games/xconq/files/patch-ai
new file mode 100644
index 000000000000..01ffb30de203
--- /dev/null
+++ b/games/xconq/files/patch-ai
@@ -0,0 +1,16 @@
+--- x11/Makefile.in.orig Sun Apr 30 19:49:50 2000
++++ x11/Makefile.in Sun Apr 30 19:50:36 2000
+@@ -25,10 +25,10 @@
+
+ krnsrcdir = $(srcdir)/../kernel
+
+-GAMEUID = games
+-GAMEGRP = bin
++GAMEUID = root
++GAMEGRP = games
+
+-GAMEPERM = 04755
++GAMEPERM = 02755
+ DIRPERM = 0755
+ FILEPERM = 0644
+
diff --git a/games/xconq/files/patch-aj b/games/xconq/files/patch-aj
new file mode 100644
index 000000000000..070398a54bbc
--- /dev/null
+++ b/games/xconq/files/patch-aj
@@ -0,0 +1,13 @@
+--- x11/xconq.c.orig Sun Apr 30 20:34:14 2000
++++ x11/xconq.c Sun Apr 30 20:34:50 2000
+@@ -119,8 +119,8 @@
+ extern uid_t games_uid;
+
+ /* Shift to being the user that started the game. */
+- games_uid = geteuid();
+- setuid(getuid());
++ games_uid = getegid();
++ setgid(getgid());
+ init_library_path(NULL);
+ printf("\n Welcome to X11 Xconq version %s\n\n",
+ version_string());
diff --git a/games/xconq/files/patch-ak b/games/xconq/files/patch-ak
new file mode 100644
index 000000000000..a234982d304a
--- /dev/null
+++ b/games/xconq/files/patch-ak
@@ -0,0 +1,20 @@
+--- kernel/unix.c.orig Mon May 18 19:35:03 1998
++++ kernel/unix.c Sun Apr 30 20:35:33 2000
+@@ -240,7 +240,7 @@
+ /* The scorefile is only writable by the owner of the Xconq
+ executable, but we normally run as the user, so switch over
+ before writing. */
+- setuid(games_uid);
++ setgid(games_uid);
+ fp = fopen(score_file_pathname(name), "a");
+ return fp;
+ }
+@@ -251,7 +251,7 @@
+ {
+ fclose(fp);
+ /* Reset the uid back to the user who started the game. */
+- setuid(getuid());
++ setgid(getgid());
+ }
+
+ static char *scorenamebuf;