aboutsummaryrefslogtreecommitdiff
path: root/games/xgalaga-sdl
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-01 21:51:38 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-01 21:51:38 +0000
commit0553a9acf8f56d86e2a202cdbc891936f771fb29 (patch)
tree7412d2505a9668c37c3e08f26888610fe1264b48 /games/xgalaga-sdl
parent629f1f8feabefee89575de74e2f09a10812e0f46 (diff)
downloadports-0553a9acf8f56d86e2a202cdbc891936f771fb29.tar.gz
ports-0553a9acf8f56d86e2a202cdbc891936f771fb29.zip
XGalaga-SDL is a port of the popular X11 game XGalaga, a clone of Galaga,
using the SDL (Simple DirectMedia Layer) library. XGalaga was originally written by Joe Rumsey. WWW: http://sourceforge.net/projects/xgalaga-sdl/ Approved by: wg/pawel (mentors)
Notes
Notes: svn path=/head/; revision=329002
Diffstat (limited to 'games/xgalaga-sdl')
-rw-r--r--games/xgalaga-sdl/Makefile46
-rw-r--r--games/xgalaga-sdl/distinfo4
-rw-r--r--games/xgalaga-sdl/pkg-descr5
-rw-r--r--games/xgalaga-sdl/pkg-plist81
4 files changed, 136 insertions, 0 deletions
diff --git a/games/xgalaga-sdl/Makefile b/games/xgalaga-sdl/Makefile
new file mode 100644
index 000000000000..fe44920fd66f
--- /dev/null
+++ b/games/xgalaga-sdl/Makefile
@@ -0,0 +1,46 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xgalaga-sdl
+PORTVERSION= 2.1.1.0
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}-sdl${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-sdl${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Classic single screen vertical shoot em up SDL
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}-sdl
+
+USE_BZIP2= yes
+USE_SDL= sdl gfx image mixer ttf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datadir=${DATADIR}
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= CREDITS README
+
+DESKTOP_ENTRIES="XGalaga SDL" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CREDITS||' \
+ -e 's|fonts/copyright||' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/xgalaga-sdl/distinfo b/games/xgalaga-sdl/distinfo
new file mode 100644
index 000000000000..2be9a0589f40
--- /dev/null
+++ b/games/xgalaga-sdl/distinfo
@@ -0,0 +1,4 @@
+SHA256 (xgalaga-sdl-2.1.1.0-sdl.tar.bz2) = 2bcafea534bc1901b736001e811dcbc1bc2d719de375ac4ebd609e55e14136bc
+SIZE (xgalaga-sdl-2.1.1.0-sdl.tar.bz2) = 464114
+SHA256 (xgalaga-sdl.png) = cc14035e06fafc78057db52376fe2f809fd8da3f946f7bdccfe4fd5b431c6287
+SIZE (xgalaga-sdl.png) = 3232
diff --git a/games/xgalaga-sdl/pkg-descr b/games/xgalaga-sdl/pkg-descr
new file mode 100644
index 000000000000..170c0a536a97
--- /dev/null
+++ b/games/xgalaga-sdl/pkg-descr
@@ -0,0 +1,5 @@
+XGalaga-SDL is a port of the popular X11 game XGalaga, a clone of Galaga,
+using the SDL (Simple DirectMedia Layer) library.
+XGalaga was originally written by Joe Rumsey.
+
+WWW: http://sourceforge.net/projects/xgalaga-sdl/
diff --git a/games/xgalaga-sdl/pkg-plist b/games/xgalaga-sdl/pkg-plist
new file mode 100644
index 000000000000..ba3a397818f6
--- /dev/null
+++ b/games/xgalaga-sdl/pkg-plist
@@ -0,0 +1,81 @@
+bin/xgalaga-sdl
+man/man6/xgalaga-sdl.6x.gz
+share/pixmaps/xgalaga-sdl.png
+%%DATADIR%%/fonts/LiberationMono-Bold.ttf
+%%DATADIR%%/images/al.png
+%%DATADIR%%/images/alien1.png
+%%DATADIR%%/images/alien10.png
+%%DATADIR%%/images/alien11.png
+%%DATADIR%%/images/alien12.png
+%%DATADIR%%/images/alien13.png
+%%DATADIR%%/images/alien14.png
+%%DATADIR%%/images/alien15.png
+%%DATADIR%%/images/alien16.png
+%%DATADIR%%/images/alien17.png
+%%DATADIR%%/images/alien2.png
+%%DATADIR%%/images/alien3.png
+%%DATADIR%%/images/alien4.png
+%%DATADIR%%/images/alien5.png
+%%DATADIR%%/images/alien6.png
+%%DATADIR%%/images/alien7.png
+%%DATADIR%%/images/alien8.png
+%%DATADIR%%/images/alien9.png
+%%DATADIR%%/images/etorp.png
+%%DATADIR%%/images/explosion.png
+%%DATADIR%%/images/extra.png
+%%DATADIR%%/images/miniship.png
+%%DATADIR%%/images/mtorp.png
+%%DATADIR%%/images/pause.png
+%%DATADIR%%/images/player1.png
+%%DATADIR%%/images/player2.png
+%%DATADIR%%/images/player3.png
+%%DATADIR%%/images/pr_brain.png
+%%DATADIR%%/images/pr_doub.png
+%%DATADIR%%/images/pr_extrabullet.png
+%%DATADIR%%/images/pr_lemon.png
+%%DATADIR%%/images/pr_machine.png
+%%DATADIR%%/images/pr_shield.png
+%%DATADIR%%/images/pr_sing.png
+%%DATADIR%%/images/pr_speed.png
+%%DATADIR%%/images/pr_spread.png
+%%DATADIR%%/images/pr_trip.png
+%%DATADIR%%/images/s1000.png
+%%DATADIR%%/images/s2000.png
+%%DATADIR%%/images/s4000.png
+%%DATADIR%%/images/s500.png
+%%DATADIR%%/images/sfont_big_red.png
+%%DATADIR%%/images/sfont_reg_cyan.png
+%%DATADIR%%/images/sfont_reg_green.png
+%%DATADIR%%/images/sfont_reg_grey.png
+%%DATADIR%%/images/sfont_reg_red.png
+%%DATADIR%%/images/sfont_reg_yellow.png
+%%DATADIR%%/images/shield.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/levels/level1.xgl
+%%DATADIR%%/levels/level10.xgl
+%%DATADIR%%/levels/level11.xgl
+%%DATADIR%%/levels/level12.xgl
+%%DATADIR%%/levels/level13.xgl
+%%DATADIR%%/levels/level14.xgl
+%%DATADIR%%/levels/level15.xgl
+%%DATADIR%%/levels/level2.xgl
+%%DATADIR%%/levels/level3.xgl
+%%DATADIR%%/levels/level4.xgl
+%%DATADIR%%/levels/level5.xgl
+%%DATADIR%%/levels/level6.xgl
+%%DATADIR%%/levels/level7.xgl
+%%DATADIR%%/levels/level8.xgl
+%%DATADIR%%/levels/level9.xgl
+%%DATADIR%%/sounds/ddloo.wav
+%%DATADIR%%/sounds/explode.wav
+%%DATADIR%%/sounds/explode_big.wav
+%%DATADIR%%/sounds/firetorp.wav
+%%DATADIR%%/sounds/shield.wav
+%%DATADIR%%/sounds/smart.wav
+%%DATADIR%%/sounds/torphit.wav
+%%DATADIR%%/sounds/warp.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%