aboutsummaryrefslogtreecommitdiff
path: root/games/xlogical/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-06 10:26:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-06 10:26:13 +0000
commit314ce217e2858ab8b10cdfddd60ea4089f9e1c2c (patch)
treee326a66a1efe167618c3855bada140172066c502 /games/xlogical/Makefile
parent8f21fec38ee1e0b8430109d61fd75b38f06e7f1d (diff)
downloadports-314ce217e2858ab8b10cdfddd60ea4089f9e1c2c.tar.gz
ports-314ce217e2858ab8b10cdfddd60ea4089f9e1c2c.zip
- Fix build with gcc 4.2
PR: 117319 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202540
Diffstat (limited to 'games/xlogical/Makefile')
-rw-r--r--games/xlogical/Makefile32
1 files changed, 13 insertions, 19 deletions
diff --git a/games/xlogical/Makefile b/games/xlogical/Makefile
index 49e174e0ed25..b810e82c80c7 100644
--- a/games/xlogical/Makefile
+++ b/games/xlogical/Makefile
@@ -5,20 +5,20 @@
# $FreeBSD$
#
-PORTNAME= xlogical
-PORTVERSION= 1.0p8
-CATEGORIES= games
-MASTER_SITES= http://changeling.ixionstudios.com/xlogical/downloads/ \
- http://freebsd.portsreview.info/downloads/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-/}
+PORTNAME= xlogical
+PORTVERSION= 1.0p8
+CATEGORIES= games
+MASTER_SITES= http://changeling.ixionstudios.com/xlogical/downloads/ \
+ http://freebsd.portsreview.info/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-/}
-MAINTAINER= aaron@baugher.biz
-COMMENT= Remake of the classic puzzle game Logical
+MAINTAINER= aaron@baugher.biz
+COMMENT= Remake of the classic puzzle game Logical
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_SDL= sdl image mixer
-GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl image mixer
+GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -30,10 +30,4 @@ post-install:
${RM} ${WRKSRC}/LICENSE
${CP} ${WRKSRC}/[A-Z][A-Z]* ${DOCSDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>