aboutsummaryrefslogtreecommitdiff
path: root/games/xnethack
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /games/xnethack
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Mk/Uses: always use colon for build/run suffix
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
Diffstat (limited to 'games/xnethack')
-rw-r--r--games/xnethack/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/xnethack/Makefile b/games/xnethack/Makefile
index d37234798498..0747725e89aa 100644
--- a/games/xnethack/Makefile
+++ b/games/xnethack/Makefile
@@ -41,7 +41,7 @@ GRAPHICS= X11_GRAPHICS
GRAPHICS= # none
.elif ${FLAVOR} == "qt"
USES+= localbase pkgconfig qt:5
-USE_QT= buildtools_build core gui multimedia network widgets
+USE_QT= buildtools:build core gui multimedia network widgets
MAKE_ENV+= MOCPATH=${MOC} LINK="${CXX} -pie"
# Qt wants PIC for some reason. For C code, PIE should be enough.
CFLAGS+= -I${QT_INCDIR} -fpie