aboutsummaryrefslogtreecommitdiff
path: root/games/xoids
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-10-14 19:49:18 +0000
committerAde Lovett <ade@FreeBSD.org>2000-10-14 19:49:18 +0000
commite20215f357c06456ddd03f38b82a6b4fe56a69ec (patch)
treeaec987b4315f8b3ca500b23863107c6c57687297 /games/xoids
parent5e6a693f47bad5fe060839af558bc0ef7de5e9c3 (diff)
downloadports-e20215f357c06456ddd03f38b82a6b4fe56a69ec.tar.gz
ports-e20215f357c06456ddd03f38b82a6b4fe56a69ec.zip
Fix Imakefile breakage under XFree86 4.x
Respect CFLAGS PR: 21976 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=33836
Diffstat (limited to 'games/xoids')
-rw-r--r--games/xoids/Makefile28
-rw-r--r--games/xoids/files/patch-aa37
2 files changed, 47 insertions, 18 deletions
diff --git a/games/xoids/Makefile b/games/xoids/Makefile
index 45f35f52df9d..745a4821c6aa 100644
--- a/games/xoids/Makefile
+++ b/games/xoids/Makefile
@@ -5,25 +5,25 @@
# $FreeBSD$
#
-PORTNAME= xoids
-PORTVERSION= 1.5
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+PORTNAME= xoids
+PORTVERSION= 1.5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-USE_IMAKE= yes
-USE_XPM= yes
-MAN6= xoids.6
-MANCOMPRESSED= no
+USE_IMAKE= yes
+USE_XPM= yes
+MAN6= xoids.6
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/xoids ${PREFIX}/bin
- @ ${INSTALL_DATA} ${WRKSRC}/xoids.1x ${PREFIX}/man/man6/xoids.6
+post-extract:
+ @${CP} ${WRKSRC}/xoids.1x ${WRKSRC}/xoids.man
+
+post-install:
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/xoids
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xoids
+ @${MKDIR} ${PREFIX}/share/doc/xoids
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xoids
.endif
.include <bsd.port.mk>
diff --git a/games/xoids/files/patch-aa b/games/xoids/files/patch-aa
index a81058ebf93d..a8aeac5f586e 100644
--- a/games/xoids/files/patch-aa
+++ b/games/xoids/files/patch-aa
@@ -1,6 +1,20 @@
---- Imakefile.orig Tue Jun 25 01:42:14 1996
-+++ Imakefile Sun Jun 20 19:18:26 1999
-@@ -19,11 +19,13 @@
+--- Imakefile.orig Tue Jun 25 15:42:14 1996
++++ Imakefile Sat Oct 14 00:59:00 2000
+@@ -6,11 +6,12 @@
+ XPM_INC_FLAGS = -I/usr/local/xpm/include
+ XPM_LIB_FLAGS = -L/usr/local/xpm/lib -lXpm
+
++MANSUFFIX = 6
++
+ XCOMM You shouldn't have to change anything below unless you need to
+ XCOMM add a new architecture.
+ #define MyNull
+
+-CDEBUGFLAGS = -O
+ OS_C_FLAGS =
+ OS_LIB_FLAGS =
+ OS_DEFINES =
+@@ -19,25 +20,23 @@
#if defined(SunArchitecture)
#endif
@@ -10,8 +24,23 @@
#endif
#if defined(FreeBSDArchitecture)
-+XPM_INC_FLAGS = -I$(X11BASE)/include/X11
++XPM_INC_FLAGS = -I$(INCROOT)/X11
+XPM_LIB_FLAGS = -lXpm
#endif
SRCS = init.c oids.c oids_x.c
+ OBJS = init.o oids.o oids_x.o
+
+ INCLUDES = $(XPM_INC_FLAGS)
+-CCOPTIONS = $(OS_C_FLAGS)
+ DEFINES = $(OS_DEFINES)
+ EXTRA_LIBRARIES = $(XPM_LIB_FLAGS) -lX11 -lm $(OS_LIB_FLAGS)
+
+-AllTarget(xoids)
+-NormalProgramTarget(xoids, $(OBJS), MyNull, MyNull, MyNull)
+-InstallProgram(xoids,$(BINDIR))
+-DependTarget()
++ComplexProgramTarget(xoids)
+
+ XCOMM End of Imakefile
+