aboutsummaryrefslogtreecommitdiff
path: root/games/xpipeman
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-23 01:27:49 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-23 01:27:49 +0000
commit6b3f9f90724c6a5bb0486dfd7248b48ba9c200c1 (patch)
treeae09bc9ebc025fcb00763f8925b6f0c0bb039ebc /games/xpipeman
parent55c528c40a4c6aaaed54de21dd73ef8a44f26a3c (diff)
downloadports-6b3f9f90724c6a5bb0486dfd7248b48ba9c200c1.tar.gz
ports-6b3f9f90724c6a5bb0486dfd7248b48ba9c200c1.zip
* Fix build.
PR: 40889 Submitted by: Amar Takhar <verm@drunkmonk.net> * However, this will not build on 64-bit archs.
Notes
Notes: svn path=/head/; revision=63420
Diffstat (limited to 'games/xpipeman')
-rw-r--r--games/xpipeman/Makefile3
-rw-r--r--games/xpipeman/files/patch-ab42
-rw-r--r--games/xpipeman/scripts/pre-configure7
3 files changed, 29 insertions, 23 deletions
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
index f9afa5a237b5..30238d81ede8 100644
--- a/games/xpipeman/Makefile
+++ b/games/xpipeman/Makefile
@@ -15,7 +15,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-BROKEN= "Does not build"
+# LP64 issues
+ONLY_FOR_ARCHS= i386
USE_IMAKE= yes
MAN6= xpipeman.6
diff --git a/games/xpipeman/files/patch-ab b/games/xpipeman/files/patch-ab
index 46438307d1b6..318169ed2d73 100644
--- a/games/xpipeman/files/patch-ab
+++ b/games/xpipeman/files/patch-ab
@@ -1,15 +1,27 @@
-*** Imakefile.orig Tue Jul 28 19:56:27 1992
---- Imakefile Sun Apr 12 12:09:36 1998
-***************
-*** 1,5 ****
-
-! SCORE_FILE = -DSCORE_FILE=\"/usr/games/lib/xpipescores\"
- MAXSCORES = -DMAXSCORES=20
- DEFINES = $(SCORE_FILE) $(MAXSCORES) -DSYSV
-
---- 1,5 ----
-
-! SCORE_FILE = -DSCORE_FILE=\"/usr/X11R6/lib/X11/xpipescores\"
- MAXSCORES = -DMAXSCORES=20
- DEFINES = $(SCORE_FILE) $(MAXSCORES) -DSYSV
-
+--- Imakefile.orig Tue Jul 28 19:56:27 1992
++++ Imakefile Mon Jul 22 14:05:57 2002
+@@ -1,7 +1,7 @@
+
+- SCORE_FILE = -DSCORE_FILE=\"/usr/games/lib/xpipescores\"
++ SCORE_FILE = -DSCORE_FILE=\"/usr/X11R6/lib/X11/xpipescores\"
+ MAXSCORES = -DMAXSCORES=20
+- DEFINES = $(SCORE_FILE) $(MAXSCORES) -DSYSV
++ DEFINES = $(SCORE_FILE) $(MAXSCORES)
+
+ SRCS = actions.c game.c graphics.c main.c score.c popup.c info.c
+ OBJS = actions.o game.o graphics.o main.o score.o popup.o info.o
+@@ -10,6 +10,9 @@
+ LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
+ SYS_LIBRARIES = -lm
+
++ MANSUFFIX = 6
++ INSTPGMFLAGS = -g games
++
+ all:: xpipeman
+
+ ComplexProgramTarget(xpipeman)
+@@ -19,4 +22,3 @@
+ * InstallManPage(xpipeman,$(MANDIR))
+ * InstallProgram(xpipeman,$(BINDIR))
+ */
+-
diff --git a/games/xpipeman/scripts/pre-configure b/games/xpipeman/scripts/pre-configure
deleted file mode 100644
index 0221c321bd3c..000000000000
--- a/games/xpipeman/scripts/pre-configure
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-#echo "LOCAL=$PREFIX" >${WRKSRC}/Imakefile || exit 1;
-echo "MANSUFFIX=6" >>${WRKSRC}/Imakefile || exit 1
-echo "INSTPGMFLAGS = -s -g games -m 2755" >>${WRKSRC}/Imakefile || exit 1
-
-exit 0