aboutsummaryrefslogtreecommitdiff
path: root/games/xpipeman
diff options
context:
space:
mode:
authorSteven Wallace <swallace@FreeBSD.org>1995-01-03 08:48:45 +0000
committerSteven Wallace <swallace@FreeBSD.org>1995-01-03 08:48:45 +0000
commitabb159a0ebb35e62192000df288aab494f35330d (patch)
tree4663d2582cc407d85a4f509f468172520dae333f /games/xpipeman
parent3003ec6553ad180e4192262e00429f19396f15a1 (diff)
downloadports-abb159a0ebb35e62192000df288aab494f35330d.tar.gz
ports-abb159a0ebb35e62192000df288aab494f35330d.zip
xpipeman - connect the pipes to stop the leaks (X Windows)
Notes
Notes: svn path=/head/; revision=670
Diffstat (limited to 'games/xpipeman')
-rw-r--r--games/xpipeman/Makefile17
-rw-r--r--games/xpipeman/files/patch-aa91
-rw-r--r--games/xpipeman/files/patch-ab15
-rw-r--r--games/xpipeman/files/xpipescores20
-rw-r--r--games/xpipeman/pkg-comment1
-rw-r--r--games/xpipeman/pkg-descr4
-rw-r--r--games/xpipeman/pkg-plist7
-rw-r--r--games/xpipeman/scripts/pre-configure7
8 files changed, 162 insertions, 0 deletions
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
new file mode 100644
index 000000000000..32b3184e969d
--- /dev/null
+++ b/games/xpipeman/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: xpipeman
+# Date created: 2 Jan 1995
+# Whom: swallace
+#
+# $Id: Makefile,v 1.3 1994/12/31 04:17:52 swallace Exp $
+#
+
+DISTNAME= xpipeman
+MASTER_SITES= ftp://iraun1.ira.uka.de/pub/x11/
+EXTRACT_SUFX= .tar.Z
+USE_IMAKE= yes
+INSTALL_MANPAGES= yes
+
+.include <bsd.port.mk>
+
+install:
+ install -c -g games -m 664 ${.CURDIR}/files/xpipescores /usr/X11R6/lib/X11
diff --git a/games/xpipeman/files/patch-aa b/games/xpipeman/files/patch-aa
new file mode 100644
index 000000000000..00e13a694bee
--- /dev/null
+++ b/games/xpipeman/files/patch-aa
@@ -0,0 +1,91 @@
+*** score.c.orig Fri Oct 11 11:35:59 1991
+--- score.c Mon Jan 2 23:46:28 1995
+***************
+*** 52,57 ****
+--- 52,58 ----
+
+ #include <X11/Xos.h> /* brings in <sys/file.h> */
+ #include <stdio.h>
++ #include <stdlib.h>
+ #include "xpipeman.h"
+
+ /*----------------------------------------------------------------------*/
+***************
+*** 63,69 ****
+
+ static SCORE scores[MAXSCORES];
+
+! void show_scores(),
+ new_high_score(),
+ load_scores(),
+ write_out_scores();
+--- 64,70 ----
+
+ static SCORE scores[MAXSCORES];
+
+! static void show_scores(),
+ new_high_score(),
+ load_scores(),
+ write_out_scores();
+***************
+*** 106,117 ****
+ #ifndef SYSV
+ flock(scorefile->_file, LOCK_EX);
+ #endif
+! while( fgets(scores[i].score,6,scorefile) /* get score */
+! && fgets(scores[i].name,26,scorefile) /* get name */
+! && fgetc(scorefile)) /* and newline */
+! {
+! i++;
+! if( i > MAXSCORES ) break;
+ }
+ }
+
+--- 107,119 ----
+ #ifndef SYSV
+ flock(scorefile->_file, LOCK_EX);
+ #endif
+! for(i = 0; i < MAXSCORES; i++) {
+! if(!fgets(scores[i].score, 6, scorefile)) /* get score */
+! break;
+! if(!fgets(scores[i].name, 26, scorefile)) /* get name */
+! break;
+! if(!fgetc(scorefile)) /* and newline */
+! break;
+ }
+ }
+
+***************
+*** 190,196 ****
+
+
+ /*ARGSUSED*/
+! static XtCallbackProc
+ popdown_callback(w, closure, call_data)
+ Widget w;
+ caddr_t closure;
+--- 192,198 ----
+
+
+ /*ARGSUSED*/
+! static void
+ popdown_callback(w, closure, call_data)
+ Widget w;
+ caddr_t closure;
+***************
+*** 249,255 ****
+ show_scores()
+ {
+ int i;
+! char tmp_str[31];
+ Arg tmp_arg;
+
+ for(i = 0;i<MAXSCORES;i++) {
+--- 251,257 ----
+ show_scores()
+ {
+ int i;
+! char tmp_str[64];
+ Arg tmp_arg;
+
+ for(i = 0;i<MAXSCORES;i++) {
diff --git a/games/xpipeman/files/patch-ab b/games/xpipeman/files/patch-ab
new file mode 100644
index 000000000000..f8d9ec60f899
--- /dev/null
+++ b/games/xpipeman/files/patch-ab
@@ -0,0 +1,15 @@
+*** Imakefile.orig Fri Sep 13 13:32:10 1991
+--- Imakefile Mon Jan 2 23:49:42 1995
+***************
+*** 1,5 ****
+
+! SCORE_FILE = -DSCORE_FILE=\"./xpipescores\"
+ MAXSCORES = -DMAXSCORES=20
+ DEFINES = $(SCORE_FILE) $(MAXSCORES)
+
+--- 1,5 ----
+
+! SCORE_FILE = -DSCORE_FILE=\"/usr/X11R6/lib/X11/xpipescores\"
+ MAXSCORES = -DMAXSCORES=20
+ DEFINES = $(SCORE_FILE) $(MAXSCORES)
+
diff --git a/games/xpipeman/files/xpipescores b/games/xpipeman/files/xpipescores
new file mode 100644
index 000000000000..0912f9c942e5
--- /dev/null
+++ b/games/xpipeman/files/xpipescores
@@ -0,0 +1,20 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/games/xpipeman/pkg-comment b/games/xpipeman/pkg-comment
new file mode 100644
index 000000000000..95e1b7659896
--- /dev/null
+++ b/games/xpipeman/pkg-comment
@@ -0,0 +1 @@
+xpipeman - connect the pipes to stop the leaks
diff --git a/games/xpipeman/pkg-descr b/games/xpipeman/pkg-descr
new file mode 100644
index 000000000000..c942f44ea356
--- /dev/null
+++ b/games/xpipeman/pkg-descr
@@ -0,0 +1,4 @@
+Xpipeman is a game of skill requiring the user to connect together pieces of
+a pipe to allow a liquid to flow through without leaking out.
+The liquid flows out of the block marked with an "S". The aim of the game
+is to connect as many pieces of pipe to the start block as possible.
diff --git a/games/xpipeman/pkg-plist b/games/xpipeman/pkg-plist
new file mode 100644
index 000000000000..d4ea039c5395
--- /dev/null
+++ b/games/xpipeman/pkg-plist
@@ -0,0 +1,7 @@
+@cwd /usr/X11R6
+man/man6/xpipeman.6.gz
+@group games
+@mode 02755
+bin/xpipeman
+@mode 0664
+lib/X11/xpipescores
diff --git a/games/xpipeman/scripts/pre-configure b/games/xpipeman/scripts/pre-configure
new file mode 100644
index 000000000000..0221c321bd3c
--- /dev/null
+++ b/games/xpipeman/scripts/pre-configure
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+#echo "LOCAL=$PREFIX" >${WRKSRC}/Imakefile || exit 1;
+echo "MANSUFFIX=6" >>${WRKSRC}/Imakefile || exit 1
+echo "INSTPGMFLAGS = -s -g games -m 2755" >>${WRKSRC}/Imakefile || exit 1
+
+exit 0