aboutsummaryrefslogtreecommitdiff
path: root/games/xpired
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-05 21:54:48 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-05 21:54:48 +0000
commit4d62cc2164e6de9ddc8336fe646258f1fd9bfd90 (patch)
treec186ac3125277a8185bce3c030117b24de9d845c /games/xpired
parent239d46f4c19037a831e7eaba17cb7c4a85ec1cb1 (diff)
downloadports-4d62cc2164e6de9ddc8336fe646258f1fd9bfd90.tar.gz
ports-4d62cc2164e6de9ddc8336fe646258f1fd9bfd90.zip
Add new port xpired: An action-puzzle game
PR: ports/40161 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=64075
Diffstat (limited to 'games/xpired')
-rw-r--r--games/xpired/Makefile33
-rw-r--r--games/xpired/distinfo1
-rw-r--r--games/xpired/files/patch-Makefile13
-rw-r--r--games/xpired/pkg-comment1
-rw-r--r--games/xpired/pkg-descr6
-rw-r--r--games/xpired/pkg-plist86
6 files changed, 140 insertions, 0 deletions
diff --git a/games/xpired/Makefile b/games/xpired/Makefile
new file mode 100644
index 000000000000..bafcc1e2680e
--- /dev/null
+++ b/games/xpired/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xpired
+# Date created: 2 July 2002
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpired
+PORTVERSION= 1.22
+CATEGORIES= games
+MASTER_SITES= http://xpired.temnet.org/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-linux_source
+
+MAINTAINER= edwin@mavetju.org
+
+LIB_DEPENDS= SDL_gfx.0:${PORTSDIR}/graphics/sdl_gfx \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+WRKSRC= ${WRKDIR}/src
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/xpired ${WRKSRC}/xpiredit ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/img
+ @${MKDIR} ${DATADIR}/snd
+.for files in xpired.lvl xpired.cfg bgimages.txt readme.txt xpired.dmo
+ @${INSTALL_DATA} ${WRKSRC}/${files} ${DATADIR}
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/img/* ${DATADIR}/img
+ @${INSTALL_DATA} ${WRKSRC}/snd/* ${DATADIR}/snd
+
+.include <bsd.port.mk>
diff --git a/games/xpired/distinfo b/games/xpired/distinfo
new file mode 100644
index 000000000000..3a2c05fb03b5
--- /dev/null
+++ b/games/xpired/distinfo
@@ -0,0 +1 @@
+MD5 (xpired-1.22-linux_source.tar.gz) = 4d6e38efe53b3840beb38a8dc9cc72d1
diff --git a/games/xpired/files/patch-Makefile b/games/xpired/files/patch-Makefile
new file mode 100644
index 000000000000..877c0dd7bb22
--- /dev/null
+++ b/games/xpired/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Mon Aug 5 14:41:31 2002
++++ Makefile Mon Aug 5 14:43:38 2002
+@@ -1,8 +1,6 @@
+-PREFIX=/usr/local
+ SHARE_PREFIX=$(PREFIX)/share/xpired
+-CFLAGS=`sdl-config --cflags` -DUNIX -DPREFIX=\"$(PREFIX)\" -DSHARE_PREFIX=\"$(SHARE_PREFIX)\"
+-LDFLAGS=`sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_gfx
+-CC=gcc
++CFLAGS=`sdl11-config --cflags` -DUNIX -DPREFIX=\"$(PREFIX)\" -DSHARE_PREFIX=\"$(SHARE_PREFIX)\"
++LDFLAGS=`sdl11-config --libs` -lSDL_mixer -lSDL_image -lSDL_gfx
+
+ BINARIES = xpired xpiredit
+
diff --git a/games/xpired/pkg-comment b/games/xpired/pkg-comment
new file mode 100644
index 000000000000..eb31c7b772c3
--- /dev/null
+++ b/games/xpired/pkg-comment
@@ -0,0 +1 @@
+An action-puzzle maze escape game (SDL)
diff --git a/games/xpired/pkg-descr b/games/xpired/pkg-descr
new file mode 100644
index 000000000000..ad0204bab2fb
--- /dev/null
+++ b/games/xpired/pkg-descr
@@ -0,0 +1,6 @@
+X-pired is an action-puzzle game written in C using SDL, SDL_mixer,
+SDL_image and SDL_gfx libraries distributed under the terms of GNU
+GPL. The goal of the game in each level is to reach the exit square,
+avoiding exploding barrels and other deadly stuff...
+
+WWW: http://xpired.temnet.org/
diff --git a/games/xpired/pkg-plist b/games/xpired/pkg-plist
new file mode 100644
index 000000000000..7e7f902ee6a0
--- /dev/null
+++ b/games/xpired/pkg-plist
@@ -0,0 +1,86 @@
+bin/xpired
+bin/xpiredit
+share/xpired/bgimages.txt
+share/xpired/img/barel.bmp
+share/xpired/img/bem1.bmp
+share/xpired/img/bem2.bmp
+share/xpired/img/bem3.bmp
+share/xpired/img/bem4.bmp
+share/xpired/img/bg-dirt.jpg
+share/xpired/img/bg-metal.jpg
+share/xpired/img/bg-organic.jpg
+share/xpired/img/bg-plate.jpg
+share/xpired/img/bg-sector.jpg
+share/xpired/img/bg-stone.jpg
+share/xpired/img/bg-stones.jpg
+share/xpired/img/bg-tek.jpg
+share/xpired/img/bg.jpg
+share/xpired/img/bo-flamable.bmp
+share/xpired/img/crate.bmp
+share/xpired/img/end.jpg
+share/xpired/img/exit-denied.bmp
+share/xpired/img/exit.bmp
+share/xpired/img/expl1.bmp
+share/xpired/img/expl2.bmp
+share/xpired/img/expl3.bmp
+share/xpired/img/explosive.bmp
+share/xpired/img/fire1.bmp
+share/xpired/img/fire2.bmp
+share/xpired/img/fire3.bmp
+share/xpired/img/flamable.bmp
+share/xpired/img/hot.bmp
+share/xpired/img/ice.bmp
+share/xpired/img/icon.bmp
+share/xpired/img/level.bmp
+share/xpired/img/lives.bmp
+share/xpired/img/numbers.bmp
+share/xpired/img/player-death1.bmp
+share/xpired/img/player-death2.bmp
+share/xpired/img/player-death3.bmp
+share/xpired/img/player-death4.bmp
+share/xpired/img/player-h-body.bmp
+share/xpired/img/player-h-legs.bmp
+share/xpired/img/player-h-push.bmp
+share/xpired/img/player-v-body.bmp
+share/xpired/img/player-v-legs.bmp
+share/xpired/img/player-v-push.bmp
+share/xpired/img/player.bmp
+share/xpired/img/retard.bmp
+share/xpired/img/shade-bem1.bmp
+share/xpired/img/shade-bem2.bmp
+share/xpired/img/shade-bem3.bmp
+share/xpired/img/shade-bem4.bmp
+share/xpired/img/shade-crate.bmp
+share/xpired/img/shade-expl1.bmp
+share/xpired/img/shade-expl2.bmp
+share/xpired/img/shade-expl3.bmp
+share/xpired/img/shade-player.bmp
+share/xpired/img/shade-round.bmp
+share/xpired/img/shade-square.bmp
+share/xpired/img/shade-t1.bmp
+share/xpired/img/shade-t2.bmp
+share/xpired/img/shade-t3.bmp
+share/xpired/img/start.bmp
+share/xpired/img/telee1.bmp
+share/xpired/img/telee2.bmp
+share/xpired/img/telee3.bmp
+share/xpired/img/teleport.bmp
+share/xpired/img/time.bmp
+share/xpired/img/tinywall.bmp
+share/xpired/img/title.jpg
+share/xpired/img/wall.bmp
+share/xpired/readme.txt
+share/xpired/snd/beep.wav
+share/xpired/snd/bombex.wav
+share/xpired/snd/burn.wav
+share/xpired/snd/fall.wav
+share/xpired/snd/gameover.wav
+share/xpired/snd/slide.wav
+share/xpired/snd/smashem.s3m
+share/xpired/snd/teleport.wav
+share/xpired/xpired.cfg
+share/xpired/xpired.dmo
+share/xpired/xpired.lvl
+@dirrm share/xpired/snd
+@dirrm share/xpired/img
+@dirrm share/xpired