aboutsummaryrefslogtreecommitdiff
path: root/games/xpyraminx/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-14 23:25:31 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-14 23:25:31 +0000
commit732065a0a435c6b3544ca4d6f1c9c4c6db78fefb (patch)
tree64bdd310658bde2263c88db9b4260a1d39f73352 /games/xpyraminx/Makefile
parent815ee98ad43276931bcd18e568392e3cfe0d2c38 (diff)
downloadports-732065a0a435c6b3544ca4d6f1c9c4c6db78fefb.tar.gz
ports-732065a0a435c6b3544ca4d6f1c9c4c6db78fefb.zip
- Add stage support
- Use PLIST_FILES instead of pkg-plist
Notes
Notes: svn path=/head/; revision=333806
Diffstat (limited to 'games/xpyraminx/Makefile')
-rw-r--r--games/xpyraminx/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/xpyraminx/Makefile b/games/xpyraminx/Makefile
index 488ce081aceb..7f8a3da4ca89 100644
--- a/games/xpyraminx/Makefile
+++ b/games/xpyraminx/Makefile
@@ -14,14 +14,14 @@ COMMENT= Pyraminx puzzle for X Window System
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= imake
USE_XORG= x11 xext xt sm ice
-MAN1= xpyraminx.1
-MANCOMPRESSED= no
-XFREE86_HTML_MAN= no
-NO_STAGE= yes
+PLIST_FILES= bin/xpyraminx \
+ lib/X11/app-defaults/Pyraminx \
+ man/man1/xpyraminx.1.gz
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xpyraminx ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Pyraminx.ad ${PREFIX}/lib/X11/app-defaults/Pyraminx
- ${INSTALL_MAN} ${WRKSRC}/xpyraminx.man ${MANPREFIX}/man/man1/xpyraminx.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpyraminx ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Pyraminx.ad ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/Pyraminx
+ ${INSTALL_MAN} ${WRKSRC}/xpyraminx.man ${STAGEDIR}${MANPREFIX}/man/man1/xpyraminx.1
.include <bsd.port.mk>