aboutsummaryrefslogtreecommitdiff
path: root/games/xshisen
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-04 13:30:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-04 13:30:38 +0000
commit5aadc16227f0e5dce9f5ff6d78d2f107ed66f1af (patch)
tree9c499d3202d3f0e9049ad9d02da90997174e998d /games/xshisen
parentc6c5aeb46a33ab5d36d553e2c9e83573cab8eba0 (diff)
downloadports-5aadc16227f0e5dce9f5ff6d78d2f107ed66f1af.tar.gz
ports-5aadc16227f0e5dce9f5ff6d78d2f107ed66f1af.zip
Fix runtime error.
PR: 210793 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418024
Diffstat (limited to 'games/xshisen')
-rw-r--r--games/xshisen/Makefile14
-rw-r--r--games/xshisen/files/patch-body.C11
2 files changed, 18 insertions, 7 deletions
diff --git a/games/xshisen/Makefile b/games/xshisen/Makefile
index afdff6aaa606..c177e4f25ebd 100644
--- a/games/xshisen/Makefile
+++ b/games/xshisen/Makefile
@@ -10,19 +10,19 @@ MASTER_SITES= LOCAL/hrs
MAINTAINER= TsurutaniNaoki@gmail.com
COMMENT= Shisen-sho puzzle game for X11
-BROKEN= fails to start
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sharedstatedir="${DATADIR}"
INSTALL_TARGET= install-prog
-.if !defined(WITHOUT_MOTIF)
-USES= motif
-CONFIGURE_ARGS+= --with-motif
-.endif
+OPTIONS_DEFINE= MOTIF
+OPTIONS_DEFAULT= MOTIF
+
+MOTIF_USES= motif
+MOTIF_CONFIGURE_WITH= motif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/games/xshisen/files/patch-body.C b/games/xshisen/files/patch-body.C
new file mode 100644
index 000000000000..ece3a898017c
--- /dev/null
+++ b/games/xshisen/files/patch-body.C
@@ -0,0 +1,11 @@
+--- body.C.orig 2002-07-07 07:22:35 UTC
++++ body.C
+@@ -227,7 +227,7 @@ Body::refreshhint(void)
+ p = new Point[max_c][2];
+ t = new Point[xsize*ysize/PKIND];
+
+- if (hintNum == 0)
++ if (hintNum != 0)
+ delete[] hintArray;
+ for(int i=0; i<PKIND; i++) {
+ piepos[i]->GetPosArray(t, num);