aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-04 11:50:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-07-04 11:50:50 +0000
commit00ad410bc0087d24ed61a88996839ec9aaeec023 (patch)
tree7b4b78049a64cb6c20a01b70699d3e9bf782250e /games
parent908c62ab05becd08ae1605994ea73ee0f1bea9c2 (diff)
downloadports-00ad410bc0087d24ed61a88996839ec9aaeec023.tar.gz
ports-00ad410bc0087d24ed61a88996839ec9aaeec023.zip
games/trenchbroom: unbreak the port's build against Clang 16
Replace deprecated since C++11 and removed from C++17 `std::auto_ptr' smart pointer class with `std::unique_ptr' which luckily can be used as a drop-in replacement in this case. Reported by: pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/trenchbroom/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/trenchbroom/Makefile b/games/trenchbroom/Makefile
index 3be5b482b795..b278d139973f 100644
--- a/games/trenchbroom/Makefile
+++ b/games/trenchbroom/Makefile
@@ -37,6 +37,9 @@ post-patch:
${WRKSRC}/common/src/IO/SystemPaths.cpp
@${REINPLACE_CMD} -e '/return m_.*Margin/s,(),,' \
${WRKSRC}/common/src/View/CellLayout.h
+ @${REINPLACE_CMD} -e '/typedef std::/s,auto_ptr,unique_ptr,' \
+ ${WRKSRC}/common/src/IO/NodeSerializer.h \
+ ${WRKSRC}/common/src/Renderer/FontTexture.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/TrenchBroom ${STAGEDIR}${PREFIX}/bin