aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 13:37:20 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 13:37:20 +0000
commit08460ba1853b64f5cd4a21e842fcd127d22d7a3e (patch)
treeb7a53e6e3c97430ff64618ade359542cee283ea2 /games
parent9d909aa766f032048a07db5b7c232716f23b0283 (diff)
downloadports-08460ba1853b64f5cd4a21e842fcd127d22d7a3e.tar.gz
ports-08460ba1853b64f5cd4a21e842fcd127d22d7a3e.zip
games/lugaru builds fine with Clang
- Add missing libGL dependency - Fix bad absolute symlink - Add LLD_UNSAFE because of the audio/openal-soft dependency [1] PR: 226980 [1]
Notes
Notes: svn path=/head/; revision=475572
Diffstat (limited to 'games')
-rw-r--r--games/lugaru/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/lugaru/Makefile b/games/lugaru/Makefile
index 4d4b915cfec8..0736da454fdb 100644
--- a/games/lugaru/Makefile
+++ b/games/lugaru/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lugaru
PORTVERSION= 269
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= https://bitbucket.org/oss${PORTNAME}/${PORTNAME}/downloads/
DISTNAME= ${PORTNAME}-rev${DISTVERSION}-src
@@ -19,10 +19,10 @@ LIB_DEPENDS= libpng.so:graphics/png \
libogg.so:audio/libogg
USES= cmake jpeg openal:soft pkgconfig tar:bzip2
-USE_GL= glu
+USE_GL= gl glu
USE_SDL= sdl
USE_XORG= sm
-USE_GCC= yes
+LLD_UNSAFE= yes
PORTDOCS= README
OPTIONS_DEFINE= DOCS
@@ -39,10 +39,11 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${DATADIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${LN} -sf ${DATADIR}/Data/Textures/Lugaru.png \
+ ${RLN} ${STAGEDIR}${DATADIR}/Data/Textures/Lugaru.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>