aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /games
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'games')
-rw-r--r--games/gnome-sudoku/Makefile2
-rw-r--r--games/qqwing/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/games/gnome-sudoku/Makefile b/games/gnome-sudoku/Makefile
index e35629bdaed1..2879cc0425c9 100644
--- a/games/gnome-sudoku/Makefile
+++ b/games/gnome-sudoku/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libgee-0.8.so:devel/libgee \
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome localbase pathfix \
+USES= compiler:c++11-lang gettext gmake gnome localbase pathfix \
pkgconfig python:3.3+ shebangfix tar:xz
USE_GNOME= cairo gtk30 intlhack libxml2:build pygobject3
INSTALLS_ICONS= yes
diff --git a/games/qqwing/Makefile b/games/qqwing/Makefile
index 09b8e9dad7d0..48567228a712 100644
--- a/games/qqwing/Makefile
+++ b/games/qqwing/Makefile
@@ -3,17 +3,17 @@
PORTNAME= qqwing
PORTVERSION= 1.3.4
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Sudoku generating and solving software
+USES= autoreconf compiler:c++11-lang gmake libtool pathfix pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= stephenostermiller
-USES= autoreconf gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes