aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 12:13:23 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 12:13:23 +0000
commit1c7c3d2208b25ea1ca091a2b3e8cb6b7283feac6 (patch)
tree969d85a11701cc0a743c50f26376c759b7da5a4d /games
parentd65af50a70ba6e7ae6c00df5e9c8a4007c79a964 (diff)
downloadports-1c7c3d2208b25ea1ca091a2b3e8cb6b7283feac6.tar.gz
ports-1c7c3d2208b25ea1ca091a2b3e8cb6b7283feac6.zip
Add an explicit dependency on pkgconf
Notes
Notes: svn path=/head/; revision=326137
Diffstat (limited to 'games')
-rw-r--r--games/atomix/Makefile9
-rw-r--r--games/gdado/Makefile8
-rw-r--r--games/gno3dtet/Makefile3
-rw-r--r--games/gnomeattacks/Makefile3
-rw-r--r--games/gnomebreakout/Makefile2
-rw-r--r--games/gnomekiss/Makefile7
-rw-r--r--games/gnono/Makefile3
-rw-r--r--games/grhino/Makefile10
-rw-r--r--games/gtetrinet/Makefile3
-rw-r--r--games/gtktetcolor/Makefile3
-rw-r--r--games/gturing/Makefile9
-rw-r--r--games/gweled/Makefile8
-rw-r--r--games/teg/Makefile3
13 files changed, 20 insertions, 51 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index 11f27321b460..e892287466bd 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: atomix
-# Date created: 30 January 2000
-# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
-#
+# Created by: Yukihiro Nakai <nakai@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/games/atomix/Makefile,v 1.14 2007/09/10 05:39:33 mezz Exp $
-#
PORTNAME= atomix
PORTVERSION= 2.14.0
@@ -16,9 +12,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A yet another little mind game
-USE_GMAKE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gdado/Makefile b/games/gdado/Makefile
index b7aae564efb5..258daba42969 100644
--- a/games/gdado/Makefile
+++ b/games/gdado/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gdado
-# Date created: 06 May 2007
-# Whom: Anish Mistry <amistry@am-productions.biz>
-#
+# Created by: Anish Mistry <amistry@am-productions.biz>
# $FreeBSD$
-#
PORTNAME= gdado
PORTVERSION= 2.2
@@ -15,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2 dice roller
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE= gmake pkgconfig
USE_GNOME= gnomeprefix gtk20 libgnomeui
post-patch:
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index d4271b5726b6..7caa9f804b35 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -13,9 +13,8 @@ COMMENT= GNOME version of the classic 3D-ified T*tris
EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gnomeprefix intlhack libgnomeui librsvg2
-USE_GMAKE= yes
USE_AUTOTOOLS= autoheader automake aclocal autoconf
ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a -c -f
diff --git a/games/gnomeattacks/Makefile b/games/gnomeattacks/Makefile
index 0eff7267b2a3..ad512c30e1bd 100644
--- a/games/gnomeattacks/Makefile
+++ b/games/gnomeattacks/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME 2 game featuring a bizarre flying GNOME logo
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gnomeprefix gnomevfs2 libgnomeui
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index 455e1a12ff6e..5d79e7391148 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -11,7 +11,7 @@ DISTNAME= gnome-breakout-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME version of the classic breakout game
-USES= pathfix
+USES= pathfix pkgconfig
USE_GNOME= gnomeprefix libgnomeui
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gnomekiss/Makefile b/games/gnomekiss/Makefile
index 8704a966a3a6..7796d8e5f317 100644
--- a/games/gnomekiss/Makefile
+++ b/games/gnomekiss/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnomekiss
-# Date created: 4 Apr 2001
-# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
-#
+# Created by: UMENO Takashi <umeno@rr.iij4u.or.jp>
# $FreeBSD$
-#
PORTNAME= gnomekiss
PORTVERSION= 2.0
@@ -16,6 +12,7 @@ COMMENT= GNOME version of Kisekae Set System
RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha
+USES= pkgconfig
USE_GNOME= gnomeprefix gnomehack libgnomeui
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gnono/Makefile b/games/gnono/Makefile
index 10c49679506a..be3804502115 100644
--- a/games/gnono/Makefile
+++ b/games/gnono/Makefile
@@ -12,8 +12,7 @@ COMMENT= Uno card game
USE_BZIP2= yes
USE_GNOME= gtk20 libgnomeui
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/grhino/Makefile b/games/grhino/Makefile
index 0f09d03a9304..39782bcc3cc7 100644
--- a/games/grhino/Makefile
+++ b/games/grhino/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: grhino
-# Date created: 21 Sep 2002
-# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
-#
+# Created by: UMENO Takashi <umeno@rr.iij4u.or.jp>
# $FreeBSD$
-#
PORTNAME= grhino
PORTVERSION= 0.16.1
@@ -14,9 +10,9 @@ MASTER_SITES= SF/rhino/GRhino/${PORTVERSION}
MAINTAINER= umeno@rr.iij4u.or.jp
COMMENT= GRhino Othello/Reversi Program
-USES= gettext
+USES= gettext pkgconfig perl5
USE_GNOME= gnomeprefix libgnomeui
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index 6b8eb6d2d3d5..811ab25ca954 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -12,9 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Version of the popular TetriNET multiplayer Tetris clone
USE_BZIP2= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= esound gnomeprefix libgnomeui
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/gtktetcolor/Makefile b/games/gtktetcolor/Makefile
index 9b8f12ad2ef8..d95cc18a26b8 100644
--- a/games/gtktetcolor/Makefile
+++ b/games/gtktetcolor/Makefile
@@ -14,9 +14,8 @@ COMMENT= Game for GNOME that resembles well-known Tetris and Columns
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gnomeprefix intlhack libgnomeui
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
index 861b61a0d069..f756eeaacd42 100644
--- a/games/gturing/Makefile
+++ b/games/gturing/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: games/gturing
-# Date created: 08 Jul 2002
-# Whom: Juan Salaverria <rael@vectorstar.net>
-#
+# Created by: Juan Salaverria <rael@vectorstar.net>
# $FreeBSD$
-#
PORTNAME= gturing
PORTVERSION= 0.1.1
@@ -15,8 +11,7 @@ MAINTAINER= sylvio@FreeBSD.org
COMMENT= Simple Turing machine simulator for GNOME 2
USE_GNOME= gnomeprefix gnomehack libgnomeui
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gweled/Makefile b/games/gweled/Makefile
index f4703b3bed11..9034ed6d3f66 100644
--- a/games/gweled/Makefile
+++ b/games/gweled/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gweled
-# Date created: November 28, 2003
-# Whom: James Earl
-#
+# Created by: James Earl
# $FreeBSD$
-#
PORTNAME= gweled
PORTVERSION= 0.7
@@ -16,7 +12,7 @@ COMMENT= GNOME version of the game called "Bejeweled" or "Diamond Mine"
LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
-USE_GMAKE= yes
+USE= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui librsvg2
GNU_CONFIGURE= yes
diff --git a/games/teg/Makefile b/games/teg/Makefile
index 9bbadae4710f..f16ca86e9d3f 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A turn-based strategy game for GNOME
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gnomeprefix intlhack libgnomeui
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib