aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 15:01:13 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 15:01:13 +0000
commit2037c0529426e393bea1735b5585ff25dc85914c (patch)
tree84d08ab50c077b40c6325a552573881240c4f9cc /games
parentdcdc5207d731c56478898efa2eb42ef071b039d3 (diff)
downloadports-2037c0529426e393bea1735b5585ff25dc85914c.tar.gz
ports-2037c0529426e393bea1735b5585ff25dc85914c.zip
- Add stage support
- Use PLIST_FILES instead of pkg-plist
Notes
Notes: svn path=/head/; revision=333696
Diffstat (limited to 'games')
-rw-r--r--games/xhexagons/Makefile14
-rw-r--r--games/xhexagons/pkg-plist2
2 files changed, 7 insertions, 9 deletions
diff --git a/games/xhexagons/Makefile b/games/xhexagons/Makefile
index c34eff55d13f..7fbe7c56e116 100644
--- a/games/xhexagons/Makefile
+++ b/games/xhexagons/Makefile
@@ -14,14 +14,14 @@ COMMENT= Hexagons puzzle (similar to Fifteen Puzzle) for X Window System
WRKSRC= ${WRKDIR}/xhexagons
USES= imake
USE_XORG= x11 xext xt sm ice
-MAN1= xhexagons.1
-XFREE86_HTML_MAN= no
-NO_INSTALL_MANPAGES= yes
-NO_STAGE= yes
+PLIST_FILES= bin/xhexagons \
+ man/man1/xhexagons.1.gz \
+ lib/X11/app-defaults/Hexagons
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xhexagons ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Hexagons.ad ${PREFIX}/lib/X11/app-defaults/Hexagons
- ${INSTALL_MAN} ${WRKSRC}/xhexagons.man ${PREFIX}/man/man1/xhexagons.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xhexagons ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Hexagons.ad ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/Hexagons
+ ${INSTALL_MAN} ${WRKSRC}/xhexagons.man ${STAGEDIR}${PREFIX}/man/man1/xhexagons.1
.include <bsd.port.mk>
diff --git a/games/xhexagons/pkg-plist b/games/xhexagons/pkg-plist
deleted file mode 100644
index dd157c044950..000000000000
--- a/games/xhexagons/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/xhexagons
-lib/X11/app-defaults/Hexagons