aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2019-05-31 13:30:11 +0000
committerKyle Evans <kevans@FreeBSD.org>2019-05-31 13:30:11 +0000
commit29ada2e00b81d8430909ffd4c16d198d3266aa57 (patch)
tree47b68b6806814b090c084e9af30ff15cb28b9179 /games
parent65e3fb58c01778942cb85438ff96201c88b721bc (diff)
downloadports-29ada2e00b81d8430909ffd4c16d198d3266aa57.tar.gz
ports-29ada2e00b81d8430909ffd4c16d198d3266aa57.zip
games/gzdoom: Fix 32-bit build after r501260 (update to 4.1.1)
The update from 3.7.2 -> 4.1.1 included some path restructuring in gzdoom, particularly around rendering bits. A list of source files that need SSE explicitly enabled for 32-bit architectures is included in src/CMakeLists.txt -- this had not been updated post-restructuring, leading to errors like: error: always_inline function '_mm_cvtss_f32' requires target feature 'mmx', but would be inlined into function 'AddLights' that is compiled without support for 'mmx' and failing the build. The patch being added updates the paths. It was submitted for upstreaming and subsequently accepted here: https://github.com/coelckers/gzdoom/pull/850 to appear in a release post-4.1.2. Reported by: pkg-fallout Approved by: koobs (ports), kevans (maintainer)
Notes
Notes: svn path=/head/; revision=503173
Diffstat (limited to 'games')
-rw-r--r--games/gzdoom/files/patch-src_CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/games/gzdoom/files/patch-src_CMakeLists.txt b/games/gzdoom/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..15d9298dca62
--- /dev/null
+++ b/games/gzdoom/files/patch-src_CMakeLists.txt
@@ -0,0 +1,16 @@
+--- src/CMakeLists.txt.orig 2019-05-04 19:58:35 UTC
++++ src/CMakeLists.txt
+@@ -1457,10 +1457,9 @@ if( ZD_CMAKE_COMPILER_IS_GNUCXX_COMPATIBLE )
+ # Need to enable intrinsics for these files.
+ if( SSE_MATTERS )
+ set_source_files_properties(
+- gl/system/gl_swframebuffer.cpp
+- polyrenderer/poly_all.cpp
+- swrenderer/r_all.cpp
+- x86.cpp
++ rendering/polyrenderer/poly_all.cpp
++ rendering/swrenderer/r_all.cpp
++ utility/x86.cpp
+ PROPERTIES COMPILE_FLAGS "-msse2 -mmmx" )
+ endif()
+ endif()