aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-14 01:16:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-14 01:16:08 +0000
commit2b944b0175d3c3b996ef920151e272f28877585a (patch)
treeb20451bddece3f235fb64bbabb9dac7d3be071a1 /games
parent3be3a520470995242bcce1f8851b617c008634c3 (diff)
downloadports-2b944b0175d3c3b996ef920151e272f28877585a.tar.gz
ports-2b944b0175d3c3b996ef920151e272f28877585a.zip
Fix build with clang/libc++
Notes
Notes: svn path=/head/; revision=327205
Diffstat (limited to 'games')
-rw-r--r--games/fishsupper/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/fishsupper/Makefile b/games/fishsupper/Makefile
index 0474fb9e64f0..ead2d3019118 100644
--- a/games/fishsupper/Makefile
+++ b/games/fishsupper/Makefile
@@ -31,6 +31,11 @@ DESKTOP_ENTRIES="Fish Supper" \
.include <bsd.port.options.mk>
+.if ${OSVERSION} > 1000000
+post-patch:
+ @${REINPLACE_CMD} -e 's|std::tr1::shared_ptr|std::shared_ptr|g' ${WRKSRC}/src/*.h ${WRKSRC}/src/*.cpp
+.endif
+
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}