aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-08 21:52:34 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-02-08 21:52:34 +0000
commit350e8445193d65b9933703a7d78499f7208a2b56 (patch)
tree5d4e1a0f599dcf59e96f1bb0e8327d059ca3f05a /games
parent63b098abd07ab92f277946807794e9edb5284699 (diff)
downloadports-350e8445193d65b9933703a7d78499f7208a2b56.tar.gz
ports-350e8445193d65b9933703a7d78499f7208a2b56.zip
games/stratagus: fix build on powerpc
/usr/bin/c++ -DHAVE_GETOPT -DHAVE_STRCASESTR -DHAVE_STRNLEN -DPIXMAPS=\"/usr/local/share/pixmaps\" -DUSE_BSD -DUSE_BZ2LIB -DUSE_MNG -DUSE_THEORA -DUSE_VORBIS -DUSE_ZLIB -I/wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/include -I/wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/guichan/include -I/wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/guichan/include/guichan -I/wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/third_party -I/wrkdirs/usr/ports/games/stratagus/work/.build -I/usr/local/include/lua51 -I/usr/local/include/SDL2 -I/usr/local/include -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -Wno-register -fsigned-char -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -Wno-register -std=gnu++17 -MD -MT CMakeFiles/stratagus.dir/src/map/fow.cpp.o -MF CMakeFiles/stratagus.dir/src/map/fow.cpp.o.d -o CMakeFiles/stratagus.dir/src/map/fow.cpp.o -c /wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/map/fow.cpp /wrkdirs/usr/ports/games/stratagus/work/stratagus-3.2.0/src/map/fow.cpp:39:10: fatal error: 'omp.h' file not found ^~~~~~~
Diffstat (limited to 'games')
-rw-r--r--games/stratagus/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 636d15e370bc..39fafe382c73 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= zenity:x11/zenity
USE_GITHUB= yes
GH_ACCOUNT= Wargus
-USES= cmake compiler:c++17-lang lua:51 pkgconfig sdl
+USES= cmake lua:51 pkgconfig sdl
USE_SDL= sdl2 mixer2 image2
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
@@ -43,6 +43,14 @@ VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
VORBIS_CMAKE_BOOL= WITH_OGGVORBIS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++17-lang
+.endif
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang