aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-01-24 15:07:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-01-24 15:07:39 +0000
commit364abe76fd9eef8f21dfc042689643cc3aee11d1 (patch)
treebf67c1bb6ae5b2f8e4074d102338a30cdf8b4cd8 /games
parent7e9d10e043b551b015afc55d516c1f0d1ee30ab2 (diff)
downloadports-364abe76fd9eef8f21dfc042689643cc3aee11d1.tar.gz
ports-364abe76fd9eef8f21dfc042689643cc3aee11d1.zip
Switch some dependencies from a directory name or a file generated by pkg-install
to a package name, as the former can't be attributed to a package
Notes
Notes: svn path=/head/; revision=377795
Diffstat (limited to 'games')
-rw-r--r--games/doom-data/Makefile.include2
-rw-r--r--games/iourbanterror/Makefile2
-rw-r--r--games/noegnud-littlehack/Makefile2
-rw-r--r--games/noegnud-nethack-deet/Makefile2
-rw-r--r--games/noegnud-nethack/Makefile2
-rw-r--r--games/noegnud-slashem/Makefile2
-rw-r--r--games/quake2-data/Makefile.include2
-rw-r--r--games/uhexen2-extras/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
index 94aaa17126fa..c73dc7faca71 100644
--- a/games/doom-data/Makefile.include
+++ b/games/doom-data/Makefile.include
@@ -12,5 +12,5 @@ PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
SUB_LIST+= DMDIR="${DMDIR}"
.if ${PORTNAME} != "data"
-RUN_DEPENDS+= ${DMDIR}:${PORTSDIR}/games/doom-data
+RUN_DEPENDS+= doom-data>0:${PORTSDIR}/games/doom-data
.endif
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index c9d4d8188429..ce61fcb266f4 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ioquake3-${DISTVERSION}
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Quake 3 engine modified for Urban Terror (based on ioquake3)
-RUN_DEPENDS= ${Q3DIR}/q3ut4:${PORTSDIR}/games/urbanterror-data
+RUN_DEPENDS= urbanterror-data>0:${PORTSDIR}/games/urbanterror-data
MASTERDIR= ${.CURDIR}/../ioquake3
diff --git a/games/noegnud-littlehack/Makefile b/games/noegnud-littlehack/Makefile
index 92174bece2ba..c4f7e88ec683 100644
--- a/games/noegnud-littlehack/Makefile
+++ b/games/noegnud-littlehack/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The noeGNUd UI for the LittleHack variation of Nethack
-RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison tar:bzip2
diff --git a/games/noegnud-nethack-deet/Makefile b/games/noegnud-nethack-deet/Makefile
index fa25afc83835..f4cf078b47d2 100644
--- a/games/noegnud-nethack-deet/Makefile
+++ b/games/noegnud-nethack-deet/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The noeGNUd UI for Nethack with DeeT's hack font patch
-RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison tar:bzip2
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index 8481a2e4229c..7e96fa6c33d6 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The noeGNUd UI for the vanilla Nethack
-RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison gmake tar:bzip2
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
index 3b3527e148ac..0737464537ec 100644
--- a/games/noegnud-slashem/Makefile
+++ b/games/noegnud-slashem/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The noeGNUd UI for the SLASH'EM variant of Nethack
-RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+RUN_DEPENDS= noegnud-data>0:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
USES= bison gmake tar:bzip2
diff --git a/games/quake2-data/Makefile.include b/games/quake2-data/Makefile.include
index 2f52221b769c..427ad958a7a2 100644
--- a/games/quake2-data/Makefile.include
+++ b/games/quake2-data/Makefile.include
@@ -58,5 +58,5 @@ SUB_LIST+= Q2DIR="${Q2DIR}"
.if ${PORTNAME} != data
# Not depending on the particular .pak file since they are OPTIONS-dependent
-RUN_DEPENDS+= ${Q2DIR}:${PORTSDIR}/games/quake2-data
+RUN_DEPENDS+= quake2-data>0:${PORTSDIR}/games/quake2-data
.endif
diff --git a/games/uhexen2-extras/Makefile b/games/uhexen2-extras/Makefile
index 6bab518c79e1..e47f8c3ee28f 100644
--- a/games/uhexen2-extras/Makefile
+++ b/games/uhexen2-extras/Makefile
@@ -16,7 +16,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Hexen II source port extras (demos, mods, etc)
-RUN_DEPENDS= ${DATADIR}:${PORTSDIR}/games/uhexen2
+RUN_DEPENDS= uhexen2>0:${PORTSDIR}/games/uhexen2
NO_BUILD= yes