aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 02:31:18 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 02:31:18 +0000
commit3bc0b4e271bf7e89ad544b05c6cfadbcee14d2d8 (patch)
tree0070e3716809730e83b210e561af3cf37f6f7227 /games
parenta330b821bb9deb2fc77e845fa7cdb5776089b1ef (diff)
downloadports-3bc0b4e271bf7e89ad544b05c6cfadbcee14d2d8.tar.gz
ports-3bc0b4e271bf7e89ad544b05c6cfadbcee14d2d8.zip
- Add stage support
Notes
Notes: svn path=/head/; revision=333646
Diffstat (limited to 'games')
-rw-r--r--games/xdesktopwaves/Makefile5
-rw-r--r--games/xdesktopwaves/files/patch-makefile15
2 files changed, 15 insertions, 5 deletions
diff --git a/games/xdesktopwaves/Makefile b/games/xdesktopwaves/Makefile
index 9d26487e7871..5687c2191b4e 100644
--- a/games/xdesktopwaves/Makefile
+++ b/games/xdesktopwaves/Makefile
@@ -10,10 +10,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Simulation of water waves on the desktop
-MAN1= xdesktopwaves.1
USE_XORG= x11 xext
-PLIST_FILES= bin/xdesktopwaves
+PLIST_FILES= bin/xdesktopwaves \
+ man/man1/xdesktopwaves.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/xdesktopwaves/files/patch-makefile b/games/xdesktopwaves/files/patch-makefile
index a4eacbc64b0f..c0b6eee45581 100644
--- a/games/xdesktopwaves/files/patch-makefile
+++ b/games/xdesktopwaves/files/patch-makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Dec 18 13:47:40 2004
-+++ Makefile Wed Feb 23 22:28:56 2005
+--- ./Makefile.orig 2004-12-18 03:47:40.000000000 -0200
++++ ./Makefile 2013-11-13 00:35:29.000000000 -0200
@@ -11,19 +11,19 @@
#=========================== C compiler configuration ==========================
@@ -26,3 +26,14 @@
INSTALL = install
RM = rm -f -v
+@@ -41,8 +41,8 @@
+ $(RM) xdesktopwaves.o
+
+ install: xdesktopwaves xdesktopwaves.1
+- $(INSTALL) -c -m 0755 -s xdesktopwaves $(BINDIR)/xdesktopwaves
+- $(INSTALL) -c -m 0444 xdesktopwaves.1 $(MAN1DIR)/xdesktopwaves.1
++ $(INSTALL) -c -m 0755 -s xdesktopwaves ${DESTDIR}$(BINDIR)/xdesktopwaves
++ $(INSTALL) -c -m 0444 xdesktopwaves.1 ${DESTDIR}$(MAN1DIR)/xdesktopwaves.1
+
+ uninstall:
+ $(RM) $(BINDIR)/xdesktopwaves