aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-01-23 19:31:26 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-01-23 19:31:26 +0000
commit46d884e87b9e0a1249a033d3a85671531373f34b (patch)
tree2d84d691f0edab863d741a630748ef0375a9d8a2 /games
parent01f3f259fef3a01a9926c0c30271267095668e6b (diff)
downloadports-46d884e87b9e0a1249a033d3a85671531373f34b.tar.gz
ports-46d884e87b9e0a1249a033d3a85671531373f34b.zip
- Update to version 0.B
- Add options for Lua scripting and sound support PR: 196181 Submitted by: Vladimir Kondratiev <wulf@cicgroup.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=377759
Diffstat (limited to 'games')
-rw-r--r--games/cataclysm-dda/Makefile106
-rw-r--r--games/cataclysm-dda/distinfo8
-rw-r--r--games/cataclysm-dda/files/cataclysm.in17
-rw-r--r--games/cataclysm-dda/files/patch-debug.cpp10
-rw-r--r--games/cataclysm-dda/files/patch-src-cata_tiles.cpp12
-rw-r--r--games/cataclysm-dda/files/patch-src-game.cpp33
-rw-r--r--games/cataclysm-dda/files/patch-src-sdltiles.cpp19
-rw-r--r--games/cataclysm-dda/files/patch-src-translations.cpp18
-rw-r--r--games/cataclysm-dda/pkg-plist347
9 files changed, 436 insertions, 134 deletions
diff --git a/games/cataclysm-dda/Makefile b/games/cataclysm-dda/Makefile
index 2562e2a7e3ac..c83edce99565 100644
--- a/games/cataclysm-dda/Makefile
+++ b/games/cataclysm-dda/Makefile
@@ -2,9 +2,13 @@
# $FreeBSD$
PORTNAME= cataclysm-dda
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.B
+PORTEPOCH= 1
CATEGORIES= games
+MASTER_SITES= https://codeload.github.com/${GH_ACCOUNT}/${GH_PROJECT}/legacy.tar.gz/${GH_TAGNAME}?dummy=/:game \
+ http://azmodean.polehammer.com/:sound
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:game
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= wulf@cicgroup.ru
COMMENT= Fork/variant of Cataclysm Roguelike by Whales
@@ -14,75 +18,89 @@ LICENSE_NAME= Creative Commons Attribution-ShareAlike 3.0 Unported License
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= gmake shebangfix
+USES= gmake shebangfix compiler:c++11-lib execinfo
SHEBANG_FILES= lang/*.sh
bash_CMD= /bin/sh
-USE_GITHUB= yes
GH_ACCOUNT= CleverRaven
GH_PROJECT= Cataclysm-DDA
-GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= ebd2393
-MAKE_ARGS+= RELEASE=1
+GH_TAGNAME= ${PORTVERSION}
+GH_COMMIT= 293f250
+MAKE_ARGS+= PREFIX=${PREFIX} RELEASE=1 USE_HOME_DIR=1
CXXFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME} -L${LOCALBASE}/lib -lexecinfo
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= NLS DOCS
-OPTIONS_DEFAULT=NCURSES
+OPTIONS_DEFINE= NLS DOCS LUA SOUND
+OPTIONS_DEFAULT=NLS DOCS NCURSES
OPTIONS_SINGLE= UI
OPTIONS_SINGLE_UI= NCURSES SDL
UI_DESC= User Interface
+SOUND_DESC= Sound support (SDL UI only)
OPTIONS_SUB= yes
-SUB_FILES= cataclysm
REINPLACE_ARGS= -i ''
NCURSES_USES= ncurses
-SDL_USE= SDL=sdl,ttf,image
+SDL_USE= SDL=sdl2,ttf2,image2
+SDL_USES= pkgconfig
SDL_MAKE_ARGS= TILES=1 TILESTARGET=cataclysm
+SDL_FETCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-fonts/terminus-font:patch
+SDL_BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
NLS_USES= gettext
NLS_LDFLAGS= -lintl
-NLS_MAKE_ARGS= L10N=localization
-
-.include <bsd.port.options.mk>
+NLS_MAKE_ARGS= LOCALIZE=1
+LUA_USES= lua:51 pkgconfig
+LUA_MAKE_ARGS= LUA=1
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MSOUND}
+.if ${PORT_OPTIONS:MSDL}
+MAKE_ARGS+= SOUND=1
+USE_SDL+= mixer2
+SOUND_FILES= cataclysmthemeREV6.ogg Dark_Days_Ahead_demo_2.ogg
+DISTFILES+= ${SOUND_FILES:S|$|:sound|}
+.else
+IGNORE= Sound is not supported with ncurses UI.
+.endif
+.endif
+post-patch:
+ ${REINPLACE_CMD} -e '/^ *CXX *=/d ; /^ *LD *=/s/g++/$$(CXX)/ ; \
+ /^ *CXXFLAGS *+*=/s/-O[s0-3]//; /^ *LOCALIZE *=/d ; \
+ s/\(-lncurses\)\(w*\)/\1\2 -ltinfo\2/ ; \
+ s/=$$(PREFIX)\//=$$(DESTDIR)$$(PREFIX)\// ; \
+ /install/s/--mode=/-m / ; s/ -t\( $$(DATA_PREFIX)\)/\1/ ; \
+ /cp -R/s/--no-preserve=ownership// ; \
+ /^ *LUA_BINARY *=/s/lua/${LUA_CMD}/' ${WRKSRC}/Makefile
.if ! ${PORT_OPTIONS:MNLS}
-MAKE_ARGS+= LOCALIZE=0
+ ${REINPLACE_CMD} -e '/LOCALE_DIR/s/^/#/' ${WRKSRC}/Makefile
+.endif
+.if ${PORT_OPTIONS:MNCURSES} && ${NCURSESBASE} == /usr
+ ${REINPLACE_CMD} -e 's/$$(shell ncursesw5-config --libs)/-lncursesw/ ; \
+ /$$(shell ncursesw5-config --cflags)/d' ${WRKSRC}/Makefile
+.endif
+.if ${PORT_OPTIONS:MSDL}
+ ${REINPLACE_CMD} -e '/"file":/s|gfx|${DATADIR}/&|' \
+ ${WRKSRC}/gfx/*/tile_config.json
+ # replace bundled windows version of terminus font with X-compatible one
+ ${CAT} `cd ${PORTSDIR}/x11-fonts/terminus-font; make -V WRKSRC`/ter-u14n.bdf \
+ | bdftopcf | ${GZIP_CMD} > ${WRKSRC}/data/font/terminus.fon
.endif
-post-extract:
- ${RM} ${WRKSRC}/data/.gitignore
-
-post-patch:
- ${REINPLACE_CMD} -e 's|"lang/mo"|"${PREFIX}/share/locale"|' ${WRKSRC}/main.cpp
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|gfx|${DATADIR}/&|' options.cpp \
- sdltiles.cpp cata_tiles.cpp gfx/*/tileset.txt
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|data/json|${DATADIR}/&|' \
- game.cpp init.cpp map.cpp sdltiles.cpp
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|data/raw|${DATADIR}/&|' \
- input.cpp iuse_software_sokoban.cpp
- ${REINPLACE_CMD} -e 's|data/font["/]|${DATADIR}/&| ; \
- s|data/FONTDATA|${DATADIR}/&|' ${WRKSRC}/sdltiles.cpp
- ${REINPLACE_CMD} -e 's|data/motd|${DATADIR}/&| ; \
- s|data/credits|${DATADIR}/&|' ${WRKSRC}/main_menu.cpp
- ${REINPLACE_CMD} -e '/^CXX *=/d ; /^LD *=/s/g++/$$(CXX)/ ; \
- /OTHERS += -O3/d ; s/\(-lncurses\)\(w*\)/\1\2 -ltinfo\2/ ; \
- /^WARNINGS *=/d' ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/cataclysm ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/cataclysm ${STAGEDIR}${PREFIX}/libexec
-.for dir in data gfx
- cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
-.endfor
-.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC}/lang/mo && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/locale
+post-install:
+.if ${PORT_OPTIONS:MSOUND}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} sound ${STAGEDIR}${DATADIR}
+ cd ${DISTDIR} && \
+ ${INSTALL_DATA} ${SOUND_FILES} ${STAGEDIR}${DATADIR}/sound
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${FIND} ${WRKSRC} \( -name "*.md" -or -name "*.txt" \) \
-exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/ \;
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/cataclysm-dda/distinfo b/games/cataclysm-dda/distinfo
index ee8a1f055083..3d366de2c99c 100644
--- a/games/cataclysm-dda/distinfo
+++ b/games/cataclysm-dda/distinfo
@@ -1,2 +1,6 @@
-SHA256 (cataclysm-dda-0.9.tar.gz) = d57455c9f2abdd50a26424d131048276efdc68d3c2d4f22b4bdde903cc0f30be
-SIZE (cataclysm-dda-0.9.tar.gz) = 7219436
+SHA256 (cataclysm-dda-0.B.tar.gz) = 4e18e7a028918fea58dd6b74ef680747df98cbc638d8d0a2d5794a3bf5108b8e
+SIZE (cataclysm-dda-0.B.tar.gz) = 21836678
+SHA256 (cataclysmthemeREV6.ogg) = fa305afea557b27ed341f6a10dcfab5aa07ecdd92e42b4dddec61eccb3c1c77f
+SIZE (cataclysmthemeREV6.ogg) = 7964468
+SHA256 (Dark_Days_Ahead_demo_2.ogg) = 75fe6b792ab06b842add070989acb9fe62f0acc5c17f344d724d774a772a68d4
+SIZE (Dark_Days_Ahead_demo_2.ogg) = 9182431
diff --git a/games/cataclysm-dda/files/cataclysm.in b/games/cataclysm-dda/files/cataclysm.in
deleted file mode 100644
index cd3ed1fd0d4e..000000000000
--- a/games/cataclysm-dda/files/cataclysm.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-
-BIN=%%PREFIX%%/libexec/cataclysm
-
-die () {
- echo `basename $0`" failed: $1"
- exit 1
-}
-
-if [ "x$HOME" = "x" ]; then
- HOME=`getent passwd $(id -nu) | cut -d: -f6`
-fi
-test "x$HOME" = "x" && die "HOME directory is not found"
-
-GAMEDIR=$HOME/.cataclysm
-mkdir -p $GAMEDIR/data || die "Can\`t create $GAMEDIR/data directory"
-cd $GAMEDIR && exec $BIN $@
diff --git a/games/cataclysm-dda/files/patch-debug.cpp b/games/cataclysm-dda/files/patch-debug.cpp
deleted file mode 100644
index 0a9355ddd827..000000000000
--- a/games/cataclysm-dda/files/patch-debug.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- debug.cpp.orig 2013-11-26 02:52:18.384654297 +0400
-+++ debug.cpp 2013-11-26 02:52:27.078654024 +0400
-@@ -8,7 +8,6 @@
-
-
- #if !(defined _WIN32 || defined WINDOWS || defined __CYGWIN__)
--#include <execinfo.h>
- #include <stdlib.h>
- #endif
-
diff --git a/games/cataclysm-dda/files/patch-src-cata_tiles.cpp b/games/cataclysm-dda/files/patch-src-cata_tiles.cpp
new file mode 100644
index 000000000000..54d8184f96b3
--- /dev/null
+++ b/games/cataclysm-dda/files/patch-src-cata_tiles.cpp
@@ -0,0 +1,12 @@
+--- src/cata_tiles.cpp.orig 2014-11-17 06:09:38.000000000 +0300
++++ src/cata_tiles.cpp 2014-11-30 11:56:51.119502150 +0300
+@@ -164,9 +164,6 @@ void cata_tiles::get_tile_information(st
+ int cata_tiles::load_tileset(std::string path, int R, int G, int B)
+ {
+ std::string img_path = path;
+-#ifdef PREFIX // use the PREFIX path over the current directory
+- img_path = (FILENAMES["datadir"] + "/" + img_path);
+-#endif
+ /** reinit tile_atlas */
+ SDL_Surface *tile_atlas = IMG_Load(img_path.c_str());
+
diff --git a/games/cataclysm-dda/files/patch-src-game.cpp b/games/cataclysm-dda/files/patch-src-game.cpp
new file mode 100644
index 000000000000..884a7be30db5
--- /dev/null
+++ b/games/cataclysm-dda/files/patch-src-game.cpp
@@ -0,0 +1,33 @@
+--- src/game.cpp.orig 2014-11-17 06:09:38.000000000 +0300
++++ src/game.cpp 2014-11-23 14:15:08.005205207 +0300
+@@ -4535,15 +4535,17 @@ std::vector<std::string> game::list_acti
+ void game::write_memorial_file(std::string sLastWords)
+ {
+
++ std::string memorialdir = FILENAMES["memorialdir"];
++
+ //Open the file first
+- DIR *dir = opendir("memorial");
++ DIR *dir = opendir(memorialdir.c_str());
+ if (!dir) {
+ #if (defined _WIN32 || defined __WIN32__)
+- mkdir("memorial");
++ mkdir(memorialdir.c_str());
+ #else
+- mkdir("memorial", 0777);
++ mkdir(memorialdir.c_str(), 0777);
+ #endif
+- dir = opendir("memorial");
++ dir = opendir(memorialdir.c_str());
+ if (!dir) {
+ dbg(D_ERROR) << "game:write_memorial_file: Unable to make memorial directory.";
+ debugmsg("Could not make './memorial' directory");
+@@ -4581,7 +4583,7 @@ void game::write_memorial_file(std::stri
+ }
+
+ //Omit the name if too many unusable characters stripped
+- std::string memorial_file_path = string_format("memorial/%s%s.txt",
++ std::string memorial_file_path = string_format((memorialdir + "%s%s.txt").c_str(),
+ player_name.str().length() <= (u.name.length() / 5) ? "" : player_name.str().c_str(),
+ timestamp.c_str());
+
diff --git a/games/cataclysm-dda/files/patch-src-sdltiles.cpp b/games/cataclysm-dda/files/patch-src-sdltiles.cpp
new file mode 100644
index 000000000000..ec452e0c56b9
--- /dev/null
+++ b/games/cataclysm-dda/files/patch-src-sdltiles.cpp
@@ -0,0 +1,19 @@
+--- src/sdltiles.cpp.orig 2014-11-17 06:09:38.000000000 +0300
++++ src/sdltiles.cpp 2014-11-30 13:31:51.462125514 +0300
+@@ -1,4 +1,5 @@
+ #if (defined TILES)
++#include <sys/param.h>
+ #include "catacurse.h"
+ #include "options.h"
+ #include "output.h"
+@@ -1213,8 +1214,8 @@ static void save_font_list()
+ wordexp("~/Library/Fonts", &exp, 0);
+ font_folder_list(fout, exp.we_wordv[0]);
+ wordfree(&exp);*/
+-#elif (defined linux || defined __linux)
+- font_folder_list(fout, "/usr/share/fonts");
++#elif (defined linux || defined __linux || defined __FreeBSD__)
++ font_folder_list(fout, "/usr/local/lib/X11/fonts");
+ font_folder_list(fout, "/usr/local/share/fonts");
+ wordexp_t exp;
+ wordexp("~/.fonts", &exp, 0);
diff --git a/games/cataclysm-dda/files/patch-src-translations.cpp b/games/cataclysm-dda/files/patch-src-translations.cpp
new file mode 100644
index 000000000000..7aaa30f28fab
--- /dev/null
+++ b/games/cataclysm-dda/files/patch-src-translations.cpp
@@ -0,0 +1,18 @@
+--- src/translations.cpp.orig 2014-11-17 06:09:38.000000000 +0300
++++ src/translations.cpp 2014-11-30 13:22:06.603147068 +0300
+@@ -1,5 +1,6 @@
+ #include "translations.h"
+
++#include <sys/param.h>
+ #include <string>
+ #ifdef LOCALIZE
+ #undef __STRICT_ANSI__ // _putenv in minGW need that
+@@ -72,7 +73,7 @@ void set_language(bool reload_options)
+
+ // Step 2. Bind to gettext domain.
+ const char *locale_dir;
+-#ifdef __linux__
++#if (defined __linux__ || defined __FreeBSD__)
+ if (!FILENAMES["base_path"].empty()) {
+ locale_dir = std::string(FILENAMES["base_path"] + "share/locale").c_str();
+ } else {
diff --git a/games/cataclysm-dda/pkg-plist b/games/cataclysm-dda/pkg-plist
index c863b3fb3106..540d13ed8f94 100644
--- a/games/cataclysm-dda/pkg-plist
+++ b/games/cataclysm-dda/pkg-plist
@@ -1,67 +1,278 @@
bin/cataclysm
-libexec/cataclysm
-%%DATADIR%%/data/FONTDATA
-%%DATADIR%%/data/cataicon.ico
-%%DATADIR%%/data/changelog.txt
-%%DATADIR%%/data/credits
-%%DATADIR%%/data/font/fixedsys.ttf
-%%DATADIR%%/data/font/terminus.fon
-%%DATADIR%%/data/json/bionics.json
-%%DATADIR%%/data/json/colors.json
-%%DATADIR%%/data/json/dreams.json
-%%DATADIR%%/data/json/furniture.json
-%%DATADIR%%/data/json/halloween_special.json
-%%DATADIR%%/data/json/hints.json
-%%DATADIR%%/data/json/item_groups.json
-%%DATADIR%%/data/json/items/ammo.json
-%%DATADIR%%/data/json/items/archery.json
-%%DATADIR%%/data/json/items/armor.json
-%%DATADIR%%/data/json/items/books.json
-%%DATADIR%%/data/json/items/comestibles.json
-%%DATADIR%%/data/json/items/containers.json
-%%DATADIR%%/data/json/items/instruments.json
-%%DATADIR%%/data/json/items/melee.json
-%%DATADIR%%/data/json/items/mods.json
-%%DATADIR%%/data/json/items/ranged.json
-%%DATADIR%%/data/json/items/tools.json
-%%DATADIR%%/data/json/items/vehicle_parts.json
-%%DATADIR%%/data/json/lab_notes.json
-%%DATADIR%%/data/json/martialarts.json
-%%DATADIR%%/data/json/materials.json
-%%DATADIR%%/data/json/migo_speech.json
-%%DATADIR%%/data/json/monstergroups.json
-%%DATADIR%%/data/json/monsters.json
-%%DATADIR%%/data/json/mutations.json
-%%DATADIR%%/data/json/names.json
-%%DATADIR%%/data/json/professions.json
-%%DATADIR%%/data/json/recipes.json
-%%DATADIR%%/data/json/skills.json
-%%DATADIR%%/data/json/snippets.json
-%%DATADIR%%/data/json/species.json
-%%DATADIR%%/data/json/techniques.json
-%%DATADIR%%/data/json/terrain.json
-%%DATADIR%%/data/json/tool_qualities.json
-%%DATADIR%%/data/json/tutorial.json
-%%DATADIR%%/data/json/vehicle_parts.json
-%%DATADIR%%/data/json/vehicles.json
-%%DATADIR%%/data/motd
-%%DATADIR%%/data/raw/keybindings.json
-%%DATADIR%%/data/raw/sokoban.txt
-%%DATADIR%%/gfx/DeonTileset/deontiles.png
-%%DATADIR%%/gfx/DeonTileset/tile_config.json
-%%DATADIR%%/gfx/DeonTileset/tileset.txt
-%%DATADIR%%/gfx/HoderTileset/hodertiles.png
-%%DATADIR%%/gfx/HoderTileset/tile_config.json
-%%DATADIR%%/gfx/HoderTileset/tileset.txt
-%%DATADIR%%/gfx/TsuTileset/tile_config.json
-%%DATADIR%%/gfx/TsuTileset/tileset.txt
-%%DATADIR%%/gfx/TsuTileset/tsutiles.png
-%%DATADIR%%/gfx/tile.png
-%%DATADIR%%/gfx/tile_config.json
-%%DATADIR%%/gfx/tile_config_template.json
-%%DATADIR%%/gfx/tinytile.png
+%%DATADIR%%/LICENSE.txt
+%%DATADIR%%/README.txt
+%%DATADIR%%/cataicon.ico
+%%DATADIR%%/changelog.txt
+%%DATADIR%%/credits/de.credits
+%%DATADIR%%/credits/en.credits
+%%DATADIR%%/credits/es_AR.credits
+%%DATADIR%%/credits/ru.credits
+%%DATADIR%%/font/fixedsys.ttf
+%%DATADIR%%/font/square.ttf
+%%DATADIR%%/font/terminus.fon
+%%DATADIR%%/fontdata.json
+%%SDL%%%%DATADIR%%/gfx/BlockheadTileset/blockheadtiles.png
+%%SDL%%%%DATADIR%%/gfx/BlockheadTileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/BlockheadTileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/DeonTileset/deontiles.png
+%%SDL%%%%DATADIR%%/gfx/DeonTileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/DeonTileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/HoderTileset/hodertiles.png
+%%SDL%%%%DATADIR%%/gfx/HoderTileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/HoderTileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/MShock24Tileset/fallback.png
+%%SDL%%%%DATADIR%%/gfx/MShock24Tileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/MShock24Tileset/tiles.png
+%%SDL%%%%DATADIR%%/gfx/MShock24Tileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/MShock32Tileset/fallback.png
+%%SDL%%%%DATADIR%%/gfx/MShock32Tileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/MShock32Tileset/tiles.png
+%%SDL%%%%DATADIR%%/gfx/MShock32Tileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/RetroASCIITileset/retroasciitiles.png
+%%SDL%%%%DATADIR%%/gfx/RetroASCIITileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/RetroASCIITileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset10/retrodaysfallback10.png
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset10/retrodaystiles10.png
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset10/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset10/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset20/retrodaysfallback20.png
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset20/retrodaystiles20.png
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset20/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/RetroDaysTileset20/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/ThuztorTileset@/thuztortiles@.png
+%%SDL%%%%DATADIR%%/gfx/ThuztorTileset@/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/ThuztorTileset@/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/TsuTileset/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/TsuTileset/tileset.txt
+%%SDL%%%%DATADIR%%/gfx/TsuTileset/tsutiles.png
+%%SDL%%%%DATADIR%%/gfx/tile.png
+%%SDL%%%%DATADIR%%/gfx/tile_config.json
+%%SDL%%%%DATADIR%%/gfx/tile_config_template.json
+%%SDL%%%%DATADIR%%/gfx/tinytile.png
+%%DATADIR%%/json/LOADING_ORDER.md
+%%DATADIR%%/json/bionics.json
+%%DATADIR%%/json/boxing.json
+%%DATADIR%%/json/bullet_pulling.json
+%%DATADIR%%/json/construction.json
+%%DATADIR%%/json/doll_speech.json
+%%DATADIR%%/json/dreams.json
+%%DATADIR%%/json/effects.json
+%%DATADIR%%/json/fish.json
+%%DATADIR%%/json/furniture.json
+%%DATADIR%%/json/furniture/ags_furniture.json
+%%DATADIR%%/json/hints.json
+%%DATADIR%%/json/item_groups.json
+%%DATADIR%%/json/items/ags_items.json
+%%DATADIR%%/json/items/ammo.json
+%%DATADIR%%/json/items/ammo_types.json
+%%DATADIR%%/json/items/archery.json
+%%DATADIR%%/json/items/armor.json
+%%DATADIR%%/json/items/bionics.json
+%%DATADIR%%/json/items/books.json
+%%DATADIR%%/json/items/comestibles.json
+%%DATADIR%%/json/items/containers.json
+%%DATADIR%%/json/items/gi.json
+%%DATADIR%%/json/items/handloaded_bullets.json
+%%DATADIR%%/json/items/martial_arts_manuals.json
+%%DATADIR%%/json/items/melee.json
+%%DATADIR%%/json/items/mods.json
+%%DATADIR%%/json/items/newspaper.json
+%%DATADIR%%/json/items/ranged.json
+%%DATADIR%%/json/items/tool_armor.json
+%%DATADIR%%/json/items/tools.json
+%%DATADIR%%/json/items/var_vehicle_parts.json
+%%DATADIR%%/json/items/vehicle_parts.json
+%%DATADIR%%/json/lab_notes.json
+%%DATADIR%%/json/main.lua
+%%DATADIR%%/json/map_extra_items.json
+%%DATADIR%%/json/mapgen/Prepper_house01.json
+%%DATADIR%%/json/mapgen/ags_station.json
+%%DATADIR%%/json/mapgen/antique_store.json
+%%DATADIR%%/json/mapgen/arcade.json
+%%DATADIR%%/json/mapgen/bandit_cabin.json
+%%DATADIR%%/json/mapgen/bandit_camp.json
+%%DATADIR%%/json/mapgen/bar.json
+%%DATADIR%%/json/mapgen/bowling_alley.json
+%%DATADIR%%/json/mapgen/cabin03.json
+%%DATADIR%%/json/mapgen/coffee_shop.json
+%%DATADIR%%/json/mapgen/diner.json
+%%DATADIR%%/json/mapgen/dojo.json
+%%DATADIR%%/json/mapgen/electronics1.json
+%%DATADIR%%/json/mapgen/evac_center.json
+%%DATADIR%%/json/mapgen/fire_station.json
+%%DATADIR%%/json/mapgen/fortified_house01.json
+%%DATADIR%%/json/mapgen/gardening_store.json
+%%DATADIR%%/json/mapgen/grocery1.json
+%%DATADIR%%/json/mapgen/gunsmith.json
+%%DATADIR%%/json/mapgen/gunstore_home_defense.json
+%%DATADIR%%/json/mapgen/gym.json
+%%DATADIR%%/json/mapgen/homeimprovement.json
+%%DATADIR%%/json/mapgen/house04.json
+%%DATADIR%%/json/mapgen/house05.json
+%%DATADIR%%/json/mapgen/house05_ab.json
+%%DATADIR%%/json/mapgen/house06.json
+%%DATADIR%%/json/mapgen/house07.json
+%%DATADIR%%/json/mapgen/house08.json
+%%DATADIR%%/json/mapgen/house09 .json
+%%DATADIR%%/json/mapgen/house10.json
+%%DATADIR%%/json/mapgen/house11.json
+%%DATADIR%%/json/mapgen/house_duplex.json
+%%DATADIR%%/json/mapgen/house_garage.json
+%%DATADIR%%/json/mapgen/house_garage2.json
+%%DATADIR%%/json/mapgen/house_garage3.json
+%%DATADIR%%/json/mapgen/house_garage4.json
+%%DATADIR%%/json/mapgen/house_garage5.json
+%%DATADIR%%/json/mapgen/house_library.json
+%%DATADIR%%/json/mapgen/house_modern_lx.json
+%%DATADIR%%/json/mapgen/house_patio.json
+%%DATADIR%%/json/mapgen/house_porch.json
+%%DATADIR%%/json/mapgen/house_rv.json
+%%DATADIR%%/json/mapgen/house_tool_shed.json
+%%DATADIR%%/json/mapgen/jewel_store.json
+%%DATADIR%%/json/mapgen/mall.json
+%%DATADIR%%/json/mapgen/meth_lab.json
+%%DATADIR%%/json/mapgen/motel.json
+%%DATADIR%%/json/mapgen/museum.json
+%%DATADIR%%/json/mapgen/necropolis.json
+%%DATADIR%%/json/mapgen/necropolisB1.json
+%%DATADIR%%/json/mapgen/pharmacy_1.json
+%%DATADIR%%/json/mapgen/pharmacy_1_open.json
+%%DATADIR%%/json/mapgen/pizza_parlor.json
+%%DATADIR%%/json/mapgen/power_station_large.json
+%%DATADIR%%/json/mapgen/power_station_small.json
+%%DATADIR%%/json/mapgen/restaurant.json
+%%DATADIR%%/json/mapgen/restaurant2.json
+%%DATADIR%%/json/mapgen/restaurant_fast.json
+%%DATADIR%%/json/mapgen/sai.json
+%%DATADIR%%/json/mapgen/warehouse.json
+%%DATADIR%%/json/martialarts.json
+%%DATADIR%%/json/materials.json
+%%DATADIR%%/json/monster_drops.json
+%%DATADIR%%/json/monstergroups.json
+%%DATADIR%%/json/monsters.json
+%%DATADIR%%/json/mutations.json
+%%DATADIR%%/json/npcs/NC_ARSONIST.json
+%%DATADIR%%/json/npcs/NC_BOUNTY_HUNTER.json
+%%DATADIR%%/json/npcs/NC_COWBOY.json
+%%DATADIR%%/json/npcs/NC_DOCTOR.json
+%%DATADIR%%/json/npcs/NC_EVAC_SHOPKEEP.json
+%%DATADIR%%/json/npcs/NC_HACKER.json
+%%DATADIR%%/json/npcs/NC_HUNTER.json
+%%DATADIR%%/json/npcs/NC_NINJA.json
+%%DATADIR%%/json/npcs/NC_SCAVENGER.json
+%%DATADIR%%/json/npcs/NC_SCIENTIST.json
+%%DATADIR%%/json/npcs/NC_THUG.json
+%%DATADIR%%/json/npcs/NC_TRADER.json
+%%DATADIR%%/json/npcs/factions.json
+%%DATADIR%%/json/npcs/items_generic.json
+%%DATADIR%%/json/npcs/npc.json
+%%DATADIR%%/json/overmap_specials.json
+%%DATADIR%%/json/overmap_terrain.json
+%%DATADIR%%/json/preload.lua
+%%DATADIR%%/json/professions.json
+%%DATADIR%%/json/recipes/recipe_ammo.json
+%%DATADIR%%/json/recipes/recipe_armor.json
+%%DATADIR%%/json/recipes/recipe_deconstruction.json
+%%DATADIR%%/json/recipes/recipe_electronics.json
+%%DATADIR%%/json/recipes/recipe_food.json
+%%DATADIR%%/json/recipes/recipe_medsandchemicals.json
+%%DATADIR%%/json/recipes/recipe_others.json
+%%DATADIR%%/json/recipes/recipe_weapon.json
+%%DATADIR%%/json/recipes/recipes.json
+%%DATADIR%%/json/regional_map_settings.json
+%%DATADIR%%/json/scenarios/scenarios.json
+%%DATADIR%%/json/skills.json
+%%DATADIR%%/json/snippets.json
+%%DATADIR%%/json/species.json
+%%DATADIR%%/json/speech.json
+%%DATADIR%%/json/start_locations.json
+%%DATADIR%%/json/techniques.json
+%%DATADIR%%/json/terrain.json
+%%DATADIR%%/json/terrain/ags_terrain.json
+%%DATADIR%%/json/test_regions.json
+%%DATADIR%%/json/tool_qualities.json
+%%DATADIR%%/json/traps.json
+%%DATADIR%%/json/tutorial.json
+%%DATADIR%%/json/vehicle_parts.json
+%%DATADIR%%/json/vehicles/vehicles.json
+%%LUA%%%%DATADIR%%/lua/autoexec.lua
+%%LUA%%%%DATADIR%%/lua/class_definitions.lua
+%%DATADIR%%/mods/AutoGasStations/modinfo.json
+%%DATADIR%%/mods/Boats/b_inflatable_boat_parts.json
+%%DATADIR%%/mods/Boats/b_item_groups.json
+%%DATADIR%%/mods/Boats/b_items.json
+%%DATADIR%%/mods/Boats/b_recipes.json
+%%DATADIR%%/mods/Boats/b_var_veh_parts.json
+%%DATADIR%%/mods/Boats/b_var_wood_veh_parts.json
+%%DATADIR%%/mods/Boats/b_vehicles.json
+%%DATADIR%%/mods/Boats/b_wooden_boat_parts.json
+%%DATADIR%%/mods/Boats/modinfo.json
+%%DATADIR%%/mods/DinoMod/dinosaur.json
+%%DATADIR%%/mods/DinoMod/fieldoffice.json
+%%DATADIR%%/mods/DinoMod/modinfo.json
+%%DATADIR%%/mods/DinoMod/regional_map_settings.json
+%%DATADIR%%/mods/EW_Pack/ew_ammo.json
+%%DATADIR%%/mods/EW_Pack/ew_ammo_handloaded.json
+%%DATADIR%%/mods/EW_Pack/ew_ammo_t.json
+%%DATADIR%%/mods/EW_Pack/ew_books.json
+%%DATADIR%%/mods/EW_Pack/ew_bullet_pulling.json
+%%DATADIR%%/mods/EW_Pack/ew_item_groups.json
+%%DATADIR%%/mods/EW_Pack/ew_mods.json
+%%DATADIR%%/mods/EW_Pack/ew_recipes.json
+%%DATADIR%%/mods/EW_Pack/ew_retool.json
+%%DATADIR%%/mods/EW_Pack/ew_weapons.json
+%%DATADIR%%/mods/EW_Pack/modinfo.json
+%%DATADIR%%/mods/Experimental_Z-Level/2fmotel.json
+%%DATADIR%%/mods/Experimental_Z-Level/modinfo.json
+%%DATADIR%%/mods/Experimental_Z-Level/office_tower.json
+%%DATADIR%%/mods/Experimental_Z-Level/overmap_specials.json
+%%DATADIR%%/mods/Experimental_Z-Level/overmap_terrain.json
+%%DATADIR%%/mods/Fast_Zombies/main.lua
+%%DATADIR%%/mods/Fast_Zombies/modinfo.json
+%%DATADIR%%/mods/Medieval_pack/modinfo.json
+%%DATADIR%%/mods/Mundane_Zombies/modinfo.json
+%%DATADIR%%/mods/No_Energy_Weapons/modinfo.json
+%%DATADIR%%/mods/No_Flaming_Weapons/modinfo.json
+%%DATADIR%%/mods/No_Medieval_Items/modinfo.json
+%%DATADIR%%/mods/No_Mutagen/modinfo.json
+%%DATADIR%%/mods/No_Old_guns/modinfo.json
+%%DATADIR%%/mods/No_Powered_Armor/modinfo.json
+%%DATADIR%%/mods/No_Religious_Books/modinfo.json
+%%DATADIR%%/mods/No_Reviving/main.lua
+%%DATADIR%%/mods/No_Reviving/modinfo.json
+%%DATADIR%%/mods/No_Rivtech_Guns/modinfo.json
+%%DATADIR%%/mods/No_Survivor_Armor/modinfo.json
+%%DATADIR%%/mods/No_Survivor_Armor/survivor.json
+%%DATADIR%%/mods/Only_Wildlife/modinfo.json
+%%DATADIR%%/mods/RL_Classes/classes.json
+%%DATADIR%%/mods/RL_Classes/modinfo.json
+%%DATADIR%%/mods/Remote_Control/modinfo.json
+%%DATADIR%%/mods/Slow_Zombies/main.lua
+%%DATADIR%%/mods/Slow_Zombies/modinfo.json
+%%DATADIR%%/mods/dev-default-mods.json
+%%DATADIR%%/mods/old_guns/modinfo.json
+%%DATADIR%%/motd/de.motd
+%%DATADIR%%/motd/en.motd
+%%DATADIR%%/motd/es_AR.motd
+%%DATADIR%%/motd/ru.motd
+%%DATADIR%%/names/en.json
+%%DATADIR%%/names/fr.json
+%%DATADIR%%/names/ja.json
+%%DATADIR%%/names/ko.json
+%%DATADIR%%/names/ru.json
+%%DATADIR%%/names/zh_CN.json
+%%DATADIR%%/names/zh_TW.json
+%%DATADIR%%/raw/colors.json
+%%DATADIR%%/raw/keybindings.json
+%%DATADIR%%/raw/sokoban.txt
+%%DATADIR%%/recycling/halloween_special.json
+%%DATADIR%%/recycling/instruments.json
+%%SOUND%%%%DATADIR%%/sound/Dark_Days_Ahead_demo_2.ogg
+%%SOUND%%%%DATADIR%%/sound/cataclysmthemeREV6.ogg
+%%SOUND%%%%DATADIR%%/sound/soundset.json
%%PORTDOCS%%%%DOCSDIR%%/CMakeLists.txt
%%PORTDOCS%%%%DOCSDIR%%/CODE_STYLE.txt
+%%PORTDOCS%%%%DOCSDIR%%/COMPILER_SUPPORT.md
%%PORTDOCS%%%%DOCSDIR%%/COMPILING.md
%%PORTDOCS%%%%DOCSDIR%%/COMPILING_osx.md
%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTING.md
@@ -69,10 +280,17 @@ libexec/cataclysm
%%PORTDOCS%%%%DOCSDIR%%/ENUMS.md
%%PORTDOCS%%%%DOCSDIR%%/GAMEMODES.md
%%PORTDOCS%%%%DOCSDIR%%/GAME_BALANCE.txt
+%%PORTDOCS%%%%DOCSDIR%%/ITEM_SPAWN.md
+%%PORTDOCS%%%%DOCSDIR%%/JSON_FLAGS.md
%%PORTDOCS%%%%DOCSDIR%%/JSON_INFO.md
+%%PORTDOCS%%%%DOCSDIR%%/JSON_LOADING_ORDER.md
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/LOADING_ORDER.md
+%%PORTDOCS%%%%DOCSDIR%%/LUA_SUPPORT.md
+%%PORTDOCS%%%%DOCSDIR%%/MAPGEN.md
%%PORTDOCS%%%%DOCSDIR%%/MODDING.txt
%%PORTDOCS%%%%DOCSDIR%%/OLD_TODO.txt
+%%PORTDOCS%%%%DOCSDIR%%/PLAYER_ACTIVITY.md
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/README_all_translators.txt
@@ -81,16 +299,23 @@ libexec/cataclysm
%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
%%PORTDOCS%%%%DOCSDIR%%/de.txt
%%PORTDOCS%%%%DOCSDIR%%/doxygen_conf.txt
+%%PORTDOCS%%%%DOCSDIR%%/freenode.txt
+%%PORTDOCS%%%%DOCSDIR%%/office_ascii_map.txt
%%PORTDOCS%%%%DOCSDIR%%/sokoban.txt
%%PORTDOCS%%%%DOCSDIR%%/tileset.txt
%%NLS%%share/locale/cs/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/de/LC_MESSAGES/cataclysm-dda.mo
+%%NLS%%share/locale/es_AR/LC_MESSAGES/cataclysm-dda.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/cataclysm-dda.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/fr/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/it/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/ja/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/ko/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/pl/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/pt/LC_MESSAGES/cataclysm-dda.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/cataclysm-dda.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/ru/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/sr/LC_MESSAGES/cataclysm-dda.mo
%%NLS%%share/locale/vi/LC_MESSAGES/cataclysm-dda.mo