aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-20 21:05:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-20 21:05:37 +0000
commit47ebae21bcf074d4df157de57649fd89ed8ecbab (patch)
treef129d44b05a57e7137d5039b066d75509c3ff2c9 /games
parentc009229106669185f1025495817b928896cd19d3 (diff)
downloadports-47ebae21bcf074d4df157de57649fd89ed8ecbab.tar.gz
ports-47ebae21bcf074d4df157de57649fd89ed8ecbab.zip
- Update to 0.15.1
- Add LICENSE - Install .desktop file and icon - Use options helpers PR: 194731 Submitted by: lightside@gmx.com
Notes
Notes: svn path=/head/; revision=372961
Diffstat (limited to 'games')
-rw-r--r--games/freedroidrpg/Makefile51
-rw-r--r--games/freedroidrpg/distinfo4
-rw-r--r--games/freedroidrpg/pkg-plist1
3 files changed, 28 insertions, 28 deletions
diff --git a/games/freedroidrpg/Makefile b/games/freedroidrpg/Makefile
index 6d6feb000f4d..f8262bf750b7 100644
--- a/games/freedroidrpg/Makefile
+++ b/games/freedroidrpg/Makefile
@@ -2,54 +2,53 @@
# $FreeBSD$
PORTNAME= freedroidrpg
-PORTVERSION= 0.15
-PORTREVISION= 6
+PORTVERSION= 0.15.1
CATEGORIES= games
-MASTER_SITES= SF/freedroid/freedroidRPG/freedroidRPG-${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\\1/}/
+MASTER_SITES= SF/freedroid/${SF_NAME}/${SF_NAME}-${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\\1/}/
+DISTNAME= ${SF_NAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Modification of the classical Freedroid engine into an RPG
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_sparc64= Does not configure on sparc64
+
GNU_CONFIGURE= yes
USES= gmake lua:51
USE_SDL= sdl image mixer gfx
CONFIGURE_ENV= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}"
USE_GCC= any # doesn't build with clang
+SF_NAME= freedroidRPG
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
PORTDATA= *
+DESKTOP_ENTRIES="FreedroidRPG" "" \
+ "${PORTNAME}" "${SF_NAME}" \
+ "Game;RolePlaying;" false
+
OPTIONS_DEFINE= BACKTRACE OPENGL VORBIS
+OPTIONS_DEFAULT=BACKTRACE OPENGL VORBIS
BACKTRACE_DESC= Use backtrace() to generate nice bug reports
-OPTIONS_DEFAULT=BACKTRACE OPENGL VORBIS
+BACKTRACE_LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+BACKTRACE_CONFIGURE_ENABLE= backtrace
+OPENGL_USE= GL=gl
+OPENGL_CONFIGURE_ENABLE= opengl
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libogg.so:${PORTSDIR}/audio/libogg
+VORBIS_CONFIGURE_ENABLE= vorbis
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBACKTRACE}
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-CONFIGURE_ARGS+=--enable-backtrace
STRIP= #
-.else
-CONFIGURE_ARGS+=--disable-backtrace
.endif
-.if ${PORT_OPTIONS:MOPENGL}
-USE_GL= yes
-CONFIGURE_ARGS+=--enable-opengl
-.else
-CONFIGURE_ARGS+=--disable-opengl
-.endif
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libogg.so:${PORTSDIR}/audio/libogg
-CONFIGURE_ARGS+=--enable-vorbis
-.else
-CONFIGURE_ARGS+=--disable-vorbis
-.endif
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not configure on sparc64
-.endif
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/win32/w32icon2_64x64.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/games/freedroidrpg/distinfo b/games/freedroidrpg/distinfo
index eccf6a182f56..c5ab66dba30f 100644
--- a/games/freedroidrpg/distinfo
+++ b/games/freedroidrpg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freedroidrpg-0.15.tar.gz) = 4481a96c9cd6bfbb91ec65dbd260a4c729b82569c977b364a7f5580760af4c2f
-SIZE (freedroidrpg-0.15.tar.gz) = 209412185
+SHA256 (freedroidRPG-0.15.1.tar.gz) = 3e0e0e901f05386f49b8dfa1a8b3582ea82347deb7fb8e94fc15bf8ad058ba08
+SIZE (freedroidRPG-0.15.1.tar.gz) = 209427247
diff --git a/games/freedroidrpg/pkg-plist b/games/freedroidrpg/pkg-plist
index bdbdc7180ce9..7e6f7f23dfa8 100644
--- a/games/freedroidrpg/pkg-plist
+++ b/games/freedroidrpg/pkg-plist
@@ -6,3 +6,4 @@ bin/gluefont
bin/make_atlas
bin/pngtoico
man/man6/freedroidRPG.6.gz
+share/pixmaps/freedroidrpg.png