aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-17 12:21:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-17 17:44:49 +0000
commit4a390cd14a8079bfac0116d897d735e5b25184f3 (patch)
tree4164689f2d4801484b1706fcad25c9266a6223dd /games
parentf5c5b1a0fa3ff319021a86f2f1e676c946d80e6e (diff)
downloadports-4a390cd14a8079bfac0116d897d735e5b25184f3.tar.gz
ports-4a390cd14a8079bfac0116d897d735e5b25184f3.zip
games/domino-chain: rename from games/pushover, update to 1.1
Diffstat (limited to 'games')
-rw-r--r--games/Makefile2
-rw-r--r--games/domino-chain/Makefile42
-rw-r--r--games/domino-chain/distinfo3
-rw-r--r--games/domino-chain/files/patch-Makefile42
-rw-r--r--games/domino-chain/files/patch-src_domino-chain_main.cpp18
-rw-r--r--games/domino-chain/pkg-descr15
-rw-r--r--games/domino-chain/pkg-plist16
-rw-r--r--games/pushover/Makefile35
-rw-r--r--games/pushover/distinfo2
-rw-r--r--games/pushover/pkg-descr6
-rw-r--r--games/pushover/pkg-plist9
11 files changed, 137 insertions, 53 deletions
diff --git a/games/Makefile b/games/Makefile
index 2efaddcc3327..cfa10b590d9d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -197,6 +197,7 @@
SUBDIR += dobutsu
SUBDIR += dodgindiamond2
SUBDIR += domination
+ SUBDIR += domino-chain
SUBDIR += dontspace
SUBDIR += doom
SUBDIR += doom-data
@@ -778,7 +779,6 @@
SUBDIR += prboom-plus
SUBDIR += primateplunge
SUBDIR += puckman
- SUBDIR += pushover
SUBDIR += pvpgn
SUBDIR += py-2048-py
SUBDIR += py-cbeams
diff --git a/games/domino-chain/Makefile b/games/domino-chain/Makefile
new file mode 100644
index 000000000000..70d531284061
--- /dev/null
+++ b/games/domino-chain/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= domino-chain
+PORTVERSION= 1.1
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Rearrange dominoes on different platforms to start a chain reaction
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpng.so:graphics/png \
+ libfribidi.so:converters/fribidi \
+ libboost_filesystem.so:devel/boost-libs
+BUILD_DEPENDS= povray:graphics/povray-meta \
+ convert:graphics/ImageMagick7
+RUN_DEPENDS= ${FREESANS_DIR}/FreeSans.ttf:x11-fonts/freefont-ttf
+
+USES= compiler:c++17-lang gettext gmake lua:52 pkgconfig sdl
+USE_GITLAB= yes
+GL_PROJECT= domino-chain.gitlab.io
+GL_COMMIT= 3969eaa66f753e873eca4ef33b263ca1307be2df
+USE_SDL= sdl2 mixer2 ttf2 image2
+
+LIBS+= ${LOCALBASE}/lib/libintl.so
+
+FREESANS_DIR= ${LOCALBASE}/share/fonts/freefont-ttf
+
+PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/fontpaths.*=/,/^}/ s|".*fonts.*"|"${FREESANS_DIR}"|' \
+ ${WRKSRC}/src/domino-chain/screen.cpp
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${WRKSRC}/AUTHORS ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/domino-chain/distinfo b/games/domino-chain/distinfo
new file mode 100644
index 000000000000..51fe998fdaa9
--- /dev/null
+++ b/games/domino-chain/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647513590
+SHA256 (domino-chain-domino-chain.gitlab.io-3969eaa66f753e873eca4ef33b263ca1307be2df_GL0.tar.gz) = 68aa9a4f85fdafd97c16be9146cc44144386e3ef1aabb4d9a4894db2933acf8f
+SIZE (domino-chain-domino-chain.gitlab.io-3969eaa66f753e873eca4ef33b263ca1307be2df_GL0.tar.gz) = 36325269
diff --git a/games/domino-chain/files/patch-Makefile b/games/domino-chain/files/patch-Makefile
new file mode 100644
index 000000000000..7a78bf2ad1e4
--- /dev/null
+++ b/games/domino-chain/files/patch-Makefile
@@ -0,0 +1,42 @@
+--- Makefile.orig 2020-02-09 08:53:36 UTC
++++ Makefile
+@@ -18,17 +18,17 @@
+ # along with this program; if not, write to the Free Software
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1335 USA
+
+-PREFIX = /usr
++PREFIX ?= /usr
+ BINDIR = $(PREFIX)/bin
+ DATADIR = $(PREFIX)/share
+-DESTDIR =
++DESTDIR ?=
+ CROSS =
+
+ BOOST_TAGS := $(if $(filter %-w64-mingw32.static-,$(CROSS)),-mt,)
+ CONVERT = convert
+-CXX = $(CROSS)$(CXX_NATIVE)
+-CXX_NATIVE = g++
+-CXXFLAGS = -Wall -Wextra -g -O2 -std=c++17
++CXX ?= $(CROSS)$(CXX_NATIVE)
++CXX_NATIVE = ${CXX}
++CXXFLAGS += -Wall -Wextra -std=c++17
+ EXEEXT = $(if $(filter %-w64-mingw32.static-,$(CROSS)),.exe,)
+ INSTALL = install
+ LDFLAGS =
+@@ -129,7 +129,7 @@ FILES_DATADIR += data/icons/hicolor/48x48/apps/domino-
+ FILES_DATADIR += data/icons/hicolor/64x64/apps/domino-chain.png
+ data/icons/hicolor/%/apps/domino-chain.png: src/doc/domino-chain.ico
+ @mkdir -p $(dir $@)
+- $(CONVERT) +set date:create +set date:modify $<[$(shell expr substr $* 1 2 / 16 - 1)] $@
++ $(CONVERT) +set date:create +set date:modify $<[$(shell expr $$(echo $* | cut -b 1-2) / 16 - 1)] $@
+
+ DOC_INCLUDES += src/doc/upload-url-dist-windows
+
+@@ -182,7 +182,6 @@ _tmp/po/leveltexts.cpp: src/levels/*/*.level
+ @mkdir -p $(dir $@)
+ sed -n '/^\(Description\|Hint\|Name\|Tutorial\)$$/,/^[^|]/ s,^| \(.*\)$$,_("\1"),p' src/levels/*/*.level | LC_ALL=C sort -u >$@
+
+-FILES_DATADIR_SYS += data/fonts/FreeSans.ttf
+ data/fonts/FreeSans.ttf:
+ @mkdir -p $(dir $@)
+ if [ -e /usr/share/fonts/truetype/freefont/FreeSans.ttf ]; then cp /usr/share/fonts/truetype/freefont/$(notdir $@) $@; \
diff --git a/games/domino-chain/files/patch-src_domino-chain_main.cpp b/games/domino-chain/files/patch-src_domino-chain_main.cpp
new file mode 100644
index 000000000000..641357aa2d03
--- /dev/null
+++ b/games/domino-chain/files/patch-src_domino-chain_main.cpp
@@ -0,0 +1,18 @@
+--- src/domino-chain/main.cpp.orig 2020-02-09 08:53:36 UTC
++++ src/domino-chain/main.cpp
+@@ -40,15 +40,8 @@
+
+ static std::string getDataDir(void)
+ {
+- const std::string portable_datadir = "./data";
+- struct stat st;
+- if (stat(portable_datadir.c_str(), &st) == 0) {
+- std::cout << "Using portable datadir: " << portable_datadir << std::endl;
+- return portable_datadir;
+- } else {
+ std::cout << "Using system datadir: " << DATADIR << std::endl;
+ return DATADIR;
+- }
+ }
+
+ static LevelState playTick(figure_c & a, graphics_c & gr, unsigned int keys)
diff --git a/games/domino-chain/pkg-descr b/games/domino-chain/pkg-descr
new file mode 100644
index 000000000000..8c492592c1f8
--- /dev/null
+++ b/games/domino-chain/pkg-descr
@@ -0,0 +1,15 @@
+Domino-Chain is a puzzle game where you have to rearrange dominoes
+on different platforms to start a chain reaction that makes all
+dominoes topple over. There are many strange types of dominoes,
+such as the Ascender which will rise to the ceiling when pushed,
+or the Exploder which will blast a hole into the platform it stands
+on.
+
+Domino-Chain is a faithful reincarnation of the game Pushover
+originally published by Ocean in 1992. Compared to Pushover,
+Domino-Chain has some new levels, some additional domino types,
+better graphics in higher resolution and high-quality music. On top
+of that, you can load and play the original levels from Pushover
+if you have a copy of it.
+
+WWW: https://domino-chain.gitlab.io/
diff --git a/games/domino-chain/pkg-plist b/games/domino-chain/pkg-plist
new file mode 100644
index 000000000000..2c87e3ce882e
--- /dev/null
+++ b/games/domino-chain/pkg-plist
@@ -0,0 +1,16 @@
+bin/domino-chain
+share/applications/domino-chain.desktop
+share/icons/hicolor/16x16/apps/domino-chain.png
+share/icons/hicolor/32x32/apps/domino-chain.png
+share/icons/hicolor/48x48/apps/domino-chain.png
+share/icons/hicolor/64x64/apps/domino-chain.png
+%%NLS%%share/locale/cs/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/de/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/es/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/it/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/domino-chain.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/domino-chain.mo
+share/man/man6/domino-chain.6.gz
+share/metainfo/domino-chain.metainfo.xml
diff --git a/games/pushover/Makefile b/games/pushover/Makefile
deleted file mode 100644
index 8746e29b9733..000000000000
--- a/games/pushover/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-PORTNAME= pushover
-PORTVERSION= 0.0.5
-PORTREVISION= 4
-CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Pushover/${PORTVERSION}
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Puzzle game where the goal is to push over all dominoes
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-LIB_DEPENDS= libpng.so:graphics/png
-
-USES= gettext gmake localbase:ldflags lua pkgconfig sdl
-GNU_CONFIGURE= yes
-USE_SDL= sdl mixer ttf
-
-PORTDOCS= *
-PORTDATA= *
-
-DESKTOP_ENTRIES="Pushover" \
- "Push over all dominoes" \
- "${DATADIR}/pushover.ico" \
- "pushover" \
- "Game;LogicGame;" \
- false
-
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|lua5.1|lua-${LUA_VER}|' ${WRKSRC}/configure
-
-.include <bsd.port.mk>
diff --git a/games/pushover/distinfo b/games/pushover/distinfo
deleted file mode 100644
index f2b48d822044..000000000000
--- a/games/pushover/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pushover-0.0.5.tar.gz) = 30ea4ec47a62e4ea90cf536b8b1b813a599a5a35d568faa9d3c57743a08e06d0
-SIZE (pushover-0.0.5.tar.gz) = 33173821
diff --git a/games/pushover/pkg-descr b/games/pushover/pkg-descr
deleted file mode 100644
index b872e00e3b2c..000000000000
--- a/games/pushover/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Pushover is a fun puzzle game originally published by Ocean in 1992.
-In this game you control an ant that can walk along platforms that
-are connected with ladders. On those platforms are dominos that
-need to fall according to some rules.
-
-WWW: http://pushover.sourceforge.net/
diff --git a/games/pushover/pkg-plist b/games/pushover/pkg-plist
deleted file mode 100644
index 417584ee74c7..000000000000
--- a/games/pushover/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/pushover
-%%NLS%%share/locale/cs/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/de/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/es/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/it/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/pushover.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/pushover.mo