aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
commit62a41b423ba42c0a1ab0c0ada5d33752e965f615 (patch)
tree5fff787fcf509ed53762690c395516c337412423 /games
parent3d7ef3e463a5e930be63835c21dd2d345f88ea2d (diff)
downloadports-62a41b423ba42c0a1ab0c0ada5d33752e965f615.tar.gz
ports-62a41b423ba42c0a1ab0c0ada5d33752e965f615.zip
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
Notes
Notes: svn path=/head/; revision=324191
Diffstat (limited to 'games')
-rw-r--r--games/3dc/Makefile3
-rw-r--r--games/acm/Makefile3
-rw-r--r--games/asc/Makefile4
-rw-r--r--games/falconseye/Makefile3
-rw-r--r--games/gtkpool/Makefile4
-rw-r--r--games/hlstats/Makefile3
-rw-r--r--games/latrine/Makefile5
-rw-r--r--games/mahjong/Makefile4
-rw-r--r--games/optimax/Makefile3
-rw-r--r--games/pengpong/Makefile3
-rw-r--r--games/ptools/Makefile3
-rw-r--r--games/stepmania-devel/Makefile5
-rw-r--r--games/zangband/Makefile3
13 files changed, 26 insertions, 20 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index 095e16faf548..30f9f13f970a 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -16,7 +16,8 @@ LICENSE= GPLv2
LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_XORG= x11 xaw xext xmu xpm xt
WRKSRC= ${WRKDIR}/3Dc/src
diff --git a/games/acm/Makefile b/games/acm/Makefile
index e00507eb4c8b..d434384977b1 100644
--- a/games/acm/Makefile
+++ b/games/acm/Makefile
@@ -16,9 +16,10 @@ COMMENT= A flight simulator for X11
LICENSE= GPLv2
+USES= perl5
USE_XORG= x11
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
MAN6= acm.6
diff --git a/games/asc/Makefile b/games/asc/Makefile
index a060fb43c5cd..93e48bf51f3b 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -27,16 +27,16 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= MUSIC XVID
MUSIC_DESC= Install extra music files
+USES= perl5
USE_BZIP2= yes
USE_SDL= image mixer sound sdl
USE_WX= 2.4+
WX_CONF_ARGS= absolute
USE_LUA= 5.1
LUA_COMPS= lua
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
MAN6= asc.6 asc_demount.6 asc_mapedit.6 asc_mount.6 \
asc_weaponguide.6
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index f188719000b5..497802f42467 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -13,11 +13,12 @@ COMMENT= NetHack derivative
RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+USES= perl5
NHDIR= "${PREFIX}/share/falconseyedir"
MAKE_ENV= NHDIR="${NHDIR}" NETHACKCONFIG="${NETHACKCONFIG}"
NETHACKCONFIG= ${FILESDIR}/x-config
USE_SDL= sdl
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_ZIP= yes
USE_XORG= x11 xpm xaw
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11 \
diff --git a/games/gtkpool/Makefile b/games/gtkpool/Makefile
index 4e05e7214422..89723adc5fe0 100644
--- a/games/gtkpool/Makefile
+++ b/games/gtkpool/Makefile
@@ -15,13 +15,13 @@ MASTER_SITES= ftp://ftp.seul.org/pub/gtkpool/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A 2D pool game using the GTK+ toolkit
+USES= perl5
USE_GNOME= gtk20
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GMAKE= yes
USE_AUTOTOOLS= aclocal automake autoheader autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
-MAKE_JOBS_SAFE= yes
post-patch:
.for file in application.cpp options.cpp
diff --git a/games/hlstats/Makefile b/games/hlstats/Makefile
index 7bf9cf15ac77..c8cb28bf44ff 100644
--- a/games/hlstats/Makefile
+++ b/games/hlstats/Makefile
@@ -18,10 +18,11 @@ LICENSE= CDDL
RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+USES= perl5
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
HLSTATS?= www/${PORTNAME}
PLIST_SUB+= HLSTATS=${HLSTATS}
diff --git a/games/latrine/Makefile b/games/latrine/Makefile
index 75baa3886b94..0a70c94b1557 100644
--- a/games/latrine/Makefile
+++ b/games/latrine/Makefile
@@ -17,11 +17,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_CSTD= gnu89
USE_SQLITE= 3
-USE_PERL5_BUILD=yes
-USES= gettext ncurses
+USE_PERL5= build
+USES= gettext ncurses perl5
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D_XOPEN_SOURCE_EXTENDED
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/mahjong/Makefile b/games/mahjong/Makefile
index 9fabb4fdc4f7..ed2aeaeb202b 100644
--- a/games/mahjong/Makefile
+++ b/games/mahjong/Makefile
@@ -19,12 +19,12 @@ COMMENT= A networked Mah Jong program, together with a computer player
LICENSE= GPLv2 # (or later)
+USES= perl5
USE_GNOME= gtk20
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GMAKE= yes
MAKE_ENV= CCLINK="${CC}" CDEBUGFLAGS="${CFLAGS}" PERL="${PERL}" \
INCLUDES="-I."
-MAKE_JOBS_SAFE= yes
MAN1= xmj.1
MLINKS= xmj.1 mj-player.1 \
diff --git a/games/optimax/Makefile b/games/optimax/Makefile
index a2ceefc7e213..8a361d9a1db6 100644
--- a/games/optimax/Makefile
+++ b/games/optimax/Makefile
@@ -21,8 +21,9 @@ COMMENT= A Core War optimizer written in Perl
RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
+USES= perl5
USE_ZIP= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
WRKSRC= ${WRKDIR}/publish_${PORTVERSION:S/.//}
BUILD_WRKSRC= ${WRKSRC}/optimars/optimars_0.1
ALL_TARGET= exmars
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index 5808c5bf042d..04795fab9772 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -10,9 +10,10 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}-linux
MAINTAINER= ports@FreeBSD.org
COMMENT= A cross-platform pong game written in SDL
+USES= perl5
USE_SDL= image sdl
NO_WRKSUBDIR= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
paddle.tga red.png
diff --git a/games/ptools/Makefile b/games/ptools/Makefile
index 8c0ed05c5fe5..0810828e1eb7 100644
--- a/games/ptools/Makefile
+++ b/games/ptools/Makefile
@@ -19,8 +19,9 @@ EXTRACT_ONLY= ${DISTFILES:C/:[[:alpha:]]+$//:N*.pl:N*.c}
MAINTAINER= ports@FreeBSD.org
COMMENT= Accessory programs for pMARS (Core War simulator)
+USES= perl5
USE_ZIP= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
MAKEFILE= makefile.ptools
ALL_TARGET= mopt mts pname
NO_WRKSUBDIR= yes
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index c42eb9dae646..138ed2692adf 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -28,13 +28,12 @@ PROJECTHOST= sm-ssc
USE_BZIP2= yes
USE_XORG= x11 xau xdmcp xext xrandr xrender xtst
USE_GL= gl glu
-USES= pathfix iconv shebangfix
+USES= pathfix iconv shebangfix perl5
USE_GNOME= gtk20
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-ffmpeg
INSTALLS_ICONS= yes
-MAKE_JOBS_SAFE= yes
SHEBANG_FILES= Utils/*.pl \
extern/zlib/zlib2ansi
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 9192507e030e..623835cccd5c 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -11,9 +11,10 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Zangband (Zelazny Angband) with color, X11 support
+USES= perl5
USE_GMAKE= yes
USE_AUTOTOOLS= automake14 autoconf
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CONFIGURE_ARGS= --datadir=${PREFIX}/lib --mandir=${PREFIX}/man \
--with-setgid=${SHAREGRP}