aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPat Jensen <patj@passpackets.com>2021-10-13 06:32:54 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-10-13 06:42:51 +0000
commit63362d760d68e56523fc44db0f948eb353fe5ced (patch)
tree0b27e4f0667f5d54a68376084076060c47590e6b /games
parent822b5bff50773c9fdb4d99b2934e7d44cd407bd1 (diff)
downloadports-63362d760d68e56523fc44db0f948eb353fe5ced.tar.gz
ports-63362d760d68e56523fc44db0f948eb353fe5ced.zip
games/wordsearch: New port: Classic word search game
- Submitter becomes maintainer wordsearch Relax with a classic word search game that you can play in your terminal. https://github.com/jensenpat/wordsearch PR: 258821
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/wordsearch/Makefile26
-rw-r--r--games/wordsearch/distinfo3
-rw-r--r--games/wordsearch/pkg-descr6
-rw-r--r--games/wordsearch/pkg-plist67
5 files changed, 103 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 29f64639d485..cae037efb8fc 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -1033,6 +1033,7 @@
SUBDIR += wolfpack
SUBDIR += wop
SUBDIR += wordplay
+ SUBDIR += wordsearch
SUBDIR += wordwarvi
SUBDIR += worldofpadman
SUBDIR += wtf
diff --git a/games/wordsearch/Makefile b/games/wordsearch/Makefile
new file mode 100644
index 000000000000..a440c9f11d38
--- /dev/null
+++ b/games/wordsearch/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= wordsearch
+DISTVERSION= 2.0
+CATEGORIES= games
+MASTER_SITES= https://github.com/jensenpat/wordsearch/releases/download/${DISTVERSION}/
+
+MAINTAINER= patj@passpackets.com
+COMMENT= Classic word search game that you can play in your terminal
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.8+ shebangfix
+SHEBANG_FILES= wordsearch
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ @${REINPLACE_CMD} -e 's|/usr/games|${PREFIX}/bin|' ${WRKSRC}/man/wordsearch.6
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/wordsearch ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/man/man6/
+ ${INSTALL_MAN} ${WRKSRC}/man/wordsearch.6 ${STAGEDIR}${PREFIX}/share/man/man6/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/wordsearch/
+ ${INSTALL_DATA} ${WRKSRC}/puzzles/*.txt ${STAGEDIR}${PREFIX}/share/wordsearch/
+
+.include <bsd.port.mk>
diff --git a/games/wordsearch/distinfo b/games/wordsearch/distinfo
new file mode 100644
index 000000000000..ca1d45f336a9
--- /dev/null
+++ b/games/wordsearch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633733285
+SHA256 (wordsearch-2.0.tar.gz) = 0a9003449b8142ede783b20bc99781febb73466787812ddcf4edbf2223f75bf3
+SIZE (wordsearch-2.0.tar.gz) = 12109
diff --git a/games/wordsearch/pkg-descr b/games/wordsearch/pkg-descr
new file mode 100644
index 000000000000..a23a956cd19a
--- /dev/null
+++ b/games/wordsearch/pkg-descr
@@ -0,0 +1,6 @@
+wordsearch is a classic word search game that you can play in your terminal. It
+features curses full screen gameplay with an easy to customize puzzle directory
+so you can share your creations with friends. It has simple to pick up gameplay
+with word-based scoring so you can play anytime.
+
+WWW: https://github.com/jensenpat/wordsearch
diff --git a/games/wordsearch/pkg-plist b/games/wordsearch/pkg-plist
new file mode 100644
index 000000000000..e05e53e95122
--- /dev/null
+++ b/games/wordsearch/pkg-plist
@@ -0,0 +1,67 @@
+bin/wordsearch
+share/man/man6/wordsearch.6.gz
+%%DATADIR%%/airplanes.txt
+%%DATADIR%%/anatomy.txt
+%%DATADIR%%/animals.txt
+%%DATADIR%%/apocalypse.txt
+%%DATADIR%%/baseball.txt
+%%DATADIR%%/bbq.txt
+%%DATADIR%%/camping.txt
+%%DATADIR%%/candy.txt
+%%DATADIR%%/cars.txt
+%%DATADIR%%/cats.txt
+%%DATADIR%%/christmas.txt
+%%DATADIR%%/coffee.txt
+%%DATADIR%%/computers.txt
+%%DATADIR%%/cookies.txt
+%%DATADIR%%/cooking.txt
+%%DATADIR%%/dairy.txt
+%%DATADIR%%/dance.txt
+%%DATADIR%%/dates.txt
+%%DATADIR%%/dinosaurs.txt
+%%DATADIR%%/dogs.txt
+%%DATADIR%%/edm.txt
+%%DATADIR%%/email.txt
+%%DATADIR%%/engines.txt
+%%DATADIR%%/fall.txt
+%%DATADIR%%/fish.txt
+%%DATADIR%%/fitness.txt
+%%DATADIR%%/football.txt
+%%DATADIR%%/fruit.txt
+%%DATADIR%%/halloween.txt
+%%DATADIR%%/hamradio.txt
+%%DATADIR%%/hiking.txt
+%%DATADIR%%/hobbies.txt
+%%DATADIR%%/hockey.txt
+%%DATADIR%%/household.txt
+%%DATADIR%%/instruments.txt
+%%DATADIR%%/internet.txt
+%%DATADIR%%/mobile.txt
+%%DATADIR%%/movies.txt
+%%DATADIR%%/nationalparks.txt
+%%DATADIR%%/networks.txt
+%%DATADIR%%/nuts.txt
+%%DATADIR%%/oldtimes.txt
+%%DATADIR%%/pasta.txt
+%%DATADIR%%/photography.txt
+%%DATADIR%%/places.txt
+%%DATADIR%%/planets.txt
+%%DATADIR%%/science.txt
+%%DATADIR%%/scifi.txt
+%%DATADIR%%/sodas.txt
+%%DATADIR%%/space.txt
+%%DATADIR%%/spices.txt
+%%DATADIR%%/spring.txt
+%%DATADIR%%/states.txt
+%%DATADIR%%/strings.txt
+%%DATADIR%%/summer.txt
+%%DATADIR%%/superpowers.txt
+%%DATADIR%%/technology.txt
+%%DATADIR%%/tennis.txt
+%%DATADIR%%/trains.txt
+%%DATADIR%%/travel.txt
+%%DATADIR%%/trees.txt
+%%DATADIR%%/unix.txt
+%%DATADIR%%/wine.txt
+%%DATADIR%%/winter.txt
+%%DATADIR%%/work.txt