aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-04-26 08:59:57 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-04-26 08:59:57 +0000
commit6a28e79a4d95982f67813b848d53446db651e6cb (patch)
treeb51bd68ab2c1983b559e00922b1201822ba167ee /games
parentd5cef08ef20655698a9899fe4c50a808d0b27f65 (diff)
downloadports-6a28e79a4d95982f67813b848d53446db651e6cb.tar.gz
ports-6a28e79a4d95982f67813b848d53446db651e6cb.zip
- Update Knights to KDE4 version, 2.0
- Pass maintainership to submitter Submitted by: Mina R Waheeb <syncer@gmail.com> via kde@ mailing list
Notes
Notes: svn path=/head/; revision=253277
Diffstat (limited to 'games')
-rw-r--r--games/knights-kde4/Makefile27
-rw-r--r--games/knights-kde4/distinfo6
-rw-r--r--games/knights-kde4/files/patch-configure419
-rw-r--r--games/knights-kde4/files/patch-core.cpp26
-rw-r--r--games/knights-kde4/pkg-descr15
-rw-r--r--games/knights-kde4/pkg-plist54
6 files changed, 36 insertions, 511 deletions
diff --git a/games/knights-kde4/Makefile b/games/knights-kde4/Makefile
index 20075d66b982..8d5e616a01f6 100644
--- a/games/knights-kde4/Makefile
+++ b/games/knights-kde4/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= knights
-PORTVERSION= 0.6
-PORTREVISION= 9
+PORTVERSION= 2.0
CATEGORIES= games kde
-MASTER_SITES= SF
+MASTER_SITES= http://www.kde-look.org/CONTENT/content-files/
+DISTNAME= 122046-${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A KDE chess interface (gnuchess/crafty)
+MAINTAINER= syncer@gmail.com
+COMMENT= A KDE4 chess interface
-RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+LIB_DEPENDS= kdegames.5:${PORTSDIR}/games/kdegames4
+RUN_DEPENDS= ${LOCALBASE}/bin/gnuchess:${PORTSDIR}/games/gnuchess
-USE_GETTEXT= yes
-USE_KDELIBS_VER=3
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
-CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+WRKSRC= ${WRKDIR}/Knights
+LATEST_LINK= ${PORTNAME}-kde4
+USE_CMAKE= yes
+USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/games/knights-kde4/distinfo b/games/knights-kde4/distinfo
index 571e6e02fb87..1d2a9857f0f0 100644
--- a/games/knights-kde4/distinfo
+++ b/games/knights-kde4/distinfo
@@ -1,3 +1,3 @@
-MD5 (knights-0.6.tar.gz) = b04574568b9bc3982b934328ee63fb74
-SHA256 (knights-0.6.tar.gz) = d2dbe089eb6e4e87b908fe708730cae19d6285ccf3f78986139dfd1940c665ae
-SIZE (knights-0.6.tar.gz) = 1317589
+MD5 (122046-knights-2.0-src.tar.gz) = ea66fc4f9bf2a8bd74220087e4c19df0
+SHA256 (122046-knights-2.0-src.tar.gz) = bac82341c768456a8a63d75e18212dc5837ec35a99ee0e39115da7ea51bea665
+SIZE (122046-knights-2.0-src.tar.gz) = 683990
diff --git a/games/knights-kde4/files/patch-configure b/games/knights-kde4/files/patch-configure
deleted file mode 100644
index 24dcd6bd5411..000000000000
--- a/games/knights-kde4/files/patch-configure
+++ /dev/null
@@ -1,419 +0,0 @@
---- configure.orig Thu Nov 11 20:31:17 2004
-+++ configure Thu Nov 11 20:33:13 2004
-@@ -20831,15 +20831,34 @@
-
-
-
--echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
--echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
--if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
-+ LIBPTHREAD=""
-+
-+ if test -n "$PTHREAD_LIBS"; then
-+ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
-+ LIBPTHREAD="PTHREAD"
-+ else
-+ PTHREAD_LIBS_save="$PTHREAD_LIBS"
-+ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
-+ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
-+
-+ kde_save_LDFLAGS="$LDFLAGS"
-+ kde_save_LIBS="$LIBS"
-+ LDFLAGS="$LDFLAGS $all_libraries"
-+ case $host_os in
-+ aix*) LDFLAGS="-brtl $LDFLAGS"
-+ test "$GCC" = yes && LDFLAGS="-Wl,$LDFLAGS"
-+ ;;
-+ esac
-+ as_ac_Lib=`echo "ac_cv_lib_$PTHREAD_LIBS''_pthread_create" | $as_tr_sh`
-+echo "$as_me:$LINENO: checking for pthread_create in -l$PTHREAD_LIBS" >&5
-+echo $ECHO_N "checking for pthread_create in -l$PTHREAD_LIBS... $ECHO_C" >&6
-+if eval "test \"\${$as_ac_Lib+set}\" = set"; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lpthread $LIBS"
-+LIBS="-l$PTHREAD_LIBS $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
--#line $LINENO "configure"
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
-@@ -20863,259 +20882,187 @@
- _ACEOF
- rm -f conftest.$ac_objext conftest$ac_exeext
- if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>&5
-+ (eval $ac_link) 2>conftest.er1
- ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
-- { ac_try='test -s conftest$ac_exeext'
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_lib_pthread_pthread_create=yes
-+ eval "$as_ac_Lib=yes"
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_lib_pthread_pthread_create=no
-+eval "$as_ac_Lib=no"
- fi
--rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
- LIBS=$ac_check_lib_save_LIBS
- fi
--echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
--echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
--if test $ac_cv_lib_pthread_pthread_create = yes; then
-- LIBPTHREAD="-lpthread"
-+echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
-+echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
-+if test `eval echo '${'$as_ac_Lib'}'` = yes; then
-+ LIBPTHREAD="$PTHREAD_LIBS_save"
- fi
-
-+ LDFLAGS="$kde_save_LDFLAGS"
-+ LIBS="$kde_save_LIBS"
-
-+ PTHREAD_LIBS="$PTHREAD_LIBS_save"
-+ fi
-+ fi
-
--
-- # Check whether --enable-kernel-threads or --disable-kernel-threads was given.
--if test "${enable_kernel_threads+set}" = set; then
-- enableval="$enable_kernel_threads"
-- kde_use_kernthreads=$enableval
--else
-- kde_use_kernthreads=no
--fi;
--
-- if test "$kde_use_kernthreads" = "yes"; then
-- ac_save_CXXFLAGS="$CXXFLAGS"
-- ac_save_CFLAGS="$CFLAGS"
-- CXXFLAGS="-I/usr/local/include/pthread/linuxthreads $CXXFLAGS"
-- CFLAGS="-I/usr/local/include/pthread/linuxthreads $CFLAGS"
--
--for ac_header in pthread/linuxthreads/pthread.h
--do
--as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
--if eval "test \"\${$as_ac_Header+set}\" = set"; then
-- echo "$as_me:$LINENO: checking for $ac_header" >&5
--echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
--if eval "test \"\${$as_ac_Header+set}\" = set"; then
-+ if test -z "$LIBPTHREAD"; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-+if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
--fi
--echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
--echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
- else
-- # Is the header compilable?
--echo "$as_me:$LINENO: checking $ac_header usability" >&5
--echo $ECHO_N "checking $ac_header usability... $ECHO_C" >&6
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-lpthread $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
--#line $LINENO "configure"
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--$ac_includes_default
--#include <$ac_header>
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char pthread_create ();
-+int
-+main ()
-+{
-+pthread_create ();
-+ ;
-+ return 0;
-+}
- _ACEOF
--rm -f conftest.$ac_objext
--if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-- (eval $ac_compile) 2>&5
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
- ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
-- { ac_try='test -s conftest.$ac_objext'
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; }; then
-- ac_header_compiler=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--ac_header_compiler=no
--fi
--rm -f conftest.$ac_objext conftest.$ac_ext
--echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
--echo "${ECHO_T}$ac_header_compiler" >&6
--
--# Is the header present?
--echo "$as_me:$LINENO: checking $ac_header presence" >&5
--echo $ECHO_N "checking $ac_header presence... $ECHO_C" >&6
--cat >conftest.$ac_ext <<_ACEOF
--#line $LINENO "configure"
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--#include <$ac_header>
--_ACEOF
--if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
-- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } >/dev/null; then
-- if test -s conftest.err; then
-- ac_cpp_err=$ac_c_preproc_warn_flag
-- else
-- ac_cpp_err=
-- fi
--else
-- ac_cpp_err=yes
--fi
--if test -z "$ac_cpp_err"; then
-- ac_header_preproc=yes
-+ (exit $ac_status); }; }; then
-+ ac_cv_lib_pthread_pthread_create=yes
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
-- ac_header_preproc=no
--fi
--rm -f conftest.err conftest.$ac_ext
--echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
--echo "${ECHO_T}$ac_header_preproc" >&6
--
--# So? What about this header?
--case $ac_header_compiler:$ac_header_preproc in
-- yes:no )
-- { echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
--echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
-- { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
--echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
-- (
-- cat <<\_ASBOX
--## ------------------------------------ ##
--## Report this to bug-autoconf@gnu.org. ##
--## ------------------------------------ ##
--_ASBOX
-- ) |
-- sed "s/^/$as_me: WARNING: /" >&2
-- ;;
-- no:yes )
-- { echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
--echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
-- { echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
--echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
-- { echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
--echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
-- (
-- cat <<\_ASBOX
--## ------------------------------------ ##
--## Report this to bug-autoconf@gnu.org. ##
--## ------------------------------------ ##
--_ASBOX
-- ) |
-- sed "s/^/$as_me: WARNING: /" >&2
-- ;;
--esac
--echo "$as_me:$LINENO: checking for $ac_header" >&5
--echo $ECHO_N "checking for $ac_header... $ECHO_C" >&6
--if eval "test \"\${$as_ac_Header+set}\" = set"; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- eval "$as_ac_Header=$ac_header_preproc"
-+ac_cv_lib_pthread_pthread_create=no
- fi
--echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Header'}'`" >&5
--echo "${ECHO_T}`eval echo '${'$as_ac_Header'}'`" >&6
--
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
- fi
--if test `eval echo '${'$as_ac_Header'}'` = yes; then
-- cat >>confdefs.h <<_ACEOF
--#define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
--_ACEOF
--
-+echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
-+echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
-+if test $ac_cv_lib_pthread_pthread_create = yes; then
-+ LIBPTHREAD="-lpthread"
- fi
-
--done
-+ fi
-
-- CXXFLAGS="$ac_save_CXXFLAGS"
-- CFLAGS="$ac_save_CFLAGS"
-- if test "$ac_cv_header_pthread_linuxthreads_pthread_h" = "no"; then
-- kde_use_kernthreads=no
-- else
-- echo "$as_me:$LINENO: checking for pthread_join in -llthread" >&5
--echo $ECHO_N "checking for pthread_join in -llthread... $ECHO_C" >&6
--if test "${ac_cv_lib_lthread_pthread_join+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- ac_check_lib_save_LIBS=$LIBS
--LIBS="-llthread $LIBS"
--cat >conftest.$ac_ext <<_ACEOF
--#line $LINENO "configure"
-+ if test -z "$LIBPTHREAD" ; then
-+ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-+echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
-+ kde_safe_libs=$LIBS
-+ LIBS="$LIBS -lpthread"
-+ cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--
--/* Override any gcc2 internal prototype to avoid an error. */
--#ifdef __cplusplus
--extern "C"
--#endif
--/* We use char because int might match the return type of a gcc2
-- builtin and then its argument prototype would still apply. */
--char pthread_join ();
-+#include <pthread.h>
- int
- main ()
- {
--pthread_join ();
-+(void)pthread_create(0,0,0,0);
- ;
- return 0;
- }
- _ACEOF
- rm -f conftest.$ac_objext conftest$ac_exeext
- if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>&5
-+ (eval $ac_link) 2>conftest.er1
- ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
-- { ac_try='test -s conftest$ac_exeext'
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_lib_lthread_pthread_join=yes
-+
-+ echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6
-+ LIBPTHREAD="-lpthread"
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_lib_lthread_pthread_join=no
--fi
--rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
--LIBS=$ac_check_lib_save_LIBS
--fi
--echo "$as_me:$LINENO: result: $ac_cv_lib_lthread_pthread_join" >&5
--echo "${ECHO_T}$ac_cv_lib_lthread_pthread_join" >&6
--if test $ac_cv_lib_lthread_pthread_join = yes; then
-- LIBPTHREAD="-llthread -llgcc_r"
-+
-+ echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6
- fi
-- if test "x$LIBPTHREAD" = "x"; then
-- kde_use_kernthreads=no
-- else
-- USE_THREADS="-D_THREAD_SAFE -I/usr/local/include/pthread/linuxthreads"
-- fi
-- fi
-- else
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+ LIBS=$kde_safe_libs
-+ fi
-+
-+ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
-+ LIBPTHREAD=""
-+ fi
-+
-+
-+
-+
- USE_THREADS=""
- if test -z "$LIBPTHREAD"; then
-
-@@ -21197,7 +21144,7 @@
- fi
-
- fi
-- fi
-+
-
-
-
diff --git a/games/knights-kde4/files/patch-core.cpp b/games/knights-kde4/files/patch-core.cpp
deleted file mode 100644
index 0fe783deb901..000000000000
--- a/games/knights-kde4/files/patch-core.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- knights/core.cpp.orig Sat Aug 21 10:14:24 2004
-+++ knights/core.cpp Sat Aug 21 10:28:14 2004
-@@ -90,7 +90,7 @@
- else
- {
- /* Use an existing internetIO */
-- (io_base*)internetioPtr = myIOMap.find(Null);
-+ internetioPtr = (io_internet*)myIOMap.find(Null);
- if( internetioPtr == NULL )
- {
- kdWarning() << "core::createNewIO: Trying to connect a match to an internetIO that doesn't exsist." << endl;
-@@ -114,12 +114,12 @@
- }
- else
- {
-- (io_base*)internetioPtr = myIOMap.find(ID);
-+ internetioPtr = (io_internet*)myIOMap.find(ID);
- if( internetioPtr == NULL )
- {
- /* no io mapped to the ID yet, use the internetio */
- /* Use an existing internetIO */
-- (io_base*)internetioPtr = myIOMap.find(Null);
-+ internetioPtr = (io_internet*)myIOMap.find(Null);
- if( internetioPtr == NULL )
- {
- kdWarning() << "core::createNewIO: Trying to connect a match to an internetIO that doesn't exsist." << endl;
diff --git a/games/knights-kde4/pkg-descr b/games/knights-kde4/pkg-descr
index 334e5ea8530a..23bcf7c83897 100644
--- a/games/knights-kde4/pkg-descr
+++ b/games/knights-kde4/pkg-descr
@@ -1,7 +1,10 @@
-Knights is a graphical chess interface designed
-to be both friendly to new chess players and
-functional for Grand Masters. Knights is similar
-to XBoard, but provides a more modern interface
-and is more friendly to chess newbies.
+Knights is a simple chess board for KDE 4.
-WWW: http://knights.sourceforge.net
+It is a rewrite of the KDE3 Knights, but it
+net yet feature-complete compared to the old
+one. Supports playing againts computer engines
+that support the XBoard protocol or against
+player at the same computer. It has automatic
+rule checking and some nice animations.
+
+WWW: http://kde-apps.org/content/show.php/Knights?content=122046
diff --git a/games/knights-kde4/pkg-plist b/games/knights-kde4/pkg-plist
index 7eebb6010fa0..8f16c367668c 100644
--- a/games/knights-kde4/pkg-plist
+++ b/games/knights-kde4/pkg-plist
@@ -1,47 +1,15 @@
bin/knights
-share/applnk/Games/Board/knights.desktop
-share/apps/knights/default-engine-portrait.jpg
-share/apps/knights/default-portrait.jpg
-share/apps/knights/icon-display.png
-share/apps/knights/icon-general.png
-share/apps/knights/pgn_template.kml
-share/apps/knights/splash.png
-share/apps/knights/themes/KBDefault.tar.gz
-share/apps/knights/themes/KCDefault.tar.gz
-share/apps/knights/themes/KSDefault.tar.gz
-share/apps/knights/wizard.png
-share/doc/HTML/de/knights/common
-share/doc/HTML/en/knights/common
-share/doc/HTML/en/knights/index.docbook
-share/doc/HTML/es/knights/common
-share/doc/HTML/et/knights/common
-share/doc/HTML/fi/knights/common
-share/doc/HTML/fr/knights/common
-share/doc/HTML/fr/knights/index.docbook
-share/doc/HTML/it/knights/common
-share/doc/HTML/ru/knights/common
+share/applications/kde4/knights.desktop
+share/apps/knights/knightsui.rc
+share/apps/knights/themes/default.desktop
+share/apps/knights/themes/knights.png
+share/apps/knights/themes/knights.svg
+share/apps/knights/themes/tux.desktop
+share/apps/knights/themes/tux.png
+share/apps/knights/themes/tux.svg
+share/config.kcfg/knights.kcfg
share/icons/hicolor/16x16/apps/knights.png
-share/icons/hicolor/16x16/mimetypes/pgn.png
share/icons/hicolor/32x32/apps/knights.png
-share/icons/hicolor/32x32/mimetypes/pgn.png
share/icons/hicolor/48x48/apps/knights.png
-share/icons/hicolor/48x48/mimetypes/pgn.png
-share/icons/hicolor/64x64/apps/knights.png
-share/icons/hicolor/64x64/mimetypes/pgn.png
-share/locale/de/LC_MESSAGES/knights.mo
-share/locale/es/LC_MESSAGES/knights.mo
-share/locale/et/LC_MESSAGES/knights.mo
-share/locale/fi/LC_MESSAGES/knights.mo
-share/locale/fr/LC_MESSAGES/knights.mo
-share/locale/it/LC_MESSAGES/knights.mo
-share/mimelnk/application/pgn.desktop
-@dirrm share/doc/HTML/ru/knights
-@dirrm share/doc/HTML/it/knights
-@dirrm share/doc/HTML/fr/knights
-@dirrm share/doc/HTML/fi/knights
-@dirrm share/doc/HTML/et/knights
-@dirrm share/doc/HTML/es/knights
-@dirrm share/doc/HTML/en/knights
-@dirrm share/doc/HTML/de/knights
-@dirrm share/apps/knights/themes
-@dirrm share/apps/knights
+@dirrm share/apps/knights/themes/
+@dirrm share/apps/knights/