aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorVasily Postnicov <shamaz.mazum@gmail.com>2022-03-31 17:28:56 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-03-31 17:35:30 +0000
commit70f7b09d39ce4c4190dc0e8baa23c5b6fc526639 (patch)
tree75a7cf76543d296325851ee7c7685c85ec27e2b9 /games
parent33aaf158b78567cbacfa82bf5715344dd33e7dce (diff)
downloadports-70f7b09d39ce4c4190dc0e8baa23c5b6fc526639.tar.gz
ports-70f7b09d39ce4c4190dc0e8baa23c5b6fc526639.zip
games/amnesia-tdd: New port: Amnesia: The Dark Descent
Amnesia: The Dark Descent is a survival horror adventure video game featuring a protagonist named Daniel exploring a dark and foreboding castle called Brennenburg, while trying to maintain his sanity by avoiding monsters and unsettling events. PR: 258509
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/amnesia-tdd/Makefile38
-rw-r--r--games/amnesia-tdd/distinfo3
-rw-r--r--games/amnesia-tdd/files/pkg-message.in9
-rw-r--r--games/amnesia-tdd/pkg-descr8
-rw-r--r--games/amnesia-tdd/pkg-plist2
6 files changed, 61 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 283d72afdfde..519c0380d987 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -46,6 +46,7 @@
SUBDIR += alienblaster
SUBDIR += alienwave
SUBDIR += allacrost
+ SUBDIR += amnesia-tdd
SUBDIR += amoebax
SUBDIR += an
SUBDIR += angband
diff --git a/games/amnesia-tdd/Makefile b/games/amnesia-tdd/Makefile
new file mode 100644
index 000000000000..2840aa58ebf5
--- /dev/null
+++ b/games/amnesia-tdd/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= amnesia-tdd
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= games
+
+MAINTAINER= shamaz.mazum@gmail.com
+COMMENT= Amnesia: The Dark Descent
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= Bundled AngelScript does not work on this architecture.
+
+LIB_DEPENDS= libIL.so:graphics/devil \
+ libvorbis.so:audio/libvorbis \
+ libtheora.so:multimedia/libtheora \
+ libogg.so:audio/libogg
+
+USES= cmake gl sdl openal perl5
+USE_GL= gl glew glu
+USE_SDL= sdl2
+USE_PERL5= build
+
+USE_GITHUB= yes
+GH_ACCOUNT= shamazmazum
+GH_PROJECT= AmnesiaTheDarkDescent
+
+SUB_FILES= pkg-message
+
+CMAKE_ON= SYSTEMWIDE_RESOURCES
+CMAKE_ARGS= -DSYSTEMWIDE_RESOURCES_LOCATION=${PREFIX}/share/${PORTNAME}
+CMAKE_SOURCE_PATH= ${WRKSRC}/amnesia/src
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/games/amnesia-tdd/distinfo b/games/amnesia-tdd/distinfo
new file mode 100644
index 000000000000..17f88c8afedf
--- /dev/null
+++ b/games/amnesia-tdd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1648180510
+SHA256 (shamazmazum-AmnesiaTheDarkDescent-v0.3.2_GH0.tar.gz) = c4fd81044b8263ec00d6d46692b20f0397189b30044d1f1306989f5257ef65cb
+SIZE (shamazmazum-AmnesiaTheDarkDescent-v0.3.2_GH0.tar.gz) = 6709761
diff --git a/games/amnesia-tdd/files/pkg-message.in b/games/amnesia-tdd/files/pkg-message.in
new file mode 100644
index 000000000000..57a41047736f
--- /dev/null
+++ b/games/amnesia-tdd/files/pkg-message.in
@@ -0,0 +1,9 @@
+[
+{ type: install
+ message: <<EOM
+To play the game you need to copy files from the original game (a
+Steam version will do) to %%DATADIR%%.
+Enjoy!
+EOM
+}
+]
diff --git a/games/amnesia-tdd/pkg-descr b/games/amnesia-tdd/pkg-descr
new file mode 100644
index 000000000000..e5c0c4c54798
--- /dev/null
+++ b/games/amnesia-tdd/pkg-descr
@@ -0,0 +1,8 @@
+Amnesia: The Dark Descent is a survival horror adventure video game by
+Frictional Games, released in 2010 for Microsoft Windows, Mac OS X and
+Linux operating systems, in 2016 for the PlayStation 4 platform and in
+2018 for the Xbox One. The game features a protagonist named Daniel
+exploring a dark and foreboding castle called Brennenburg, while
+trying to maintain his sanity by avoiding monsters and unsettling
+events. The game was critically well-received, earning two awards
+from the Independent Games Festival and numerous positive reviews.
diff --git a/games/amnesia-tdd/pkg-plist b/games/amnesia-tdd/pkg-plist
new file mode 100644
index 000000000000..9db2c713cc93
--- /dev/null
+++ b/games/amnesia-tdd/pkg-plist
@@ -0,0 +1,2 @@
+bin/Amnesia
+@dir share/amnesia-tdd