aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-17 13:27:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-17 13:27:06 +0000
commit74ba0b7dd4e40f2aae1ca3582f9392eb432e86db (patch)
treeb4fd480f2c27f0bcfec0810967b8e2097ba15235 /games
parentab4355c3cda0c7116e55e544ddfd11f7a9adaab4 (diff)
downloadports-74ba0b7dd4e40f2aae1ca3582f9392eb432e86db.tar.gz
ports-74ba0b7dd4e40f2aae1ca3582f9392eb432e86db.zip
Fix build with clang/libc++
Notes
Notes: svn path=/head/; revision=327479
Diffstat (limited to 'games')
-rw-r--r--games/allacrost/Makefile2
-rw-r--r--games/allacrost/files/patch-src-luabind-luabind-detail-call__function.hpp18
-rw-r--r--games/allacrost/files/patch-src-luabind-luabind-detail-call__member.hpp17
-rw-r--r--games/allacrost/files/patch-src-luabind-luabind-detail-get__signature.hpp19
-rw-r--r--games/allacrost/files/patch-src-luabind-luabind-wrapper__base.hpp17
-rw-r--r--games/allacrost/files/patch-src-utils.cpp16
-rw-r--r--games/valyriatear/Makefile2
7 files changed, 85 insertions, 6 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 9a237e2612d4..ae7108d59510 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -25,7 +25,7 @@ USE_OPENAL= al
USE_LUA= 5.1
USE_SDL= sdl ttf net
USE_GL= yes
-USE_GCC= 4.2+
+USE_GCC= yes # problems in luabind
USES= gettext
CONFIGURE_ARGS= --datadir=${DATADIR}
diff --git a/games/allacrost/files/patch-src-luabind-luabind-detail-call__function.hpp b/games/allacrost/files/patch-src-luabind-luabind-detail-call__function.hpp
new file mode 100644
index 000000000000..ffb5e450500b
--- /dev/null
+++ b/games/allacrost/files/patch-src-luabind-luabind-detail-call__function.hpp
@@ -0,0 +1,18 @@
+--- src/luabind/luabind/detail/call_function.hpp.orig 2010-01-04 02:08:15.000000000 +0300
++++ src/luabind/luabind/detail/call_function.hpp 2013-09-17 16:37:59.151519546 +0400
+@@ -323,7 +323,8 @@
+
+ #endif // LUABIND_CALL_FUNCTION_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -440,4 +441,5 @@
+
+
+ #endif
++#endif
+
diff --git a/games/allacrost/files/patch-src-luabind-luabind-detail-call__member.hpp b/games/allacrost/files/patch-src-luabind-luabind-detail-call__member.hpp
new file mode 100644
index 000000000000..3b0fbbea3db3
--- /dev/null
+++ b/games/allacrost/files/patch-src-luabind-luabind-detail-call__member.hpp
@@ -0,0 +1,17 @@
+--- src/luabind/luabind/detail/call_member.hpp.orig 2010-01-04 02:08:15.000000000 +0300
++++ src/luabind/luabind/detail/call_member.hpp 2013-09-17 06:10:17.991226170 +0400
+@@ -316,7 +316,8 @@
+
+ #endif // LUABIND_CALL_MEMBER_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -361,3 +362,4 @@
+
+ #endif
+
++#endif
diff --git a/games/allacrost/files/patch-src-luabind-luabind-detail-get__signature.hpp b/games/allacrost/files/patch-src-luabind-luabind-detail-get__signature.hpp
new file mode 100644
index 000000000000..6803b0a2e894
--- /dev/null
+++ b/games/allacrost/files/patch-src-luabind-luabind-detail-get__signature.hpp
@@ -0,0 +1,19 @@
+--- src/luabind/luabind/detail/get_signature.hpp.orig 2010-01-04 02:08:15.000000000 +0300
++++ src/luabind/luabind/detail/get_signature.hpp 2013-09-17 16:37:38.311587583 +0400
+@@ -160,7 +160,8 @@
+
+ #endif // LUABIND_GET_SIGNATURE_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ // member functions
+ template<class T, class C BOOST_PP_COMMA_IF(BOOST_PP_ITERATION()) BOOST_PP_ENUM_PARAMS(BOOST_PP_ITERATION(), class A)>
+@@ -212,5 +213,6 @@
+ }
+
+ #endif
++#endif
+
+ #endif // LUABIND_NO_ERROR_CHECKING
diff --git a/games/allacrost/files/patch-src-luabind-luabind-wrapper__base.hpp b/games/allacrost/files/patch-src-luabind-luabind-wrapper__base.hpp
new file mode 100644
index 000000000000..73a26627ed99
--- /dev/null
+++ b/games/allacrost/files/patch-src-luabind-luabind-wrapper__base.hpp
@@ -0,0 +1,17 @@
+--- ./src/luabind/luabind/wrapper_base.hpp.orig 2010-01-04 02:08:15.000000000 +0300
++++ ./src/luabind/luabind/wrapper_base.hpp 2013-09-17 06:29:47.072226158 +0400
+@@ -89,7 +89,8 @@
+
+ #endif // LUABIND_WRAPPER_BASE_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -188,3 +189,4 @@
+ #undef N
+
+ #endif
++#endif
diff --git a/games/allacrost/files/patch-src-utils.cpp b/games/allacrost/files/patch-src-utils.cpp
index 1744e5b3e887..3a1966441815 100644
--- a/games/allacrost/files/patch-src-utils.cpp
+++ b/games/allacrost/files/patch-src-utils.cpp
@@ -1,6 +1,14 @@
---- src/utils.cpp.orig 2010-09-02 20:33:23.000000000 +0400
-+++ src/utils.cpp 2010-09-02 20:34:01.000000000 +0400
-@@ -337,7 +337,7 @@
+--- src/utils.cpp.orig 2010-05-17 03:38:35.000000000 +0400
++++ src/utils.cpp 2013-09-17 03:18:36.343226027 +0400
+@@ -21,6 +21,7 @@
+ #else
+ #include <dirent.h>
+ #include <sys/types.h>
++ #include <unistd.h>
+ #include <pwd.h>
+ #endif
+
+@@ -337,7 +338,7 @@
}
const char *source_char = reinterpret_cast<const char *>(source);
@@ -9,7 +17,7 @@
// We are using an iconv API that uses const char*
const char *sourceChar = source_char;
#else
-@@ -369,7 +369,7 @@
+@@ -369,7 +370,7 @@
return false;
}
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index e0f1bcb14fbf..3a8c7844a481 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -27,7 +27,7 @@ USE_SDL= sdl image ttf
USE_GL= gl
USE_OPENAL= yes
USE_LUA= 5.1
-USE_GCC= any # problems in luabind; recheck with next update
+USE_GCC= yes # problems in luabind; recheck with next update
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lintl
PORTDOCS= *