aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 05:55:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-22 05:55:16 +0000
commit7628682008eee6789e49d5bfb059163e3bd9d3ad (patch)
treefcc82fa6d197b7e3690433b4af55c1b7e9915a64 /games
parent07efa6b5c4fdaec8b7159f5b8c106caf7696a470 (diff)
downloadports-7628682008eee6789e49d5bfb059163e3bd9d3ad.tar.gz
ports-7628682008eee6789e49d5bfb059163e3bd9d3ad.zip
[UPDATE] games/q3server-excessive: integrate with "quake3-data", rename to "quake3-excessive"
Changes: * Rename to "quake3-excessive" (also rename port directory). * Integrate with "quake3-data". PR: ports/86187 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=148998
Diffstat (limited to 'games')
-rw-r--r--games/quake3-excessive/Makefile28
-rw-r--r--games/quake3-excessive/pkg-descr6
-rw-r--r--games/quake3-excessive/pkg-plist15
3 files changed, 36 insertions, 13 deletions
diff --git a/games/quake3-excessive/Makefile b/games/quake3-excessive/Makefile
index 18ee1ddab40a..b1c526fcc761 100644
--- a/games/quake3-excessive/Makefile
+++ b/games/quake3-excessive/Makefile
@@ -7,12 +7,34 @@
PORTNAME= excessive
PORTVERSION= 003
+CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pat
DISTNAME= ${PORTNAME}_q3_server_${PORTVERSION}
-COMMENT= Quake III Arena Excessive Mod for Linux
+MAINTAINER= pat@FreeBSD.org
+COMMENT= Quake III Arena Mod: Excessive
-Q3_MOD_MASTER= ${.CURDIR}/../q3server-ra3
+WRKSRC= ${WRKDIR}/${PORTNAME}
-.include "${Q3_MOD_MASTER}/Makefile"
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-extract:
+ @(cd ${WRKSRC}; ${UNZIP_CMD} description.pk3)
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in description.txt motd.cfg maplist.cfg
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/vm
+ @${INSTALL_DATA} ${WRKSRC}/vm/qagame.qvm ${DATADIR}/vm
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include "${.CURDIR}/../quake3-data/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/games/quake3-excessive/pkg-descr b/games/quake3-excessive/pkg-descr
index a90135d78aa8..5a06f213b729 100644
--- a/games/quake3-excessive/pkg-descr
+++ b/games/quake3-excessive/pkg-descr
@@ -1,6 +1,6 @@
-This package contains all of the items you'll need to run a
-Quake III Arena dedicated server with Excessive mod under
-FreeBSD with Linux emulation.
+Excessive is a mod for Quake III Arena. It's a server-side only mod, so if you
+only want to play on Excessive servers, you do not need to install this. If
+you plan on running an Excessive server, then this is for you.
WWW: http://www.planetquake.com/excessive/
diff --git a/games/quake3-excessive/pkg-plist b/games/quake3-excessive/pkg-plist
index 88f642fc5b29..49ecc0a1e9a5 100644
--- a/games/quake3-excessive/pkg-plist
+++ b/games/quake3-excessive/pkg-plist
@@ -1,7 +1,8 @@
-%%Q3DIR%%description.pk3
-%%Q3DIR%%maplist.cfg
-%%Q3DIR%%motd.cfg
-%%Q3DIR%%readme.txt
-%%Q3DIR%%vm/qagame.qvm
-@dirrm %%Q3DIR%%vm
-@dirrm %%Q3DIR%%
+%%DATADIR%%/description.txt
+%%DATADIR%%/maplist.cfg
+%%DATADIR%%/motd.cfg
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%DATADIR%%/vm/qagame.qvm
+@dirrm %%DATADIR%%/vm
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%