aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2018-08-16 13:18:54 +0000
committerStefan Eßer <se@FreeBSD.org>2018-08-16 13:18:54 +0000
commit7a971b83a3af6dd47db3053c8b13a61daf62e18c (patch)
treec04898079a87e3edb761eae62ec20a6fc80a047c /games
parent737a6362f260d1eb9e7f8d9c9d532fb7ec84b974 (diff)
downloadports-7a971b83a3af6dd47db3053c8b13a61daf62e18c.tar.gz
ports-7a971b83a3af6dd47db3053c8b13a61daf62e18c.zip
Upgrade to latest official version and apply auth API patch not yet in
the official version. Approved by: antoine (implicit)
Notes
Notes: svn path=/head/; revision=477335
Diffstat (limited to 'games')
-rw-r--r--games/gogrepo/Makefile3
-rw-r--r--games/gogrepo/distinfo6
-rw-r--r--games/gogrepo/files/patch-gogrepo.py15
3 files changed, 17 insertions, 7 deletions
diff --git a/games/gogrepo/Makefile b/games/gogrepo/Makefile
index ceae6f20c060..e18533ee93c8 100644
--- a/games/gogrepo/Makefile
+++ b/games/gogrepo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gogrepo
PORTVERSION= 0.3a
+PORT_REVISION= 2
CATEGORIES= games net
MAINTAINER= se@FreeBSD.org
@@ -15,7 +16,7 @@ RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/html5lib/html5parser.py:www/py-html5lib
USE_GITHUB= yes
GH_ACCOUNT= eddie3
-GH_TAGNAME= c7f3dd0
+GH_TAGNAME= d64d45a
USES= python shebangfix
SHEBANG_FILES= gogrepo.py
diff --git a/games/gogrepo/distinfo b/games/gogrepo/distinfo
index ba473030e9cb..468dbc6200cc 100644
--- a/games/gogrepo/distinfo
+++ b/games/gogrepo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490357927
-SHA256 (eddie3-gogrepo-0.3a-c7f3dd0_GH0.tar.gz) = d6c35a08dc9d0d311dd93a767c197d17cb2f863d75c6d2febe3ce2d0ea6abf1e
-SIZE (eddie3-gogrepo-0.3a-c7f3dd0_GH0.tar.gz) = 15045
+TIMESTAMP = 1534425381
+SHA256 (eddie3-gogrepo-0.3a-d64d45a_GH0.tar.gz) = 02adc531637172e5f40bfd82ef5ea28c8cf86a3d00bfcfea805268499f697d97
+SIZE (eddie3-gogrepo-0.3a-d64d45a_GH0.tar.gz) = 15041
diff --git a/games/gogrepo/files/patch-gogrepo.py b/games/gogrepo/files/patch-gogrepo.py
index 69c2318a1e09..17627771a6d7 100644
--- a/games/gogrepo/files/patch-gogrepo.py
+++ b/games/gogrepo/files/patch-gogrepo.py
@@ -1,4 +1,4 @@
---- gogrepo.py.orig 2017-04-18 19:27:22 UTC
+--- gogrepo.py.orig 2018-05-23 15:45:06 UTC
+++ gogrepo.py
@@ -4,7 +4,7 @@ from __future__ import print_function
from __future__ import division
@@ -9,7 +9,7 @@
__author__ = 'eddie3'
__version__ = '0.3a'
__url__ = 'https://github.com/eddie3/gogrepo'
-@@ -110,7 +110,7 @@ HTTP_GAME_DOWNLOADER_THREADS = 4
+@@ -113,7 +113,7 @@ HTTP_GAME_DOWNLOADER_THREADS = 4
HTTP_PERM_ERRORCODES = (404, 403, 503)
# Save manifest data for these os and lang combinations
@@ -18,7 +18,16 @@
DEFAULT_LANG_LIST = ['en']
# These file types don't have md5 data from GOG
-@@ -575,7 +575,7 @@ def cmd_login(user, passwd):
+@@ -699,7 +699,7 @@ def cmd_login(user, passwd):
+ etree = html5lib.parse(page, namespaceHTMLElements=False)
+ for elm in etree.findall('.//script'):
+ if elm.text is not None and 'GalaxyAccounts' in elm.text:
+- login_data['auth_url'] = elm.text.split("'")[1]
++ login_data['auth_url'] = elm.text.split("'")[3]
+ break
+
+ # fetch the login token
+@@ -731,7 +731,7 @@ def cmd_login(user, passwd):
# perform two-step if needed
if login_data['two_step_url'] is not None: