aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2017-05-06 20:33:40 +0000
committerStefan Eßer <se@FreeBSD.org>2017-05-06 20:33:40 +0000
commit7aa1a2e07ab5178ab66a9c1139fedd884d917157 (patch)
tree7d82bb7e52bd448faff16eb1ce6dcc25fccf5006 /games
parent910185205211e7bf1a73c24ea90c7c9f41541dfa (diff)
downloadports-7aa1a2e07ab5178ab66a9c1139fedd884d917157.tar.gz
ports-7aa1a2e07ab5178ab66a9c1139fedd884d917157.zip
Batch downloader for games distributed by GOG.com (Good Old Games).
A number of Linux games distributed by GOG.com should be usable under Linux emulation on FreeBSD, but none has actually been tested. Approved by: antoine (mentor)
Notes
Notes: svn path=/head/; revision=440289
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gogrepo/Makefile36
-rw-r--r--games/gogrepo/distinfo3
-rw-r--r--games/gogrepo/files/patch-gogrepo.py29
-rw-r--r--games/gogrepo/pkg-descr12
5 files changed, 81 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 26d03344f478..db0e7d2dba59 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -377,6 +377,7 @@
SUBDIR += gnushogi
SUBDIR += gnustep-ladder
SUBDIR += gnustep-sudoku
+ SUBDIR += gogrepo
SUBDIR += golddig
SUBDIR += goldencheetah
SUBDIR += golly
diff --git a/games/gogrepo/Makefile b/games/gogrepo/Makefile
new file mode 100644
index 000000000000..672e6ee05b93
--- /dev/null
+++ b/games/gogrepo/Makefile
@@ -0,0 +1,36 @@
+# Created by: Stefan Esser <se@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gogrepo
+PORTVERSION= 0.3a
+CATEGORIES= games net
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Batch downloader for (linux,mac,windows) games distributed by GOG.com
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/html5lib/html5parser.py:www/py-html5lib \
+ html2text:textproc/py-html2text
+
+USE_GITHUB= yes
+GH_ACCOUNT= eddie3
+GH_TAGNAME= c7f3dd0
+
+USES= python shebangfix
+SHEBANG_FILES= gogrepo.py
+
+OPTIONS_DEFINE= DOCS
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= bin/gogrepo
+PORTDOCS= README.md
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/gogrepo.py ${STAGEDIR}${PREFIX}/bin/gogrepo
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/gogrepo/distinfo b/games/gogrepo/distinfo
new file mode 100644
index 000000000000..ba473030e9cb
--- /dev/null
+++ b/games/gogrepo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490357927
+SHA256 (eddie3-gogrepo-0.3a-c7f3dd0_GH0.tar.gz) = d6c35a08dc9d0d311dd93a767c197d17cb2f863d75c6d2febe3ce2d0ea6abf1e
+SIZE (eddie3-gogrepo-0.3a-c7f3dd0_GH0.tar.gz) = 15045
diff --git a/games/gogrepo/files/patch-gogrepo.py b/games/gogrepo/files/patch-gogrepo.py
new file mode 100644
index 000000000000..69c2318a1e09
--- /dev/null
+++ b/games/gogrepo/files/patch-gogrepo.py
@@ -0,0 +1,29 @@
+--- gogrepo.py.orig 2017-04-18 19:27:22 UTC
++++ gogrepo.py
+@@ -4,7 +4,7 @@ from __future__ import print_function
+ from __future__ import division
+ from __future__ import unicode_literals
+
+-__appname__ = 'gogrepo.py'
++__appname__ = 'gogrepo'
+ __author__ = 'eddie3'
+ __version__ = '0.3a'
+ __url__ = 'https://github.com/eddie3/gogrepo'
+@@ -110,7 +110,7 @@ HTTP_GAME_DOWNLOADER_THREADS = 4
+ HTTP_PERM_ERRORCODES = (404, 403, 503)
+
+ # Save manifest data for these os and lang combinations
+-DEFAULT_OS_LIST = ['windows']
++DEFAULT_OS_LIST = ['linux']
+ DEFAULT_LANG_LIST = ['en']
+
+ # These file types don't have md5 data from GOG
+@@ -575,7 +575,7 @@ def cmd_login(user, passwd):
+
+ # perform two-step if needed
+ if login_data['two_step_url'] is not None:
+- login_data['two_step_security_code'] = input("enter two-step security code: ")
++ login_data['two_step_security_code'] = input("enter two-step security code (sent by mail): ")
+
+ # Send the security code back to GOG
+ with request(login_data['two_step_url'], delay=0,
diff --git a/games/gogrepo/pkg-descr b/games/gogrepo/pkg-descr
new file mode 100644
index 000000000000..4d10d4d89285
--- /dev/null
+++ b/games/gogrepo/pkg-descr
@@ -0,0 +1,12 @@
+A Python-based tool for downloading your GOG.com game collections and
+extras to your local computer for full offline enjoyment.
+
+It is a clean standalone python script that can be run from anywhere.
+It requires a typical Python 2.7 or 3.x installation and html5lib.
+
+By default, game folders are saved in the same location that the script
+is run in. You can also specify another directory. Run gogrepo.py -h to
+see help or read more below. Each game has its own directories with all
+game/bonus files saved within.
+
+WWW: http://github.com/eddie3/gogrepo