aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-30 16:25:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-30 16:25:09 +0000
commit7d22a26b87bebdedfe9e8bf210fefbcf33dd7269 (patch)
tree312573e92631131acbd8ffaebf0d574d993fa95a /games
parent378a6482aa9bfac9049fe62404f79d678a8e5c4b (diff)
downloadports-7d22a26b87bebdedfe9e8bf210fefbcf33dd7269.tar.gz
ports-7d22a26b87bebdedfe9e8bf210fefbcf33dd7269.zip
- Fix shebangs
- Add NO_ARCH
Notes
Notes: svn path=/head/; revision=448992
Diffstat (limited to 'games')
-rw-r--r--games/schiff/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/games/schiff/Makefile b/games/schiff/Makefile
index be99ddccde12..7a57490f72b9 100644
--- a/games/schiff/Makefile
+++ b/games/schiff/Makefile
@@ -3,7 +3,7 @@
PORTNAME= schiff
PORTVERSION= 16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games python
MASTER_SITES= SF/pygamebook/${PORTNAME:S/s/S/}/${PORTNAME}${PORTVERSION}.py/ \
SF/nemysisfreebsdp/games/:icons
@@ -19,8 +19,11 @@ LICENSE= GPLv2+
RUN_DEPENDS= ${PYGAME}
-USES= python:2,run
+USES= python:2,run shebangfix
+SHEBANG_FILES= schiff.py
NO_BUILD= yes
+NO_WRKSUBDIR= yes
+NO_ARCH= yes
SUB_FILES= ${PORTNAME}
@@ -31,14 +34,14 @@ PLIST_FILES= bin/${PORTNAME} \
DESKTOP_ENTRIES="Schiff" "" ${PORTNAME} \
"${PORTNAME}" "Game;LogicGame;" ""
+do-extract:
+ @${CP} ${_DISTDIR}/schiff${PORTVERSION}.py ${WRKSRC}/${PORTNAME}.py
+
do-install:
- @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
- ${WRKDIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
@${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_SCRIPT} ${_DISTDIR}/schiff${PORTVERSION}.py \
- ${STAGEDIR}${DATADIR}/${PORTNAME}.py
-
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py \
+ ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/