aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-20 15:06:14 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-20 15:06:14 +0000
commit7e223b85118f24db9d6d99ba140621d85e2af079 (patch)
treed79f93c82dac5aec16534db50c252c8339ae3e0c /games
parent97df660718094932aa2f31a2c7235a8f991b8286 (diff)
downloadports-7e223b85118f24db9d6d99ba140621d85e2af079.tar.gz
ports-7e223b85118f24db9d6d99ba140621d85e2af079.zip
Define USE_PERL5_BUILD, not erroneous USE_PERL.
Submitted by: Oliver Eikemeier
Notes
Notes: svn path=/head/; revision=94477
Diffstat (limited to 'games')
-rw-r--r--games/3dc/Makefile2
-rw-r--r--games/alephone/Makefile2
-rw-r--r--games/atr3d/Makefile2
-rw-r--r--games/awele/Makefile2
-rw-r--r--games/bomberinstinct/Makefile2
-rw-r--r--games/doom/Makefile2
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/gcompris/Makefile2
-rw-r--r--games/gnocatan/Makefile2
-rw-r--r--games/gnomechess/Makefile2
-rw-r--r--games/gracer/Makefile2
-rw-r--r--games/hlserver-admin/Makefile2
-rw-r--r--games/hlserver-psychostats/Makefile2
-rw-r--r--games/lbreakout/Makefile2
-rw-r--r--games/myth2_demo/Makefile2
-rw-r--r--games/pengpong/Makefile2
-rw-r--r--games/pioneers/Makefile2
-rw-r--r--games/rtcw/Makefile2
-rw-r--r--games/scummvm/Makefile2
-rw-r--r--games/toppler/Makefile2
-rw-r--r--games/ttraffic/Makefile2
-rw-r--r--games/tuxtype/Makefile2
-rw-r--r--games/tvp/Makefile2
-rw-r--r--games/virt/Makefile2
-rw-r--r--games/xsokoban/Makefile2
-rw-r--r--games/zangband/Makefile2
26 files changed, 26 insertions, 26 deletions
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index 08906559a874..5eccd07d847d 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -17,7 +17,7 @@ COMMENT= 3-Dimensional Chess for X Window System
LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
USE_XPM= yes
WRKSRC= ${WRKDIR}/3Dc/src
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 1e66b70ad4bb..5ab09b48ea15 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12:install \
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index a69400728e42..72f8b7517695 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_MESA= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/games/awele/Makefile b/games/awele/Makefile
index ea72bf291675..f6d6d7556fc5 100644
--- a/games/awele/Makefile
+++ b/games/awele/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
WRKSRC= ${WRKDIR}/awele
USE_IMAKE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
MAN6= xawele.6
post-patch:
diff --git a/games/bomberinstinct/Makefile b/games/bomberinstinct/Makefile
index 659b588004e8..b4ae388256df 100644
--- a/games/bomberinstinct/Makefile
+++ b/games/bomberinstinct/Makefile
@@ -23,7 +23,7 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
diff --git a/games/doom/Makefile b/games/doom/Makefile
index 715052604645..1e8fa6fd01be 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -25,7 +25,7 @@ DISTFILES2= doom1v18.wad.gz
ONLY_FOR_ARCHS= i386
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_XLIB= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 319b5996783c..d58cdc3ec22a 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
NHDIR= "${PREFIX}/share/falconseyedir"
MAKE_ENV= NHDIR="${NHDIR}" NETHACKCONFIG="${NETHACKCONFIG}"
NETHACKCONFIG= ${FILESDIR}/x-config
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_X_PREFIX= Yes
USE_ZIP= yes
USE_XPM= yes
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 75e1744735dc..5e47ef3227ee 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gnomecanvas
USE_LIBTOOL= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index 31f56a50dbcb..65b08d639626 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -18,7 +18,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gnomechess/Makefile b/games/gnomechess/Makefile
index cdf307316897..fe0bbc6d2b8f 100644
--- a/games/gnomechess/Makefile
+++ b/games/gnomechess/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index d7d0960a4db3..fd57c9b88c8f 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
tcl82.1:${PORTSDIR}/lang/tcl82
USE_MESA= YES
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_AUTOCONF_VER=213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/tcl8.2 \
diff --git a/games/hlserver-admin/Makefile b/games/hlserver-admin/Makefile
index 06fd9f3d3470..41ca6211fa20 100644
--- a/games/hlserver-admin/Makefile
+++ b/games/hlserver-admin/Makefile
@@ -17,7 +17,7 @@ DIST_SUBDIR= ${PORTNAME}
COMMENT= Popular Half-Life mod server administration tool for Linux
-USE_PERL= yes
+USE_PERL5_BUILD=yes
WRKSRC= ${WRKDIR}/Adminmod
slaveport-post-extract:
diff --git a/games/hlserver-psychostats/Makefile b/games/hlserver-psychostats/Makefile
index 08bf454d2bdc..4ec350382770 100644
--- a/games/hlserver-psychostats/Makefile
+++ b/games/hlserver-psychostats/Makefile
@@ -18,7 +18,7 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= martin@tradex.sk
COMMENT= Popular player statistics generator for Half-Life (cs/dod)
-USE_PERL= yes
+USE_PERL5_BUILD=yes
WRKSRC= ${WRKDIR}/${DISTNAME}
# files which should be installed with executable perms
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index c723f874d94d..c50f0ee67a88 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-lcompat" \
SDL_CONFIG="${SDL_CONFIG}"
diff --git a/games/myth2_demo/Makefile b/games/myth2_demo/Makefile
index 945b9e183bf0..14c71b58ce46 100644
--- a/games/myth2_demo/Makefile
+++ b/games/myth2_demo/Makefile
@@ -28,7 +28,7 @@ RESTRICTED= "no license"
NO_CDROM= ${RESTRICTED}
NO_FTP= ${RESTRICTED}
USE_LINUX= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/update/demos/myth2_demo/
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index 59a4a8553421..f3ab10d46842 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -20,7 +20,7 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
NO_WRKSUBDIR= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-USE_PERL= yes
+USE_PERL5_BUILD=yes
DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
paddle.tga red.png
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index 31f56a50dbcb..65b08d639626 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -18,7 +18,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/games/rtcw/Makefile b/games/rtcw/Makefile
index 1ddb9a4038e8..52bd09a395b0 100644
--- a/games/rtcw/Makefile
+++ b/games/rtcw/Makefile
@@ -20,7 +20,7 @@ USE_LINUX_PREFIX= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
RTCWDIR= usr/games/rtcw
PLIST_SUB+= RTCWDIR="${RTCWDIR}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 73188024f905..26a2d3336116 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_REINPLACE= yes
MAN6= scummvm.6
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index bab21e26a241..916d125f02ae 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS+= SDL_mixer:${PORTSDIR}/audio/sdl_mixer
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
index d3d48a997e3e..768e727924d1 100644
--- a/games/ttraffic/Makefile
+++ b/games/ttraffic/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
post-patch:
${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index 077d86814c87..78f5fff04e77 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_AUTOMAKE_VER=14
USE_GMAKE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
diff --git a/games/tvp/Makefile b/games/tvp/Makefile
index 9f45beca4dee..6916864d3121 100644
--- a/games/tvp/Makefile
+++ b/games/tvp/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/tcl8.2 \
-ltcl82 -ltk82 -lX11 -lm"
#CFLAGS+= -lX11 -lm -ltcl82 -ltk82 \
# -L${LOCALBASE}/lib -L${X11BASE}/lib
-USE_PERL= yes
+USE_PERL5_BUILD=yes
MAN6= tvp.6
MLINKS= tvp.6 xprez.6 - aprez.6 - prez.6
diff --git a/games/virt/Makefile b/games/virt/Makefile
index 7628fda7351b..c1ecd46a0271 100644
--- a/games/virt/Makefile
+++ b/games/virt/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= lg@rrf.ru
COMMENT= Game and keyboard teacher in one. Enjoy it!
USE_GNOME= gtk12
-USE_PERL= yes
+USE_PERL5_BUILD=yes
MAN6= virt.6
MANCOMPRESSED= no
diff --git a/games/xsokoban/Makefile b/games/xsokoban/Makefile
index 9eebeecd1b33..f7ed636df79c 100644
--- a/games/xsokoban/Makefile
+++ b/games/xsokoban/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A puzzle of pushing objects to the goals
USE_IMAKE= yes
-USE_PERL= yes
+USE_PERL5_BUILD=yes
USE_XPM= yes
WRKSRC= ${WRKDIR}/xsokoban
ALL_TARGET= xsokoban
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index eafc3b61be5e..51c17ace9fc8 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -18,7 +18,7 @@ COMMENT= Zangband (Zelazny Angband) with color, X11 support
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER=14
-USE_PERL= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --datadir=${PREFIX}/lib \
--with-setgid=${SHAREGRP}