aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2001-06-16 10:33:59 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2001-06-16 10:33:59 +0000
commit82b3a1f5ea141463e93610b4351f922c0bf49774 (patch)
tree35e6f21f04ec509bf18dd7fe2014b8cddac30c23 /games
parent44b2d737c9750579fb45676262481f9419894c61 (diff)
downloadports-82b3a1f5ea141463e93610b4351f922c0bf49774.tar.gz
ports-82b3a1f5ea141463e93610b4351f922c0bf49774.zip
Initial import.
a visual, sound game library.
Notes
Notes: svn path=/head/; revision=44062
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/kxl/Makefile22
-rw-r--r--games/kxl/distinfo1
-rw-r--r--games/kxl/files/patch-aa64
-rw-r--r--games/kxl/pkg-comment1
-rw-r--r--games/kxl/pkg-descr5
-rw-r--r--games/kxl/pkg-plist6
7 files changed, 100 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index da0b67ae1b5c..55cb1b360742 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -141,6 +141,7 @@
SUBDIR += krogue
SUBDIR += krubik
SUBDIR += ktamaga
+ SUBDIR += kxl
SUBDIR += ladder
SUBDIR += lbreakout
SUBDIR += lexter
diff --git a/games/kxl/Makefile b/games/kxl/Makefile
new file mode 100644
index 000000000000..ee572956b5db
--- /dev/null
+++ b/games/kxl/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: kxl
+# Date created: 16 June 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kxl
+PORTVERSION= 0.5.6
+CATEGORIES= games
+MASTER_SITES= http://www2.mwnet.or.jp/~fc3srx7/download/
+DISTNAME= KXL-${PORTVERSION}
+
+MAINTAINER= nakai@FreeBSD.org
+
+USE_X_PREFIX= yes
+INSTALL_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS=="-L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/games/kxl/distinfo b/games/kxl/distinfo
new file mode 100644
index 000000000000..131ee98f886f
--- /dev/null
+++ b/games/kxl/distinfo
@@ -0,0 +1 @@
+MD5 (KXL-0.5.6.tar.gz) = 7868cf8e6c342da9cac03a0f5d933598
diff --git a/games/kxl/files/patch-aa b/games/kxl/files/patch-aa
new file mode 100644
index 000000000000..7ebdd5dc40e6
--- /dev/null
+++ b/games/kxl/files/patch-aa
@@ -0,0 +1,64 @@
+--- src/KXLsound.c.orig Thu May 17 18:08:13 2001
++++ src/KXLsound.c Sat Jun 16 19:31:43 2001
+@@ -3,7 +3,6 @@
+ #include <fcntl.h>
+ #include <sys/time.h>
+ #include <sys/ioctl.h>
+-#include <linux/soundcard.h>
+ #include "KXL.h"
+
+ #define MIN(a, b) ((a<b) ? a : b)
+@@ -45,12 +44,14 @@
+ ******************************************/
+ void KXL_SoundServer(void)
+ {
++#ifndef __FreeBSD__
+ Uint16 i;
+ KXL_SoundControl Command;
+ fd_set sound_fdset;
+
+ if (KXL_SoundOk == False)
+ return;
++
+
+ close(KXL_SoundData.Pipe[1]);
+ for (i = 0; i < MAX_SOUNDS_PLAYING; i ++)
+@@ -166,6 +167,7 @@
+ }
+ }
+ }
++#endif
+ }
+
+ /******************************************
+@@ -245,6 +247,7 @@
+ ******************************************/
+ void KXL_InitSound(Uint8 *path, Uint8 **fname)
+ {
++#ifndef __FreeBSD__
+ KXL_SoundOk = False;
+ KXL_LoadSoundData(path, fname);
+ if (pipe(KXL_SoundData.Pipe) < 0) {
+@@ -264,6 +267,7 @@
+ }
+ if (KXL_SoundOk == False)
+ fprintf(stderr, "KXL_InitSoundServer : no sounds\n");
++#endif
+ }
+
+ /******************************************
+@@ -271,6 +275,7 @@
+ ******************************************/
+ void KXL_EndSound(void)
+ {
++#ifndef __FreeBSD__
+ if (KXL_SoundOk == False)
+ return;
+ KXL_PlaySound(0, KXL_SOUND_STOP_ALL);
+@@ -278,5 +283,6 @@
+ KXL_Free(KXL_wavelist[-- KXL_SoundData.ListCnt]);
+ KXL_Free(KXL_wavelist);
+ kill(KXL_SoundData.ID, SIGTERM);
++#endif
+ }
+
diff --git a/games/kxl/pkg-comment b/games/kxl/pkg-comment
new file mode 100644
index 000000000000..8383ffc0249d
--- /dev/null
+++ b/games/kxl/pkg-comment
@@ -0,0 +1 @@
+a visual, sound library for games
diff --git a/games/kxl/pkg-descr b/games/kxl/pkg-descr
new file mode 100644
index 000000000000..7704fbc3d261
--- /dev/null
+++ b/games/kxl/pkg-descr
@@ -0,0 +1,5 @@
+a visual, sound library for games
+
+Sound is not available on FreeBSD.
+
+WWW: http://www2.mwnet.or.jp/~fc3srx7/down.html
diff --git a/games/kxl/pkg-plist b/games/kxl/pkg-plist
new file mode 100644
index 000000000000..108efddc0f93
--- /dev/null
+++ b/games/kxl/pkg-plist
@@ -0,0 +1,6 @@
+include/KXL.h
+lib/libKXL-0.5.6.so
+lib/libKXL.a
+lib/libKXL.so
+lib/libKXL.la
+share/aclocal/KXL.m4