aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-07-05 17:26:10 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-07-05 17:26:10 +0000
commit84d5cb591b6118197c17abd71e7ee85fea9c6550 (patch)
tree8d8c85d118c3706801ecd96c66093bd0b5589b81 /games
parent7e450076425a0509129b6963729d82423f020801 (diff)
downloadports-84d5cb591b6118197c17abd71e7ee85fea9c6550.tar.gz
ports-84d5cb591b6118197c17abd71e7ee85fea9c6550.zip
Add USE_CSTD=gnu89 to fix linking when building with clang
Notes
Notes: svn path=/head/; revision=300524
Diffstat (limited to 'games')
-rw-r--r--games/ezquake/Makefile1
-rw-r--r--games/fteqw/Makefile1
-rw-r--r--games/koth/Makefile1
-rw-r--r--games/sdlroids/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/games/ezquake/Makefile b/games/ezquake/Makefile
index 19b367c8ca8b..33cf4f134252 100644
--- a/games/ezquake/Makefile
+++ b/games/ezquake/Makefile
@@ -29,6 +29,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
USE_DOS2UNIX= *.[ch] Makefile*
USE_GMAKE= yes
USE_TCL= yes
+USE_CSTD= gnu89
MAKE_ENV= TCL_SUFX="${TCL_VER:S/.//}"
.for v in TCL_INCLUDEDIR TCL_LIBDIR DATADIR
MAKE_ENV+= ${v}="${${v}}"
diff --git a/games/fteqw/Makefile b/games/fteqw/Makefile
index fe29cf5f0e44..dba00e9ddfae 100644
--- a/games/fteqw/Makefile
+++ b/games/fteqw/Makefile
@@ -17,6 +17,7 @@ COMMENT= QuakeWorld client with cool features, but still compatible
USE_DOS2UNIX= yes
USE_GMAKE= yes
+USE_CSTD= gnu89
NO_WRKSUBDIR= yes
OPTIONS_MULTI= EXE
diff --git a/games/koth/Makefile b/games/koth/Makefile
index 788319134804..9dc2b121e3ae 100644
--- a/games/koth/Makefile
+++ b/games/koth/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
USE_BZIP2= yes
USE_GMAKE= yes
+USE_CSTD= gnu89
PLIST_FILES= bin/kclever-ai bin/kmoron-ai bin/koth bin/koths
MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
diff --git a/games/sdlroids/Makefile b/games/sdlroids/Makefile
index aac8e3008777..00db4ca0d658 100644
--- a/games/sdlroids/Makefile
+++ b/games/sdlroids/Makefile
@@ -18,6 +18,7 @@ USE_SDL= mixer sdl
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
+USE_CSTD= gnu89
MAN6= sdlroids.6