aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-06-16 21:41:43 +0000
committerSteve Wills <swills@FreeBSD.org>2018-06-16 21:41:43 +0000
commit878350f44fbd3e618639b07613084a6cf2869277 (patch)
tree86a7ab990303c06f5ae6b48203ebeb2ed83370f6 /games
parent3a3a1be7be2993ee7db59144a5313113306f326c (diff)
downloadports-878350f44fbd3e618639b07613084a6cf2869277.tar.gz
ports-878350f44fbd3e618639b07613084a6cf2869277.zip
games/frogatto: fix build on HEAD
PR: 229066 Submitted by: fiziologus@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=472570
Diffstat (limited to 'games')
-rw-r--r--games/frogatto/Makefile3
-rw-r--r--games/frogatto/files/patch-Makefile2
-rw-r--r--games/frogatto/files/patch-src-code_editor_dialog.cpp11
-rw-r--r--games/frogatto/files/patch-src-surface_cache.cpp11
-rw-r--r--games/frogatto/files/patch-src-texture.hpp11
5 files changed, 36 insertions, 2 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 753b3d164cff..7d50a66fb52c 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -3,7 +3,7 @@
PORTNAME= frogatto
PORTVERSION= 1.3.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MAINTAINER= fiziologus@gmail.com
@@ -26,6 +26,7 @@ USES= gmake pkgconfig
ALL_TARGET= game server
USE_GL= glew glu
USE_SDL= sdl image mixer ttf
+USE_CXXSTD= c++11
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
diff --git a/games/frogatto/files/patch-Makefile b/games/frogatto/files/patch-Makefile
index 50294eedbd5d..de5962f8035f 100644
--- a/games/frogatto/files/patch-Makefile
+++ b/games/frogatto/files/patch-Makefile
@@ -14,7 +14,7 @@
# Initial compiler options, used before CXXFLAGS and CPPFLAGS.
-BASE_CXXFLAGS += -g -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wignored-qualifiers -Wformat -Wswitch
-+BASE_CXXFLAGS += -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wformat -Wswitch
++BASE_CXXFLAGS += -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wformat -Wswitch -Wno-narrowing
# Compiler include options, used after CXXFLAGS and CPPFLAGS.
INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng zlib)
diff --git a/games/frogatto/files/patch-src-code_editor_dialog.cpp b/games/frogatto/files/patch-src-code_editor_dialog.cpp
new file mode 100644
index 000000000000..37fa72cbf600
--- /dev/null
+++ b/games/frogatto/files/patch-src-code_editor_dialog.cpp
@@ -0,0 +1,11 @@
+--- src/code_editor_dialog.cpp.orig 2018-06-16 12:59:49.843741000 +0300
++++ src/code_editor_dialog.cpp 2018-06-16 13:01:13.695918000 +0300
+@@ -55,7 +55,7 @@
+
+ //std::cerr << "CED: " << x() << "," << y() << "; " << width() << "," << height() << std::endl;
+ drag_widget* dragger = new drag_widget(x(), y(), width(), height(),
+- drag_widget::DRAG_HORIZONTAL, NULL,
++ drag_widget::DRAG_HORIZONTAL, [](int, int){},
+ boost::bind(&code_editor_dialog::on_drag_end, this, _1, _2),
+ boost::bind(&code_editor_dialog::on_drag, this, _1, _2));
+
diff --git a/games/frogatto/files/patch-src-surface_cache.cpp b/games/frogatto/files/patch-src-surface_cache.cpp
new file mode 100644
index 000000000000..f0ecde358279
--- /dev/null
+++ b/games/frogatto/files/patch-src-surface_cache.cpp
@@ -0,0 +1,11 @@
+--- src/surface_cache.cpp.orig 2018-06-16 13:59:29.319430000 +0300
++++ src/surface_cache.cpp 2018-06-16 14:00:09.140102000 +0300
+@@ -116,7 +116,7 @@
+ }
+ #endif // ANDROID
+ //std::cerr << "loading image '" << fname << "'\n";
+- if(surf.get() == false || surf->w == 0) {
++ if(surf.get() == nullptr || surf->w == 0) {
+ if(key != "") {
+ std::cerr << "failed to load image '" << key << "'\n";
+ }
diff --git a/games/frogatto/files/patch-src-texture.hpp b/games/frogatto/files/patch-src-texture.hpp
new file mode 100644
index 000000000000..eb4210b32904
--- /dev/null
+++ b/games/frogatto/files/patch-src-texture.hpp
@@ -0,0 +1,11 @@
+--- src/texture.hpp.orig 2018-06-16 11:06:31.462187000 +0300
++++ src/texture.hpp 2018-06-16 11:11:11.775394000 +0300
+@@ -58,7 +58,7 @@
+ unsigned int get_id() const;
+ static void set_current_texture(unsigned int id);
+ void set_as_current_texture() const;
+- bool valid() const { return id_; }
++ bool valid() const { return static_cast<bool>(id_); }
+
+ static texture get(const std::string& str, int options=0);
+ static texture get(const std::string& str, const std::string& algorithm);