aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-10-14 18:29:38 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-10-14 18:29:46 +0000
commit8836ed4d8ccbe9d12abec32d0a8062835bbd55c4 (patch)
tree58162766fe0913f41c1b9f051ebd23be6511e1ff /games
parentc45b9330c566f85c8e4e3b48c24ef000d50ff15d (diff)
downloadports-8836ed4d8ccbe9d12abec32d0a8062835bbd55c4.tar.gz
ports-8836ed4d8ccbe9d12abec32d0a8062835bbd55c4.zip
games/SpaceCadetPinball: Use current directory not PREFIX
Diffstat (limited to 'games')
-rw-r--r--games/SpaceCadetPinball/Makefile1
-rw-r--r--games/SpaceCadetPinball/files/patch-SpaceCadetPinball_winmain.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/SpaceCadetPinball/Makefile b/games/SpaceCadetPinball/Makefile
index 2ca3b0dfefd8..c48fed37a377 100644
--- a/games/SpaceCadetPinball/Makefile
+++ b/games/SpaceCadetPinball/Makefile
@@ -1,5 +1,6 @@
PORTNAME= SpaceCadetPinball
PORTVERSION= 1.1.1.20211010
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= nc@FreeBSD.org
diff --git a/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_winmain.cpp b/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_winmain.cpp
new file mode 100644
index 000000000000..9784ec56667e
--- /dev/null
+++ b/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_winmain.cpp
@@ -0,0 +1,11 @@
+--- SpaceCadetPinball/winmain.cpp.orig 2021-10-14 18:28:42 UTC
++++ SpaceCadetPinball/winmain.cpp
+@@ -56,7 +56,7 @@ int winmain::WinMain(LPCSTR lpCmdLine)
+ SDL_ShowSimpleMessageBox(SDL_MESSAGEBOX_ERROR, "Could not initialize SDL2", SDL_GetError(), nullptr);
+ return 1;
+ }
+- BasePath = SDL_GetBasePath();
++ BasePath = SDL_strdup("./");
+
+ pinball::quickFlag = strstr(lpCmdLine, "-quick") != nullptr;
+ DatFileName = options::get_string("Pinball Data", pinball::get_rc_string(168, 0));