aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-17 10:41:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-17 10:41:47 +0000
commit8c3765c795b032e0a84a7981d32851fba2bbf50a (patch)
treebd4607d2969a1150edd0c1b506b3fe4b67b3ed87 /games
parent25c786b1f574f011a545552da3b1d735aa4a9a22 (diff)
downloadports-8c3765c795b032e0a84a7981d32851fba2bbf50a.tar.gz
ports-8c3765c795b032e0a84a7981d32851fba2bbf50a.zip
A simple, easy to understand game. From an overhead perspective, pilot your
little ship around with the arrow keys, shooting your way (with the space bar) through about twenty levels of action and gorgeous (_cough_) 3d graphics. In theory, all you windows folks need to do is extract the archive, and double click the exe. In theory. Sorry, I never got round to adding sound - but look on the bright side, at least you can use it at work without anyone noticing. :) PR: ports/84924 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=142996
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/duel/Makefile64
-rw-r--r--games/duel/distinfo2
-rw-r--r--games/duel/files/duel-sh.in21
-rw-r--r--games/duel/pkg-descr8
-rw-r--r--games/duel/pkg-plist82
6 files changed, 178 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9503cfa734bc..3e129fffe1f2 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -118,6 +118,7 @@
SUBDIR += dopewars
SUBDIR += drm
SUBDIR += dsnake
+ SUBDIR += duel
SUBDIR += duke3d
SUBDIR += dungeon
SUBDIR += dungeoncrawl
diff --git a/games/duel/Makefile b/games/duel/Makefile
new file mode 100644
index 000000000000..02d80e97d5b3
--- /dev/null
+++ b/games/duel/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: duel
+# Date created: 10 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= duel
+PORTVERSION= 0.98
+CATEGORIES= games
+MASTER_SITES= http://www.personal.rdg.ac.uk/~sir03me/
+DISTNAME= lin${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= An overhead, OpenGL space shooter
+
+BUILD_DEPENDS= ${X11BASE}/lib/libftgl.a:${PORTSDIR}/graphics/ftgl
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
+USE_GL= yes
+USE_SDL= sdl
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ''
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` `freetype-config --cflags` -I${X11BASE}/include -I${X11BASE}/include/FTGL" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+
+SUB_FILES= ${PORTNAME}-sh
+
+post-patch:
+# Fix SDL include statement
+.for f in *.cpp *.h
+ @${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
+ ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+# Remove -lSDL flag
+ @${REINPLACE_CMD} -e 's|-lSDL ||' ${WRKSRC}/src/Makefile.in
+
+do-install:
+# Script
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
+
+# Program
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/libexec
+
+# Data
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/runDir/* ${DATADIR}
+
+post-install:
+# Fix permissions
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ ${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ ${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+
+.include <bsd.port.mk>
diff --git a/games/duel/distinfo b/games/duel/distinfo
new file mode 100644
index 000000000000..60cfef7e9895
--- /dev/null
+++ b/games/duel/distinfo
@@ -0,0 +1,2 @@
+MD5 (linduel.tar.bz2) = 651311e4342572e68e84018a80b690b0
+SIZE (linduel.tar.bz2) = 8555684
diff --git a/games/duel/files/duel-sh.in b/games/duel/files/duel-sh.in
new file mode 100644
index 000000000000..a4b16f177e54
--- /dev/null
+++ b/games/duel/files/duel-sh.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.duel, and create symlinks to the data files, but the configuration file
+# is copied, and write permission for the user is added to it.
+
+cd %%DATADIR%% || exit 1
+
+find * -type d -exec mkdir -p ~/.duel/{} \; || exit 1
+
+for f in log.txt scores
+do
+ test -f ~/.duel/$f || cp $f ~/.duel && chmod u+w ~/.duel/$f
+done
+
+find * -type f -exec ln -s %%DATADIR%%/{} ~/.duel/{} \; 2>/dev/null || exit 1
+
+cd ~/.duel || exit 1
+
+exec %%PREFIX%%/libexec/duel
diff --git a/games/duel/pkg-descr b/games/duel/pkg-descr
new file mode 100644
index 000000000000..f3ab53413051
--- /dev/null
+++ b/games/duel/pkg-descr
@@ -0,0 +1,8 @@
+A simple, easy to understand game. From an overhead perspective, pilot your
+little ship around with the arrow keys, shooting your way (with the space bar)
+through about twenty levels of action and gorgeous (_cough_) 3d graphics. In
+theory, all you windows folks need to do is extract the archive, and double
+click the exe. In theory. Sorry, I never got round to adding sound - but look
+on the bright side, at least you can use it at work without anyone noticing. :)
+
+WWW: http://www.personal.rdg.ac.uk/~sir03me/code.html
diff --git a/games/duel/pkg-plist b/games/duel/pkg-plist
new file mode 100644
index 000000000000..6c497af8bbb1
--- /dev/null
+++ b/games/duel/pkg-plist
@@ -0,0 +1,82 @@
+bin/duel
+libexec/duel
+%%DATADIR%%/log.txt
+%%DATADIR%%/scores
+%%DATADIR%%/data/Artlookin.zip
+%%DATADIR%%/data/Artlookin/Artlookin-Regular.ttf
+%%DATADIR%%/data/Artlookin/ArtlookinBold.ttf
+%%DATADIR%%/data/Artlookin/ArtlookinItalic.ttf
+%%DATADIR%%/data/Artlookin/ArtlookinOneType.ttf
+%%DATADIR%%/data/Azimech.ttf
+%%DATADIR%%/data/Azimech.zip
+%%DATADIR%%/data/azimech.txt
+%%DATADIR%%/data/back.bmp
+%%DATADIR%%/data/base.bmp
+%%DATADIR%%/data/base.obj
+%%DATADIR%%/data/intro.bmp
+%%DATADIR%%/data/levels/demo0.dvl
+%%DATADIR%%/data/levels/demo1.dvl
+%%DATADIR%%/data/levels/demo2.dvl
+%%DATADIR%%/data/levels/galaxy.gal
+%%DATADIR%%/data/levels/level1.dvl
+%%DATADIR%%/data/levels/level10.dvl
+%%DATADIR%%/data/levels/level11.dvl
+%%DATADIR%%/data/levels/level12.dvl
+%%DATADIR%%/data/levels/level13.dvl
+%%DATADIR%%/data/levels/level14.dvl
+%%DATADIR%%/data/levels/level15.dvl
+%%DATADIR%%/data/levels/level16.dvl
+%%DATADIR%%/data/levels/level17.dvl
+%%DATADIR%%/data/levels/level18.dvl
+%%DATADIR%%/data/levels/level19.dvl
+%%DATADIR%%/data/levels/level2.dvl
+%%DATADIR%%/data/levels/level20.dvl
+%%DATADIR%%/data/levels/level3.dvl
+%%DATADIR%%/data/levels/level4.dvl
+%%DATADIR%%/data/levels/level5.dvl
+%%DATADIR%%/data/levels/level6.dvl
+%%DATADIR%%/data/levels/level7.dvl
+%%DATADIR%%/data/levels/level8.dvl
+%%DATADIR%%/data/levels/level9.dvl
+%%DATADIR%%/data/rock.bmp
+%%DATADIR%%/data/rock.obj
+%%DATADIR%%/data/rock2.obj
+%%DATADIR%%/data/ships/bigship.obj
+%%DATADIR%%/data/ships/gladiator.bmp
+%%DATADIR%%/data/ships/gladiator.obj
+%%DATADIR%%/data/ships/gladiator.shp
+%%DATADIR%%/data/ships/gladiator_nb.bmp
+%%DATADIR%%/data/ships/gladiator_redb.bmp
+%%DATADIR%%/data/ships/miggy.bmp
+%%DATADIR%%/data/ships/miggy.obj
+%%DATADIR%%/data/ships/miggy.shp
+%%DATADIR%%/data/ships/miggyBoosted.shp
+%%DATADIR%%/data/ships/miggy_nb.bmp
+%%DATADIR%%/data/ships/miggy_redb.bmp
+%%DATADIR%%/data/ships/mule.bmp
+%%DATADIR%%/data/ships/mule.obj
+%%DATADIR%%/data/ships/mule.shp
+%%DATADIR%%/data/ships/mule_mk2.bmp
+%%DATADIR%%/data/ships/mule_mk2.shp
+%%DATADIR%%/data/ships/mule_nb.bmp
+%%DATADIR%%/data/ships/mule_redb.bmp
+%%DATADIR%%/data/ships/pulsar.bmp
+%%DATADIR%%/data/ships/pulsar.obj
+%%DATADIR%%/data/ships/pulsar.shp
+%%DATADIR%%/data/ships/pulsar_nb.bmp
+%%DATADIR%%/data/ships/pulsar_redb.bmp
+%%DATADIR%%/data/ships/ray.bmp
+%%DATADIR%%/data/ships/ray.obj
+%%DATADIR%%/data/ships/ray.shp
+%%DATADIR%%/data/ships/ray2.obj
+%%DATADIR%%/data/ships/ray_nb.bmp
+%%DATADIR%%/data/ships/ray_redb.bmp
+%%DATADIR%%/data/shot.bmp
+%%DATADIR%%/data/shot2.bmp
+%%DATADIR%%/data/shot3.bmp
+%%DATADIR%%/data/stars.bmp
+@dirrm %%DATADIR%%/data/ships
+@dirrm %%DATADIR%%/data/levels
+@dirrm %%DATADIR%%/data/Artlookin
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%