aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-16 19:04:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-16 20:33:11 +0000
commit8c64c7509613a9ef648f84603fbf438801cffde8 (patch)
tree8ac90838f7551135138e61c68bb3e9e615c3d548 /games
parent8993bae2daf3f6105494f0776e3577c3aaaf4f9d (diff)
downloadports-8c64c7509613a9ef648f84603fbf438801cffde8.tar.gz
ports-8c64c7509613a9ef648f84603fbf438801cffde8.zip
games/xmoto: update 0.5.11 → 0.6.1
Diffstat (limited to 'games')
-rw-r--r--games/xmoto/Makefile48
-rw-r--r--games/xmoto/distinfo5
-rw-r--r--games/xmoto/files/patch-src-GameInit.cpp11
-rw-r--r--games/xmoto/files/patch-src-VTexture.h11
-rw-r--r--games/xmoto/files/patch-src-WWW.cpp47
-rw-r--r--games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp34
-rw-r--r--games/xmoto/files/patch-src-helpers-System.cpp11
-rw-r--r--games/xmoto/files/patch-src-include-xm__hashmap.h33
-rw-r--r--games/xmoto/files/patch-src_CMakeLists.txt57
-rw-r--r--games/xmoto/files/patch-src_common_Locales.cpp25
-rw-r--r--games/xmoto/pkg-plist35
11 files changed, 120 insertions, 197 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index ae5eca40d627..f9178f5e9a4b 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -1,10 +1,6 @@
PORTNAME= xmoto
-PORTVERSION= 0.5.11
-PORTREVISION= 10
+PORTVERSION= 0.6.1
CATEGORIES= games
-MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
- http://mirror.amdmi3.ru/distfiles/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Challenging 2D motocross platform game
@@ -17,47 +13,39 @@ LIB_DEPENDS= libode.so:devel/ode \
libcurl.so:ftp/curl \
libxdg-basedir.so:x11/libxdg-basedir
-GNU_CONFIGURE= yes
-USES= compiler:c++11-lang dos2unix gl gmake gnome jpeg localbase lua:51 sdl sqlite xorg
+USES= compiler:c++11-lang cmake gl gnome jpeg lua:52 pkgconfig sdl sqlite
+USE_GITHUB= yes
USE_GNOME= libxml2
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
-USE_CXXSTD= c++11
-USE_XORG= x11
-DOS2UNIX_GLOB= *.cpp *.h
+CMAKE_ARGS= -DOpenGL_GL_PREFERENCE="GLVND"
-CPPFLAGS+= -isystem${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-PORTDOCS= README ChangeLog
+PORTDOCS= README.md ChangeLog
PORTDATA= *
-DESKTOP_ENTRIES="XMoto" \
- "Motorcross game" \
- "${DATADIR}/xmoto_icone_x.ico" \
- "xmoto" \
- "Game;SportsGame;ArcadeGame;" \
- false
+ASIAN_FONT_PATH=${LOCALBASE}/share/fonts/TrueType/bkai00mp.ttf
OPTIONS_DEFINE= ASIAN_TTF DOCS NLS
OPTIONS_SUB= yes
ASIAN_TTF_DESC= Use asian TTF font
+ASIAN_TTF_RUN_DEPENDS= ${ASIAN_FONT_PATH}:chinese/arphicttf
-ASIAN_TTF_RUN_DEPENDS= ${LOCALBASE}/share/fonts/TrueType/bkai00mp.ttf:chinese/arphicttf
-ASIAN_TTF_CONFIGURE_ON= --with-asian-ttf-file=${LOCALBASE}/share/fonts/TrueType/bsmi00lp.ttf
-ASIAN_TTF_CONFIGURE_OFF=--without-asian-ttf-file
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_CMAKE_BOOL= USE_GETTEXT
+# ensure bundled depends are not used
post-extract:
- @${RM} -r ${WRKSRC}/src/ode
+.for d in bzip2 lua ode xdgbasedir
+ @${RM} -r ${WRKSRC}/src/${d}
+.endfor
post-patch:
- @${REINPLACE_CMD} -e "s/lua5.1/lua-${LUA_VER}/g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} \
+ -e "s|find_package(Lua|& ${LUA_VER} REQUIRED EXACT|" \
+ -e "s|/usr/share/fonts/truetype/arphic/bkai00mp.ttf|${ASIAN_FONT_PATH}|" \
+ -e "s|DEFAULT_ASIAN_TTF_FILE|ASIAN_TTF_FILE|" \
+ ${WRKSRC}/src/CMakeLists.txt
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index 1c8b11fe613e..a6e8c0a69834 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xmoto-0.5.11-src.tar.gz) = a584a6f9292b184686b72c78f16de4b82d5c5b72ad89e41912ff50d03eca26b2
-SIZE (xmoto-0.5.11-src.tar.gz) = 40785573
+TIMESTAMP = 1647452639
+SHA256 (xmoto-xmoto-0.6.1_GH0.tar.gz) = 209c8c38b1742d0620d40f90365c7a56f67c86da826c80a76d37fa46ee9c9b66
+SIZE (xmoto-xmoto-0.6.1_GH0.tar.gz) = 41623870
diff --git a/games/xmoto/files/patch-src-GameInit.cpp b/games/xmoto/files/patch-src-GameInit.cpp
deleted file mode 100644
index f1af17b61b4c..000000000000
--- a/games/xmoto/files/patch-src-GameInit.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/GameInit.cpp.orig 2011-10-11 20:18:35 UTC
-+++ src/GameInit.cpp
-@@ -248,7 +248,7 @@ void GameApp::run_load(int nNumArgs, cha
- Logger::setActiv(XMSession::instance()->noLog() == false); /* apply log activ mode */
-
- LogInfo(std::string("X-Moto " + XMBuild::getVersionString(true)).c_str());
-- LogInfo("compiled at "__DATE__" "__TIME__);
-+ LogInfo("compiled at " __DATE__ " " __TIME__);
- if(SwapEndian::bigendien) {
- LogInfo("Systeme is bigendien");
- } else {
diff --git a/games/xmoto/files/patch-src-VTexture.h b/games/xmoto/files/patch-src-VTexture.h
deleted file mode 100644
index ab8dcd92d31a..000000000000
--- a/games/xmoto/files/patch-src-VTexture.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/VTexture.h.orig 2011-10-11 20:18:35 UTC
-+++ src/VTexture.h
-@@ -135,7 +135,7 @@ private:
-
- void cleanUnregistredTextures();
-
-- HashNamespace::hash_map<const char*, int*, HashNamespace::hash<const char*>, hashcmp_str> m_textureSizeCache;
-+ HashNamespace::hash_map<std::string, int*> m_textureSizeCache;
- std::vector<std::string> m_textureSizeCacheKeys;
- std::vector<int*> m_textureSizeCacheValues;
-
diff --git a/games/xmoto/files/patch-src-WWW.cpp b/games/xmoto/files/patch-src-WWW.cpp
deleted file mode 100644
index b9dd3df2540f..000000000000
--- a/games/xmoto/files/patch-src-WWW.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/WWW.cpp.orig 2011-10-11 20:18:35 UTC
-+++ src/WWW.cpp
-@@ -206,7 +206,7 @@ void FSWeb::downloadFile(const std::stri
- std::string v_www_agent = WWW_AGENT;
-
- /* open the file */
-- if( (v_destinationFile = fopen(v_local_file_tmp.c_str(), "wb")) == false) {
-+ if( (v_destinationFile = fopen(v_local_file_tmp.c_str(), "wb")) == NULL) {
- throw Exception("error : unable to open output file "
- + v_local_file_tmp);
- }
-@@ -320,7 +320,7 @@ void FSWeb::uploadReplay(const std::stri
- LogInfo(std::string("Uploading replay " + p_replayFilename).c_str());
-
- /* open the file */
-- if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == false) {
-+ if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == NULL) {
- throw Exception("error : unable to open output file " DEFAULT_WWW_MSGFILE("UR"));
- }
-
-@@ -478,7 +478,7 @@ void FSWeb::sendVote(const std::string&
- LogInfo("Sending vote");
-
- /* open the file */
-- if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == false) {
-+ if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == NULL) {
- throw Exception("error : unable to open output file " DEFAULT_WWW_MSGFILE("SV"));
- }
-
-@@ -562,7 +562,7 @@ void FSWeb::sendReport(const std::string
- LogInfo("Sending report");
-
- /* open the file */
-- if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == false) {
-+ if( (v_destinationFile = fopen(v_local_file.c_str(), "wb")) == NULL) {
- throw Exception("error : unable to open output file " DEFAULT_WWW_MSGFILE("SR"));
- }
-
-@@ -677,7 +677,7 @@ void FSWeb::uploadDbSync(const std::stri
- LogInfo(std::string("Uploading dbsync " + p_dbSyncFilename + " to " + p_url_to_transfert).c_str());
-
- /* open the file */
-- if( (v_destinationFile = fopen(p_answerFile.c_str(), "wb")) == false) {
-+ if( (v_destinationFile = fopen(p_answerFile.c_str(), "wb")) == NULL) {
- throw Exception("error : unable to open output file " + p_answerFile);
- }
-
diff --git a/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp b/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
deleted file mode 100644
index 142ccfe0fb23..000000000000
--- a/games/xmoto/files/patch-src-drawlib-DrawLibOpenGL.cpp
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/drawlib/DrawLibOpenGL.cpp.orig 2011-10-11 20:18:26 UTC
-+++ src/drawlib/DrawLibOpenGL.cpp
-@@ -80,7 +80,7 @@ public:
- /* a glyph from other glyphs */
- /*kejo:why not just grrr create a copy contructor*/
- GLFontGlyph(const std::string& i_value,
-- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str>& i_glyphsLetters);
-+ HashNamespace::hash_map<std::string, GLFontGlyphLetter*>& i_glyphsLetters);
- virtual ~GLFontGlyph();
-
- std::string Value() const;
-@@ -132,11 +132,11 @@ public:
- private:
- std::vector<std::string> m_glyphsKeys;
- std::vector<GLFontGlyph*> m_glyphsValues;
-- HashNamespace::hash_map<const char*, GLFontGlyph*, HashNamespace::hash<const char*>, hashcmp_str> m_glyphs;
-+ HashNamespace::hash_map<std::string, GLFontGlyph*> m_glyphs;
-
- std::vector<std::string> m_glyphsLettersKeys;
- std::vector<GLFontGlyphLetter*> m_glyphsLettersValues;
-- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str> m_glyphsLetters;
-+ HashNamespace::hash_map<std::string, GLFontGlyphLetter*> m_glyphsLetters;
-
- unsigned int getLonguestLineSize(const std::string& i_value, unsigned int i_start = 0, unsigned int i_nbLinesToRead = -1);
- };
-@@ -825,7 +825,7 @@ GLFontGlyph::GLFontGlyph(const std::stri
- }
-
- GLFontGlyph::GLFontGlyph(const std::string& i_value,
-- HashNamespace::hash_map<const char*, GLFontGlyphLetter*, HashNamespace::hash<const char*>, hashcmp_str>& i_glyphsLetters) {
-+ HashNamespace::hash_map<std::string, GLFontGlyphLetter*>& i_glyphsLetters) {
- GLFontGlyph* v_glyph;
- std::string v_char;
-
diff --git a/games/xmoto/files/patch-src-helpers-System.cpp b/games/xmoto/files/patch-src-helpers-System.cpp
deleted file mode 100644
index 8de4695f8677..000000000000
--- a/games/xmoto/files/patch-src-helpers-System.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/helpers/System.cpp.orig 2014-03-29 06:14:14 UTC
-+++ src/helpers/System.cpp
-@@ -31,6 +31,8 @@ Foundation, Inc., 59 Temple Place, Suite
- #include <unistd.h>
- #endif
-
-+#include <unistd.h> // for getpid()
-+
- std::vector<std::string>* System::getDisplayModes(int windowed) {
- std::vector<std::string>* modes = new std::vector<std::string>;
- SDL_Rect **sdl_modes;
diff --git a/games/xmoto/files/patch-src-include-xm__hashmap.h b/games/xmoto/files/patch-src-include-xm__hashmap.h
deleted file mode 100644
index 4696d9b3c8d3..000000000000
--- a/games/xmoto/files/patch-src-include-xm__hashmap.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/include/xm_hashmap.h.orig 2019-10-23 11:51:33 UTC
-+++ src/include/xm_hashmap.h
-@@ -1,25 +1,11 @@
- #ifndef __XMHASHMAP_H__
- #define __XMHASHMAP_H__
-
--#ifdef __GNUC__
--#if (__GNUC__ >= 3)
--#include <ext/hash_map>
-- namespace HashNamespace=__gnu_cxx;
--#else
--#include <hash_map>
--#define HashNamespace std
--#endif
--#else // #ifdef __GNUC__
--#include <hash_map>
--namespace HashNamespace=std;
--#endif
--struct hashcmp_str {
-- bool operator()(const char* s1, const char* s2) {
-- if(s1 == NULL || s2 == NULL) {
-- return false;
-- }
-- return strcmp(s1, s2) == 0;
-- }
-+#include <unordered_map>
-+
-+namespace HashNamespace {
-+ template <class Key, class T, class Hash = std::hash<Key>, class Pred = std::equal_to<Key>, class Allocator = std::allocator< std::pair<const Key, T> >>
-+ using hash_map = std::unordered_map<Key, T, Hash, Pred, Allocator>;
- };
-
- #endif
diff --git a/games/xmoto/files/patch-src_CMakeLists.txt b/games/xmoto/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..bb012ae49335
--- /dev/null
+++ b/games/xmoto/files/patch-src_CMakeLists.txt
@@ -0,0 +1,57 @@
+--- src/CMakeLists.txt.orig 2020-06-21 19:18:16 UTC
++++ src/CMakeLists.txt
+@@ -41,7 +41,7 @@ endif()
+ find_package(PNG REQUIRED)
+
+ find_package(Lua)
+-set(USE_SYSTEM_Lua $<AND:$<BOOL:${PREFER_SYSTEM_Lua}>,$<BOOL:${LUA51_FOUND}>,$<NOT:$<BOOL:${WIN32}>>>)
++set(USE_SYSTEM_Lua $<AND:$<BOOL:${PREFER_SYSTEM_Lua}>,$<BOOL:${LUA_FOUND}>,$<NOT:$<BOOL:${WIN32}>>>)
+ if (NOT LUA_VERSION_STRING VERSION_LESS 5.2 AND LUA_VERSION_STRING VERSION_LESS 5.3)
+ add_definitions("-DLUA_COMPAT_ALL")
+ elseif (LUA_VERSION_STRING VERSION_GREATER_EQUAL "5.3")
+@@ -398,14 +398,30 @@ elseif(APPLE AND BUILD_MACOS_BUNDLE)
+ endif()
+
+ target_include_directories(xmoto
+- PRIVATE
+-
+- "${PROJECT_SOURCE_DIR}/src"
++ PRIVATE SYSTEM
++ "${Intl_INCLUDE_DIR}"
++ "${JPEG_INCLUDE_DIR}"
++ "${LIBLZMA_INCLUDE_DIR}"
+ "${LIBXML2_INCLUDE_DIR}"
++ "${OPENGL_INCLUDE_DIR}"
++ "${PNG_PNG_INCLUDE_DIR}"
++ "${SDL_INCLUDE_DIR}"
++ "${SDL_MIXER_INCLUDE_DIR}"
++ "${SDL_NET_INCLUDE_DIR}"
++ "${SQLITE3_INCLUDE_DIRS}"
++ "${ZLIB_INCLUDE_DIR}"
++ "$<${USE_SYSTEM_BZip2}:${BZIP2_INCLUDE_DIR}>"
+ "$<${USE_SYSTEM_Lua}:${LUA_INCLUDE_DIR}>"
+- "$<$<NOT:${USE_SYSTEM_Lua}>:${PROJECT_SOURCE_DIR}/vendor/lua/lua>"
++ "$<${USE_SYSTEM_ODE}:${ODE_INCLUDE_DIR}>"
++ "$<${USE_SYSTEM_XDG}:${XDG_INCLUDE_DIR}>"
+ )
+
++target_include_directories(xmoto
++ PRIVATE
++ "${PROJECT_SOURCE_DIR}/src"
++# "$<$<NOT:${USE_SYSTEM_Lua}>:${PROJECT_SOURCE_DIR}/vendor/lua/lua>"
++)
++
+ target_link_libraries(xmoto PUBLIC
+ $<$<PLATFORM_ID:Windows>:userenv>
+
+@@ -463,7 +479,9 @@ target_compile_definitions(xmoto PUBLIC MS_MKDIR=$<BOO
+
+ target_compile_definitions(xmoto PUBLIC USE_OPENGL=$<BOOL:${USE_OPENGL}>)
+ target_compile_definitions(xmoto PUBLIC USE_SDLGFX=$<BOOL:${USE_SDLGFX}>)
+-target_compile_definitions(xmoto PUBLIC USE_GETTEXT=$<BOOL:${USE_GETTEXT}>)
++if (USE_GETTEXT)
++ target_compile_definitions(xmoto PUBLIC USE_GETTEXT=1)
++endif()
+ target_compile_definitions(xmoto PUBLIC ALLOW_DEV=$<BOOL:${ALLOW_DEV}>)
+ target_compile_definitions(xmoto PUBLIC BUILD_MACOS_BUNDLE=$<BOOL:${BUILD_MACOS_BUNDLE}>)
+
diff --git a/games/xmoto/files/patch-src_common_Locales.cpp b/games/xmoto/files/patch-src_common_Locales.cpp
new file mode 100644
index 000000000000..92f912cdde8f
--- /dev/null
+++ b/games/xmoto/files/patch-src_common_Locales.cpp
@@ -0,0 +1,25 @@
+--- src/common/Locales.cpp.orig 2020-06-21 19:18:16 UTC
++++ src/common/Locales.cpp
+@@ -25,7 +25,9 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+ #include "helpers/Log.h"
+ #include "helpers/VExcept.h"
+ #include <iostream>
++#if USE_GETTEXT
+ #include <libintl.h>
++#endif
+
+ #define PACKAGE_LANG "xmoto"
+
+@@ -68,10 +70,12 @@ std::pair<std::string, std::string> Locales::changeLoc
+ #endif
+
+ /* Make change known. */
++#if USE_GETTEXT
+ {
+ extern int _nl_msg_cat_cntr;
+ ++_nl_msg_cat_cntr;
+ }
++#endif
+
+ std::pair<std::string, std::string> locale_str(
+ locale.first == NULL ? std::string("") : std::string(locale.first),
diff --git a/games/xmoto/pkg-plist b/games/xmoto/pkg-plist
index b7f23819d4eb..78f9801d980d 100644
--- a/games/xmoto/pkg-plist
+++ b/games/xmoto/pkg-plist
@@ -1,28 +1,27 @@
bin/xmoto
-man/man6/xmoto.6.gz
-%%NLS%%share/locale/ca_AD/LC_MESSAGES/xmoto.mo
+share/applications/xmoto.desktop
%%NLS%%share/locale/ca_ES/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/ca_FR/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/ca_IT/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/cs_CZ/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/da_DK/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/de_DE/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/es_ES/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/fi_FI/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/fr_FR/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/gl_ES/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/hu_HU/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/it_IT/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/lt_LT/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/lv_LV/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/nb_NO/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/nl_NL/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/nn_NO/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/pl_PL/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/pt_PT/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/ru_RU/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/sk_SK/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/sv_SE/LC_MESSAGES/xmoto.mo
-%%NLS%%share/locale/tr_TR/LC_MESSAGES/xmoto.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xmoto.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xmoto.mo
+share/man/man6/xmoto.6.gz
+share/pixmaps/xmoto.xpm