aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-17 16:27:49 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-17 16:30:15 +0000
commit9b178ffd7e2fd77fecb8c80d22f7c80bc9e93977 (patch)
treeb360bb8359894fe0da8a0f81ea62594442d1436c /games
parentdba2ffb1db8db7c1d11cff8257e54464cee1ec58 (diff)
downloadports-9b178ffd7e2fd77fecb8c80d22f7c80bc9e93977.tar.gz
ports-9b178ffd7e2fd77fecb8c80d22f7c80bc9e93977.zip
*/*: llvm15 build fixes
llvm15 was also merged into 13.2-STABLE effective from OSVERSION 1302505. Fix the ports that failed to build with llvm15. Approved by: portmgr (blanket)
Diffstat (limited to 'games')
-rw-r--r--games/libretro-bluemsx/Makefile2
-rw-r--r--games/libretro-mame2000/Makefile2
-rw-r--r--games/libretro-mame2003_plus/Makefile2
-rw-r--r--games/spellcast/Makefile2
-rw-r--r--games/tuxmath/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/games/libretro-bluemsx/Makefile b/games/libretro-bluemsx/Makefile
index 451f6b608347..3197bb9b96a1 100644
--- a/games/libretro-bluemsx/Makefile
+++ b/games/libretro-bluemsx/Makefile
@@ -19,7 +19,7 @@ PLIST_FILES= lib/libretro/bluemsx_libretro.so
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
diff --git a/games/libretro-mame2000/Makefile b/games/libretro-mame2000/Makefile
index 2932af3207c4..10661009ae88 100644
--- a/games/libretro-mame2000/Makefile
+++ b/games/libretro-mame2000/Makefile
@@ -22,7 +22,7 @@ PLIST_FILES= lib/libretro/mame2000_libretro.so
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
diff --git a/games/libretro-mame2003_plus/Makefile b/games/libretro-mame2003_plus/Makefile
index eeb4d606b206..c4a8f579fe47 100644
--- a/games/libretro-mame2003_plus/Makefile
+++ b/games/libretro-mame2003_plus/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= lib/libretro/mame2003_plus_libretro.so
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
diff --git a/games/spellcast/Makefile b/games/spellcast/Makefile
index ac996cda9ce5..6e3b9410a498 100644
--- a/games/spellcast/Makefile
+++ b/games/spellcast/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index 41c71aaa016f..4041dfd6ebe0 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -53,7 +53,7 @@ SVG_CONFIGURE_WITH= rsvg
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif