aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-20 05:10:25 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-05-20 05:10:25 +0000
commit9b686acb9f876925f4e7b46076f0cc77ca277508 (patch)
treecad51ecc81b73c705ed8b3058290243fe8d6a60b /games
parenta2e3d8c958bf2fa32b0619e3f20385ba426a192a (diff)
downloadports-9b686acb9f876925f4e7b46076f0cc77ca277508.tar.gz
ports-9b686acb9f876925f4e7b46076f0cc77ca277508.zip
[NEW PORT] games/libretro-mu: PalmOS emulator to the libretro API
Mu is a PalmOS emulator core for libretro compatible emulators, such as games/retroarch. PR: 246148 Submitted by: menelkir@itroll.org Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D24863
Notes
Notes: svn path=/head/; revision=535968
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/libretro-mu/Makefile29
-rw-r--r--games/libretro-mu/distinfo3
-rw-r--r--games/libretro-mu/files/patch-Makefile.freebsd5
-rw-r--r--games/libretro-mu/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 07f45cc5fcf9..d6bdfb52c890 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -502,6 +502,7 @@
SUBDIR += libretro-mame2003
SUBDIR += libretro-mame2003_plus
SUBDIR += libretro-mgba
+ SUBDIR += libretro-mu
SUBDIR += libretro-nestopia
SUBDIR += libretro-nxengine
SUBDIR += libretro-o2em
diff --git a/games/libretro-mu/Makefile b/games/libretro-mu/Makefile
new file mode 100644
index 000000000000..aacc435b6341
--- /dev/null
+++ b/games/libretro-mu/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libretro-mu
+PORTVERSION= 0.20200504
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= PalmOS emulator to the libretro API
+
+LICENSE= GPLv3 MIT
+LICENSE_COMB= multi
+
+USES= compiler:c++11-lib gmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= Mu
+GH_TAGNAME= 4ac4068
+
+PLIST_FILES= lib/libretro/mu_libretro.so
+
+MAKEFILE= Makefile.freebsd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${INSTALL_LIB} ${WRKSRC}/libretroBuildSystem/mu_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+
+.include <bsd.port.mk>
diff --git a/games/libretro-mu/distinfo b/games/libretro-mu/distinfo
new file mode 100644
index 000000000000..3324cfddcf56
--- /dev/null
+++ b/games/libretro-mu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588720451
+SHA256 (libretro-Mu-0.20200504-4ac4068_GH0.tar.gz) = 494e8bd382ff099342c7aa2eae8f6292705bcc0476e8c271bfbe331ba2d1a9a4
+SIZE (libretro-Mu-0.20200504-4ac4068_GH0.tar.gz) = 1152461
diff --git a/games/libretro-mu/files/patch-Makefile.freebsd b/games/libretro-mu/files/patch-Makefile.freebsd
new file mode 100644
index 000000000000..92903057d253
--- /dev/null
+++ b/games/libretro-mu/files/patch-Makefile.freebsd
@@ -0,0 +1,5 @@
+--- Makefile.freebsd.orig 2020-05-03 19:06:09 UTC
++++ Makefile.freebsd
+@@ -0,0 +1,2 @@
++all:
++ cd libretroBuildSystem && ${MAKE}
diff --git a/games/libretro-mu/pkg-descr b/games/libretro-mu/pkg-descr
new file mode 100644
index 000000000000..145efab5e521
--- /dev/null
+++ b/games/libretro-mu/pkg-descr
@@ -0,0 +1,3 @@
+Palm OS emulator for libretro API
+
+WWW: https://github.com/libretro/Mu