aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 19:56:11 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-13 19:56:11 +0000
commita27b54553fe42ebf827e2623e32b9d094e5a336a (patch)
tree25d3d250190c1c0aa4407acc9423daa3a5913b25 /games
parent454976ca10daaac69ae0a106df07c1c47b723143 (diff)
downloadports-a27b54553fe42ebf827e2623e32b9d094e5a336a.tar.gz
ports-a27b54553fe42ebf827e2623e32b9d094e5a336a.zip
- Convert LIB_DEPENDS to new syntax
- Add DOCS option - Add stage support
Notes
Notes: svn path=/head/; revision=333721
Diffstat (limited to 'games')
-rw-r--r--games/xmastermind/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/games/xmastermind/Makefile b/games/xmastermind/Makefile
index 2c34d0a321cf..bb87fde715e5 100644
--- a/games/xmastermind/Makefile
+++ b/games/xmastermind/Makefile
@@ -12,7 +12,7 @@ COMMENT= Mastermind game for X Window System
LICENSE= GPLv2
-LIB_DEPENDS= forms:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= libforms.so:${PORTSDIR}/x11-toolkits/xforms
USE_XORG= x11 xpm
MAKE_ENV= GRAPHLIBS="${LDFLAGS}"
@@ -23,7 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib -lforms -lXpm -lX11
PORTDOCS= BUGS README.for.developers README.for.users
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
'/^CC/s| =| ?=| ; \
@@ -32,15 +33,11 @@ post-patch:
@${REINPLACE_CMD} -e \
's|malloc.h|stdlib.h|' ${WRKSRC}/list.h
-.include <bsd.port.options.mk>
-
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
.include <bsd.port.mk>