aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-16 14:38:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-16 20:33:10 +0000
commita507658b9701e52d3fad928e3668e6c138ded393 (patch)
tree96234a40ab738c69850444802f0247042a76f33e /games
parent81a9c9cf783e481ef271db9a5693844f77fa7f1b (diff)
downloadports-a507658b9701e52d3fad928e3668e6c138ded393.tar.gz
ports-a507658b9701e52d3fad928e3668e6c138ded393.zip
games/mari0: update 1.6 → 1.6.2
- Switch to GitHub - Switch to latest love
Diffstat (limited to 'games')
-rw-r--r--games/mari0/Makefile34
-rw-r--r--games/mari0/distinfo6
-rw-r--r--games/mari0/files/mari0.in2
3 files changed, 14 insertions, 28 deletions
diff --git a/games/mari0/Makefile b/games/mari0/Makefile
index 8fae1ff1877f..e1b99a430292 100644
--- a/games/mari0/Makefile
+++ b/games/mari0/Makefile
@@ -1,53 +1,39 @@
# Created by: Mahdi Mokhtari <mokhi64@gmail.com>
PORTNAME= mari0
-PORTVERSION= 1.6
-PORTREVISION= 3
+PORTVERSION= 1.6.2
CATEGORIES= games
-MASTER_SITES= http://stabyourself.net/dl.php?file=${PORTNAME}-${PORTVERSION:C/\./00/}/
-DISTNAME= ${PORTNAME}-source
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Nintendo\'s Super Mario Bros and Valve\'s Portal at same time
LICENSE= CC-BY-NC-SA-3.0
-RUN_DEPENDS= love08:devel/love08
+RUN_DEPENDS= love:devel/love
-USES= zip
+USE_GITHUB= yes
+GH_ACCOUNT= Stabyourself
NO_BUILD= yes
NO_ARCH= yes
SUB_FILES= ${PORTNAME}
SUB_LIST+= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
-PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.gif
-PORTDOCS= *
+PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.png
PORTDATA= *
DESKTOP_ENTRIES="Mari0" \
"" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.gif" \
+ "mari0" \
"${PORTNAME}" \
"Game;ArcadeGame;" \
""
-OPTIONS_DEFINE= DOCS
-
-post-extract:
- @cd ${WRKDIR} && ${EXTRACT_CMD} ${PORTNAME}_${PORTVERSION}.love >/dev/null 2>&1
-
do-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${PORTVERSION}.love \
- ${STAGEDIR}${DATADIR}/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/ \
+ '-not -name README.md -not -name \.*'
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKDIR}/graphics/icon.gif \
- ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.gif
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/readme.txt ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/graphics/icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/games/mari0/distinfo b/games/mari0/distinfo
index 887d93018f83..b340ec608c64 100644
--- a/games/mari0/distinfo
+++ b/games/mari0/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484752394
-SHA256 (mari0-1.6/mari0-source.zip) = b217134425527e879d5355eb7f51e29a60ad0e93550e5769b2f56c04a1f69037
-SIZE (mari0-1.6/mari0-source.zip) = 3625226
+TIMESTAMP = 1647440228
+SHA256 (Stabyourself-mari0-1.6.2_GH0.tar.gz) = 90e880156f24290f910c29952b25cd43c4ee5ce673fe443543747a23e1ac2f5d
+SIZE (Stabyourself-mari0-1.6.2_GH0.tar.gz) = 3508539
diff --git a/games/mari0/files/mari0.in b/games/mari0/files/mari0.in
index 84ac5d4ecdb3..8cfdb3aa0796 100644
--- a/games/mari0/files/mari0.in
+++ b/games/mari0/files/mari0.in
@@ -1,3 +1,3 @@
#!/bin/sh
-exec %%LOCALBASE%%/bin/love08 %%DATADIR%%/mari0_%%PORTVERSION%%.love "$@"
+exec %%LOCALBASE%%/bin/love %%DATADIR%% "$@"