aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-05 19:39:46 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-05 19:39:46 +0000
commitb39d6c6fb4911fbe4cf3c93b326382a3dc1a0cea (patch)
tree3ab6884e88fa3e622154666238cabd6c6b5cc369 /games
parentf544624201cc27872d4fa0a5279fe168803abe66 (diff)
downloadports-b39d6c6fb4911fbe4cf3c93b326382a3dc1a0cea.tar.gz
ports-b39d6c6fb4911fbe4cf3c93b326382a3dc1a0cea.zip
games/frotz: update to 2.50
- give maintainership to David Griffith <bugs@661.org> Frotz 2.50 was released on Tuesday November 12, 2019. NEW FEATURES - Added UTF-8 input and output. Plain ASCII is still available. - Added -L option for restoring save file directly from the command line. - Added -R option for restricted read/write path. - Sound effects in AIFF, MOD, and OGG formats supported per the Blorb specs. - Sound driver selection is automated through the use of libao. - Allow for an alternative Blorb file to be specified on the command line. BUG FIXES - Overhauled MacOS compilation. - Corrected problems with error handling. - Fixed a lot of unsafe strcpy() and strcat() calls. - Fixed numerous problems with portability to other flavors of Unix. - Fixed adaptive palette rendering for SDL. - Fixed scaling with manually specified window dimensions. - Fixed problem with unnecessary newlines with input timeouts. - Allow fontdir in .sfrotzrc to work relative to user's home directory. - Fixed problem with memory allocation leading to crashes in DOS. - Fixed problem with DOS Frotz creating non-portable Quetzal files. PR: 242821 Submitted by: David Griffith <bugs@661.org>
Notes
Notes: svn path=/head/; revision=522166
Diffstat (limited to 'games')
-rw-r--r--games/frotz/Makefile24
-rw-r--r--games/frotz/distinfo5
-rw-r--r--games/frotz/files/patch-Makefile11
-rw-r--r--games/frotz/files/patch-src_curses_ux__audio__oss.c20
-rw-r--r--games/frotz/pkg-descr10
5 files changed, 30 insertions, 40 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index 3017e68492e7..009861397e51 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -2,41 +2,39 @@
# $FreeBSD$
PORTNAME= frotz
-PORTVERSION= 2.44
+PORTVERSION= 2.50
CATEGORIES= games
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Infocom games interpreter
+MAINTAINER= dave@661.org
+COMMENT= Infocom Z-machine games interpreter
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GITHUB= yes
-GH_ACCOUNT= DavidGriffith
+USE_GITLAB= yes
+GL_ACCOUNT= DavidGriffith
+GL_COMMIT= 9867a1f14da1e9c0707492d2ac74d1e8ffdd3a64
USES= gmake ncurses
-MAKE_ARGS= -e CURSES="${LDFLAGS} -lncurses"
MAKE_ENV= OPTS="${CFLAGS}" CONFIG_DIR="${PREFIX}/etc"
+ALL_TARGET= nosound dumb
+INSTALL_TARGET= frotz
+
PLIST_FILES= bin/frotz \
man/man6/frotz.6.gz
-PORTDOCS= AUTHORS BUGS ChangeLog HOW_TO_PLAY README
+PORTDOCS= AUTHORS ChangeLog HOW_TO_PLAY README
PORTEXAMPLES= frotz.conf-big frotz.conf-small
-OPTIONS_DEFINE= DOCS EXAMPLES DUMB OSS
-OPTIONS_DEFAULT= OSS
+OPTIONS_DEFINE= DOCS EXAMPLES DUMB
DUMB_DESC= Install dfrotz (dumb frotz)
-OSS_MAKE_ENV= SOUND_DEFS='-DOSS_SOUND -DSOUND_DEV=\"/dev/dsp\"'
DUMB_PLIST_FILES= bin/dfrotz \
man/man6/dfrotz.6.gz
DUMB_PORTDOCS= DUMB
-pre-build-OSS-on:
- cd ${WRKSRC} && ${DO_MAKE_BUILD} soundcard.h
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
diff --git a/games/frotz/distinfo b/games/frotz/distinfo
index 9e602638a037..d7a4b6f53888 100644
--- a/games/frotz/distinfo
+++ b/games/frotz/distinfo
@@ -1,2 +1,3 @@
-SHA256 (DavidGriffith-frotz-2.44_GH0.tar.gz) = dbb5eb3bc95275dcb984c4bdbaea58bc1f1b085b20092ce6e86d9f0bf3ba858f
-SIZE (DavidGriffith-frotz-2.44_GH0.tar.gz) = 276815
+TIMESTAMP = 1576709471
+SHA256 (DavidGriffith-frotz-9867a1f14da1e9c0707492d2ac74d1e8ffdd3a64_GL0.tar.gz) = 0fdbf055edd31e2f07b52f720a74a098d81b766a00a4103955edb2171d13b0d6
+SIZE (DavidGriffith-frotz-9867a1f14da1e9c0707492d2ac74d1e8ffdd3a64_GL0.tar.gz) = 346458
diff --git a/games/frotz/files/patch-Makefile b/games/frotz/files/patch-Makefile
new file mode 100644
index 000000000000..f682f121ca69
--- /dev/null
+++ b/games/frotz/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2019-12-18 22:55:03 UTC
++++ Makefile
+@@ -297,7 +297,7 @@ ifneq ($(and $(wildcard $(GIT_DIR)),$(sh
+ $(NAME)src/doc/*.6 $(NAME)src/doc/frotz.conf* \
+ $(NAME)src/doc/Xresources > /dev/null
+ else
+- @echo "Not in a git repository or git command not found. Cannot make a tarball."
++ @echo "Not in a git repository or git command not found. Cannot make a tarball."
+ endif
+
+ all: $(FROTZ_BIN) $(DFROTZ_BIN) $(SFROTZ_BIN)
diff --git a/games/frotz/files/patch-src_curses_ux__audio__oss.c b/games/frotz/files/patch-src_curses_ux__audio__oss.c
deleted file mode 100644
index b40b5db55367..000000000000
--- a/games/frotz/files/patch-src_curses_ux__audio__oss.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/curses/ux_audio_oss.c.orig 2014-03-06 06:08:15 UTC
-+++ src/curses/ux_audio_oss.c
-@@ -80,7 +80,7 @@ static void sigterm_handler(int signal)
- _exit(0);
- }
-
--static void sigint_handler(int signal) {
-+static void oss_sigint_handler(int signal) {
- num_repeats = 1;
- }
-
-@@ -141,7 +141,7 @@ static void play_sound(int volume, int r
- sigaddset(&sa.sa_mask, SIGTERM);
- sa.sa_flags = 0;
- sigaction(SIGTERM, &sa, NULL);
-- sa.sa_handler = sigint_handler;
-+ sa.sa_handler = oss_sigint_handler;
- sigaction(SIGINT, &sa, NULL);
-
- for (num_repeats = repeats; num_repeats > 0;
diff --git a/games/frotz/pkg-descr b/games/frotz/pkg-descr
index a31a0ac7e7c6..7a6dd78f6404 100644
--- a/games/frotz/pkg-descr
+++ b/games/frotz/pkg-descr
@@ -2,9 +2,9 @@ An interpreter for all Infocom games. Complies with standard
1.0 of Graham Nelson's specification. Frotz runs text adventures
which come in so-called story files: ZORK1.DAT, TRINITY.DAT,
CURSES.Z5, JIGSAW.Z8, ARTHUR.ZIP etc. It is possible to play
-Atari ST, Amiga or Macintosh games on your PC once you manage
-to transfer the story files. There is an increasing number
-of new games available on the Internet. Check the if-archive
-at ftp.ifarchive.org.
+Atari ST, Amiga or Macintosh games on your computer once you
+manage to transfer the story files. There is an increasing
+number of new games available on the Internet. Check the
+if-archive at http://ifarchive.org/
-WWW: https://github.com/DavidGriffith/frotz
+WWW: https://gitlab.com/DavidGriffith/frotz