aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2007-01-21 21:38:30 +0000
committerPeter Pentchev <roam@FreeBSD.org>2007-01-21 21:38:30 +0000
commitc9171663d544a04dabba2e2f13b805d910ac50cb (patch)
tree1b663519b10234b8dbf0acbc31f0a6e9c1db2c35 /games
parent68171b19384f34bc18cc4fe1a12e6774e699b2f5 (diff)
downloadports-c9171663d544a04dabba2e2f13b805d910ac50cb.tar.gz
ports-c9171663d544a04dabba2e2f13b805d910ac50cb.zip
Update to scare-1.3.5 and add a "test" target.
Notes
Notes: svn path=/head/; revision=182920
Diffstat (limited to 'games')
-rw-r--r--games/scare/Makefile7
-rw-r--r--games/scare/distinfo6
-rw-r--r--games/scare/files/no-xglk.patch6
-rw-r--r--games/scare/files/patch-Makefile16
-rw-r--r--games/scare/files/patch-os_glk.c4
-rw-r--r--games/scare/files/xglk.patch6
6 files changed, 21 insertions, 24 deletions
diff --git a/games/scare/Makefile b/games/scare/Makefile
index f265ae62db1d..9d87763c77b9 100644
--- a/games/scare/Makefile
+++ b/games/scare/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scare
-PORTVERSION= 1.3.4
+PORTVERSION= 1.3.5
CATEGORIES= games
MASTER_SITES= ftp://ftp.ifarchive.org/if-archive/programming/adrift/ \
http://www.geocities.com/legion_if/
@@ -42,6 +42,9 @@ EXTRA_PATCHES= ${FILESDIR}/no-xglk.patch
PLIST_FILES= ${BINFILES:S,^,bin/,}
do-install:
- ${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/,} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/source/,} ${PREFIX}/bin/
+
+test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
.include <bsd.port.post.mk>
diff --git a/games/scare/distinfo b/games/scare/distinfo
index cf72c082e860..ad072c67e967 100644
--- a/games/scare/distinfo
+++ b/games/scare/distinfo
@@ -1,3 +1,3 @@
-MD5 (scare-1.3.4.zip) = 82fc641ba6a92b933f9bd53f4963b9b9
-SHA256 (scare-1.3.4.zip) = fa93cb5f8cd35facad027d08ac898c569b4b60aecac038acacb7b7e6fb9218b1
-SIZE (scare-1.3.4.zip) = 633157
+MD5 (scare-1.3.5.zip) = 1f26a09440f2fc180ac6435c47a0a6e5
+SHA256 (scare-1.3.5.zip) = 8b65d60591b6db6618ce35ef027e4d2c51fda1362b1d74632e74f62571ac8722
+SIZE (scare-1.3.5.zip) = 1305393
diff --git a/games/scare/files/no-xglk.patch b/games/scare/files/no-xglk.patch
index 13a6928f0fd8..2111fd497104 100644
--- a/games/scare/files/no-xglk.patch
+++ b/games/scare/files/no-xglk.patch
@@ -1,6 +1,6 @@
---- Makefile Fri Feb 4 22:09:46 2005
-+++ Makefile.noglk Fri Feb 4 22:09:33 2005
-@@ -68,8 +68,9 @@
+--- source/Makefile Sun Jan 21 23:18:36 2007
++++ source/Makefile.noglk Sun Jan 21 23:21:08 2007
+@@ -73,8 +73,9 @@
# If your make can't handle sinclude or -include, and you're not building
# for Glk, comment out the include line.
GLKPATH = $(GLKDIR)/$(GLK)
diff --git a/games/scare/files/patch-Makefile b/games/scare/files/patch-Makefile
index 66a07d9dc13d..52cfbf3040e9 100644
--- a/games/scare/files/patch-Makefile
+++ b/games/scare/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Sep 26 21:47:00 2006
-+++ Makefile Tue Sep 26 21:49:23 2006
+--- source/Makefile.old Sun Jan 21 23:16:03 2007
++++ source/Makefile Sun Jan 21 23:18:36 2007
@@ -26,18 +26,19 @@
#
@@ -11,7 +11,7 @@
+CC ?= gcc
+DEBUG ?=
+CEXTRA ?=
-+CFLAGS ?= -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
++CFLAGS ?= -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
-pedantic -Wshadow -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations -Wredundant-decls \
-Wwrite-strings -Wundef -Wbad-function-cast -Waggregate-return \
@@ -21,28 +21,22 @@
-LDEXTRA =
-LDFLAGS = $(DEBUG) $(LDEXTRA)
+ $(DEBUG)
-+CFLAGS += $(CEXTRA)
++CFLAGS += $(CEXTRA)
+LDLIBS ?=
+LDEXTRA ?=
+LDFLAGS ?= $(DEBUG) $(LDEXTRA)
# Generic compiler and linker flags.
#CC = cc
-@@ -79,12 +80,12 @@
+@@ -79,9 +80,9 @@
SHELL = /bin/sh
# Miscellaneous tools, overridable by the command line.
--ZIP = zip
-UNZIP = unzip
-RM = rm
--LN = ln
--TAR = tar
-TEST = test
-+ZIP ?= zip
+UNZIP ?= unzip
+RM ?= rm
-+LN ?= ln
-+TAR ?= tar
+TEST ?= test
# SCARE objects and headers.
diff --git a/games/scare/files/patch-os_glk.c b/games/scare/files/patch-os_glk.c
index 4f53fcd59c80..5d70a7ead120 100644
--- a/games/scare/files/patch-os_glk.c
+++ b/games/scare/files/patch-os_glk.c
@@ -1,5 +1,5 @@
---- os_glk.c.orig Tue Sep 26 21:50:17 2006
-+++ os_glk.c Tue Sep 26 21:55:13 2006
+--- source/os_glk.c.orig Tue Sep 26 21:50:17 2006
++++ source/os_glk.c Tue Sep 26 21:55:13 2006
@@ -1110,6 +1110,8 @@
&& gsclinux_graphics_enabled && glk_gestalt (gestalt_Graphics, 0))
{
diff --git a/games/scare/files/xglk.patch b/games/scare/files/xglk.patch
index 8f92bb477e9f..ef555fe6d738 100644
--- a/games/scare/files/xglk.patch
+++ b/games/scare/files/xglk.patch
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Sep 26 22:15:12 2006
-+++ Makefile Tue Sep 26 22:17:36 2006
+--- source/Makefile Sun Jan 21 23:22:38 2007
++++ source/Makefile.xglk Sun Jan 21 23:23:11 2007
@@ -73,7 +73,7 @@
# If your make can't handle sinclude or -include, and you're not building
# for Glk, comment out the include line.
@@ -9,7 +9,7 @@
GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
# Always use the Bourne shell.
-@@ -127,7 +127,7 @@
+@@ -134,7 +134,7 @@
os_glk.o: os_glk.c $(HEADERS)
$(CC) $(GLKARCH) $(CFLAGS) -Wno-write-strings \